Singlecore Turboproblem (nicht nur) beim Haswell-E

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
Ich möchte diesen Thread nutzen um einem Problem auf die Spur zu kommen das hier im Forum schon ein paar User beim neuen Haswell-E aufgefallen ist, ich mittlerweile zufällig aber auch beim Sandy-E bemerkt habe: Die CPUs takten bei Last auf nur einem Thread nicht voll hoch.

Da dieses Thema im S2011 OC Thread ein wenig unterzugehen droht würde ich gerne versuchen die Problematik hier im Thread aufzuarbeiten, vielleicht ist es so möglich ausreichend Fakten und Erfahrungen zusammen zu tragen um der tatsächlichen Ursache des Problems auf die Spur zu kommen statt uns nur mit Workarounds zu behelfen.

Das Problem kurz umrissen am Beispiel meines Systems (3930k @ 6x 4,5 GHz, Asus Rampage IV Formula:
Bei voller Last auf nur einem Thread (im Prinzip aber bis rauf auf 5 Threads) taktet die CPU nur bis auf 4,2 GHz hoch.
Bei voller Last auf allen 12 Threads (reproduzierbar ab 6 Threads aufwärts) taktet die CPU korrekt bis auf 4,5 GHz hoch.

Aufgefallen ist das Problem meiner Kenntnis nach zuerst ein paar Besitzern von X99 Systemen, mir war beim Zocken mit CPU Takt im OSD aber zufällig aufgefallen, und ich konnte dann auch reproduzierbar nachvollziehen, dass das Problem bei meinem X79 System ebenfalls auftritt.

Es gab einige Vermutungen die Problematik könnte mit dem verwendeten Betriebssystem zusammen hängen, das kann ich nach meinen Tests mit Windows 7, Windows 8.1 und Windows 10 (jeweils 64-Bit) jedoch nicht nachvollziehen.

Was definitiv hilft ist den Energiesparplan "Höchstleistung" zu verwenden da die minimale CPU-Leistung hier mit 100% angegeben ist, die CPU läuft dann dauerhaft auf vollem Takt (bei mir also 4,5 GHz).

Eine Vermutung die im Raum steht ist dass Windows die C-States falsch ansteuert da ggf die CPU-Last falsch ermittelt wird. Das ist IMHO die bisher heißeste Spur.

In Reviews liest man von diesem Problem im allgemeinen nichts, allerdings wird hier gerade wenn es um die Performace geht vermutlich oft mit dem Energiesparplan "Höchstleistung" gearbeitet.
Ich meine mich aber an einen Test der Haswell-EP Plattform in der c't zu erinnern in der das Problem auch aufgefallen ist.

Vermutete Zusammenhänge:
  • Verwendete Windows-Version (Nein)
  • BIOS (?)
  • Energiesparplan (Ja)
  • Windows steuert die C-States grundsätzlich falsch (?)
  • Takt-Auslesefehler (Nein)

Links:
Hier mal die Links zu ein paar aufs Thema bezogenen Posts:
http://extreme.pcgameshardware.de/m...7-5820k-schlechte-single-core-leistung-3.html
http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-402.html#post22643538
http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-410.html#post22693645
http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-417.html#post22716453
http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-418.html#post22725790
http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-424.html#post22736975
http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-428.html#post22741022 (dieser Lösungsansatz funktioniert!)

Lösung:
"Santa" hat einen interessanten und bei mir funktionierenden Lösungsansatz geliefert: Das Energiesparprofil "Höchstleistung" aktivieren, bearbeiten und die minimale CPU-Leistung wie im "Ausgeglichen" auf 5 % herunter setzen.
Die CPU taktet jetzt im Idle auf 1,2 GHz runter und unter Last auf einem Thread sofort auf 4,5 GHz hoch.
Sie scheint auch insgesamt "spritziger" zu agieren da der Takt bei untätigem System öfter weiter in die Höhe springt.

So jetzt hoffe ich auf euer Feedback.
 
Zuletzt bearbeitet:
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
Da ich ja auch schon so einiges zu dem Thema geschrieben habe im Sockel 2011 Laberthread, auch mal mein Senf dazu:
Man muss meiner Ansicht nach zwischen Sandy und Haswell-E unterscheiden. Es mögen beide das Problem haben aber Haswell-E Taktet alle Kerne einzeln. Das macht Sandy meines Wissens nach nicht.

Somit gibt es im Prinzip zwei Problemsituationen:
Haswell-E:
Ein Programm erzeugt Singlecorelast (System Windows 7). Sofern der Prozess auf einem virtuellen Kern läuft, taktet der physische Kern hoch und man sieht volle Geschwindigkeit. Die Regel ist aber, dass der Windows Scheduler einen Prozess nicht nur auf einem Kern laufen lässt. Da kommen ja auch ganz viele andere Prozesse und hätten gern auch CPU Zeit, also switcht der Scheduler den Prozess ständig zwischen verschiedenen Kernen hin und her (nach welcher Logik bitte die Windows Entwickler fragen). Desto mehr in der Schlange stehen und in kurzen Intervallen CPU Zeit wollen, desto mehr wird geswitcht. Das lässt sich sehr gut reproduzieren, wenn man z.B. HWInfo64 aufruft (das zeigt in kurzen Zeitabständen den Multi aller CPU-Kerne an - jede Auffrischung benötigt kurz die Aufmerksamkeit der CPU). Während HWInfo im Hintergrund läuft,g startet man SuperPi. Das Ergebnis unter Windows 7 ist, dass je nach Anzahl und CPU Konsum der weiteren Prozesse ein SuperPi Lauf, der mit einem 4790K bei gleichem Takt 7,5 Minuten gedauert hat, auch mal gerne 12 Minuten dauert!

Gleiches Szenario mit HyperPi (das nagelt den Prozess an einen Kern fest). Somit bekommt man die volle Performanz. Auf dem Kern sollte man dann aber kein anderes Programm festpinnen. Festpinnen kann man z.B. über einen entsprechenden Befehl beim Aufruf von Programmen oder im Taskmanager.

Bei Windows 10 habe ich den selben Test gemacht wie in Windows 7 - dort war die Zeit für SuperPi 32M aber bei ca. 8 Minuten - also viel besser als die Zeit, die ich bei gleichzeitig laufendem HWInfo64 in Windows 7 zu sehen bekommen habe, obwohl ich (soweit möglich) viele Anwendungen installiert habe, die ich auch in Windows 7 nutze. Weiterhin war in Windows 10 sichtbar, dass der maximale Turbo auf einem Kern sehr häufig anlag (fast immer, soweit man das optisch beurteilen kann). In Windows 7 war das selten bis überhaupt nicht der Fall (auch wieder abhängig von den weiteren laufenden Prozessen). Ich habe sowohl ein Windows 7 getestet, dass frisch aufgesetzt wurde, als auch eins, dass ich schon mit dem 4790K benutzt habe. Beide hatten aktuelle Inf Treiber von Intel an Bord.

Das Problem besteht bei allen ungeraden Kernlasten also 1,3,5,7,9,11 (der letzte Kern ist bestenfalls teilweise im Turbo - wie viel teilweise ist hängt davon ab, wie viel Prozesse sich um den virtuellen Kern streiten. Bei Last auf zwei virtuellen Kernen, geht ein Physischer relativ dauerhaft hoch (ist aber auch wieder abhängig davon was sonst noch läuft, je weniger Konkurrenz, desto besser)

Windows 8(.1) habe ich nicht aber von einem anderen User gehört, dass dort das Problem wie in Windows 7 auftritt.

Sandy:
Das System habe ich nicht und hatte ich nicht. Da kann ich nur vermuten. Ich vermute, dass dort dass Problem ist, dass eine gewisse Mindestlast über alle Kerne vorliegen muss (nach obiger Beschreibung quasi über alle), bevor der übergreifende Turbo gezündet wird.

Die sogenannten "Lösungsansätze" sind aus meiner Sicht leider bestenfalls Workarounds, die eine eh schon schlechten Idle Verbrauch von Haswell-E noch weiter versauen, weil sie die Zwischenstufen zwischen min und max deaktivieren.

Ansatz 1: Minimale Prozessorleistung 100% (der Energiesparplan ist egal, die Einstellung minimale Prozessorleistung reicht)
Ansatz 2: Speedstep aus (dann gibt's nur noch min max)

Beides versaut den Stromverbrauch total. Interessant ist aber, dass ich zwischendurch nach Installation aller Treiber / Programme zum Board automatisch die 100% da stehen hatte und mich über den hohen Idleverbrauch Gewundert habe. Im Kontext der o.g. Thematik mag das Absicht gewesen sein. Ich weiß aber nicht durch welches Programm oder welchen Treiber dieser Wert gesetzt wurde. Müsste ich mal testen. Ich vermute mal durch das ASRock Boardutility - dort kann man nämlich sparsam und maximale Leistung einstellen.

Fazit aus meiner Sicht aktuell: Wenn man Singlecoreprogramme fährt, muss man die bei Haswell-E festpinnen - das ist quasi unmöglich, da man dafür erst mal alle Singlecoreprogramme kennen muss und die auch noch jedes mal manuell festpinnen muss (geht auch über Batch Startaufruf mit Kernnummer aber dann darf man niemals zwei mit dem selben Kern gleichzeitig starten). Dann müsste man quasi eine Liste neben dem Rechner haben was darf ich in welcher Kombination starten oder nicht starten. Super...

Oder für Sandy und Haswell-E man nimmt den mindestens 4x Idleverbrauch von Haswell ohne E in Kauf für weniger Leistung ... (Stichworte: Speedstep aus oder Minimalleistung 100%). Das ist vorsintflutlich...

Aber echt traurig, dass das keinem Tester aufgefallen ist (oder haben die weggesehen, damit man beim nächsten Test auch wieder schön mit Board und CPU versorgt wird?) ...

Kontaktiert habe ich bisher ASRock. Die haben aber meiner Meinung nach das Problem nicht wirklich verstanden und ich hatte auch nicht den Eindruck dort mit besonders qualifizierten Supportmitarbeitern zu tun zu haben. Die wollten mir zuerst erklären, dass Powerlimits das Problem sind - dass dann aber alle Kerne gleichzeitig trotz angeblichem Powerlimit hochtakten, konnten sie mir nicht erklären. Als nächstes wurde mir dann erklärt, dass meine Monitoringtools nur falsch anzeigen und als drittes, dass es bei deren Windows Installation das Problem nicht gibt. Seit fast 3 Wochen habe ich von denen aber auch keine Antwort mehr erhalten - die ignorieren meine Mails unterdessen einfach. Angeblich wollten Sie Intel kontaktieren.

Ansonsten habe ich noch den c't Redakteur angesprochen, der den aktuellen X99 Test durchgeführt hat. Ihm war das Problem neu und er tippt darauf, dass es ein Windows Problem ist und dort behoben werden muss. Er meinte, dass er versucht bei Intel was raus zu bekommen.

Tja, da sind wir wieder in Zeiten der Turbo Taste von 1995 angekommen ...
 
Zuletzt bearbeitet:

fdsonne

Moderator
Hardwareluxx Team
Mitglied seit
08.08.2006
Beiträge
36.267
Ort
SN
Was mir spontan dazu einfällt. Hast du bzw. habt ihr mal das hier probiert?
How to launch a process with CPU affinity set - Debugging Internet - Site Home - MSDN Blogs

Damit lassen sich die Tasks direkt mit angepinnter CPU-Core Anzahl starten, tritt das Problem dann immernoch auf?
Zu Core2Quad Zeiten war das ganze ja bspw. auch Thema, nur hatte es dort einen etwas anderen Hintergrund. Dass nämlich beim rumschubsen des Threads auf einen anderen Part des Dual Dualcores (die Quads bestehen ja aus zwei Dual Cores) entweder die Daten vom L2 Cache übertragen werden mussten oder Cache Querzugriffe stattfanden. -> mit dem Tool konnte man bzw. kann man dies verhindern, indem man den Tasks an die richtigen Cores fest pinnt.

Rein von der Theorie her müsste mit festpinnen des Tasks (Single Thread) auf maximal zwei Cores (also bspw. die 1 und die 3) der Takt voll aufdrehen, da der Taskscheduler nur noch zwischen den beiden Cores 1 und 3 hin und her schuben darf.


Ansonsten, was auch interessant wäre zu erfahren, ob das Verhalten auch auftritt, wenn man den Hexacore Bios oder Windowsseitig mal zu einem Quadcore degradiert.


Mich dünkt, das das nicht unbedingt ein Hardwareproblem ist. Und auch nicht primär ein Softwareproblem, sondern wie schon in deinen Links vermutet wurde, das einfach durch das hin und her schubsen des Threads über die Cores der CPU der Turbo gar nicht richtig greifen kann oder gar nicht dazu kommt, zu greifen. Was auch nicht wirklich abwägig ist, wenn die CPU breiter wird, die Last aber nicht zunimmt.
Eventuell sind sechs Cores einfach zu breit für nen SingleThread Task um den Turbo voll aufdrehen zu lassen?
Auch hat das ganze dezent das genau gegenteiligen Touch von der Thematik, die NVidia aktuell mit dem GM204 als GPU fährt... Wo die Schaltung so derart schnell ist, dass man die Lastzustände genauer ausnutzt und die Zeit der nicht Nutzung für Taktreduzierungen/vGPU Spannungsreduzierungen und somit zum Stromsparen nimmt.
Das das Ganze dann im Hochleistungsprofil nicht auftritt, ist dann ebenso logisch, wo das Hochleistungsprofil eben genau dort ansetzt und etwas flotter agiert.

Die Unterschiede zwischen 7 und 10, ggf. auch 8 und 8.1, sofern das mal wer nachtestet, könnten daher kommen, das MS einfach entweder den Threadscheduler verlangsamt hat, sprich die Threads weniger fix über die Cores huschen, oder das das Powermanagement allgemein spritziger eingestellt ist, gerade auch im Bezug auf die GPU Geschichten ist Schnelligkeit ja da von Vorteil...
 

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
Mit dem hin- und herspringen eines einzelnen Threads der einen Kern auf 100% Last bringt hat die Problematik meiner Auffassung nach eher nichts zu tun.

Ich habe Prime unter Windows 7, 8.1 und 10 mit einem Worker mal auf einen Kern "fest gepinnt" und mal normal, also mit Affinität zu allen Kernen / Threads der CPU laufen lassen und das Ergebnis war immer das gleiche. Die CPU lief nur mit 4,2 statt 4,5 GHz. Ab sechs Workern springt aber immer der Turbo an, bei 8.1 hatte ich schon den flüchtigen Eindruck dass es da etwas weniger Worker braucht, die Zwischenstufen habe ich mir aber nicht so genau angeschaut.

Was ich jetzt noch ausprobiert hatte und extrem interessant fand war Santas Idee hier: http://www.hardwareluxx.de/communit...1-oc-laberthread-851887-428.html#post22741022
Energiesparplan "Höchstleistung" aktivieren und die minimale CPU-Leistung statt auf 100 % auf 5 % setzen (so ist es bei den anderen Profilen üblicherweise auch eingestellt).

Das führt bei mir dazu dass die CPU auch bei nur einem Worker in Prime unter Win 7 auf 4,5 GHz geht.
Da muss aber noch mehr dahinter stecken, das ganze Taktverhalten ist viel "giftiger".

Ich bin sogar so weit gegangen mal die Energiesparplan "Ausbalanciert" genau so einzustellen wie "Höchstleistung" ab Werk steht. Trotzdem arbeitet die CPU unterschiedlich.
Es muss also mehr Unterschiede zwischen den Energiesparplänen geben als die sichtbaren.
 
Zuletzt bearbeitet:

fdsonne

Moderator
Hardwareluxx Team
Mitglied seit
08.08.2006
Beiträge
36.267
Ort
SN
Mit dem hin- und herspringen eines einzelnen Threads der einen Kern auf 100% Last bringt hat die Problematik meiner Auffassung nach eher nichts zu tun.

Ich habe Prime unter Windows 7, 8.1 und 10 mit einem Worker mal auf einen Kern "fest gepinnt" und mal normal, also mit Affinität zu allen Kernen / Threads der CPU laufen lassen und das Ergebnis war immer das gleiche. Die CPU lief nur mit 4,2 statt 4,5 GHz. Ab sechs Workern springt aber immer der Turbo an, bei 8.1 hatte ich schon den flüchtigen Eindruck dass es da etwas weniger Worker braucht, die Zwischenstufen habe ich mir aber nicht so genau angeschaut.

Du hast im Taskmanager den einen Worker auf einen der Threads der CPU festgepinnt und der Taskmanager zeigte dir darauf hin 100% Load auf diesem einen Thread an? Also die Kurve ganz oben im Diagramm? -> und der Takt war dennoch nicht im Turbomode?

Das verwundert mich... Zumindest ein Stück weit. Andererseits könnte es aber auch die Erklärung sein.
Es wäre aus meiner Sicht nicht undenkbar, das ein einziger Thread Volllast auf ner 12+ Thread CPU ggf. nicht ausreicht um den Turbo zu zünden... Die CPU geht ja bei weniger als einem Thread Load auch nicht auf vollen Turbo Takt.
Das das bei dir allerdings erst mit dem 6. Worker in den Turbo läuft, ist allerdings äußerst komisch muss ich sagen... Das kenne ich so nicht. Auch wenn ich atm keine Sandy/Ivy/Haswell E oder EP Maschinen nativ mit Windows betankt, griffbereit habe ist mir dieses Verhalten bis dato nie untergekommen...


Hier wäre es denke ich äußerst hilfreich zu wissen, wie das Windows Powermanagment genau funktioniert. :(
Leider hab ich davon nicht wirklich den Plan...
Soweit ich allerdings weis gibt es durchaus unterschiede zwischen Ausbalanciert und Höchstleistung, die man nicht über die Advanced Settings verbiegen kann, sondern die Hardcoded im OS hinterlegt sind. Was du ja selbst auch bestätigst mit der Aussage, das es spritzier wirkt.
Bestenfalls noch über die Registry zu verdrehen sind, aber wie gesagt, damit hab ich mich bis dato nicht beschäftigt...


PS: wenn du kannst, teste mal 2008R2 Server respektive 2012/2012 R2 im Vergleich... Ich würde mich definitiv nicht wundern, wenn dort der Turbo anders reagiert :wink:
 

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
Du hast im Taskmanager den einen Worker auf einen der Threads der CPU festgepinnt und der Taskmanager zeigte dir darauf hin 100% Load auf diesem einen Thread an? Also die Kurve ganz oben im Diagramm? -> und der Takt war dennoch nicht im Turbomode?

Genau dieses.
Wobei ich da ich es nur mit übertaktetem System getestet habe gerade nicht sagen kann ob der Turbo nicht zündet oder nur nicht alle Stufen zündet. Basistakt wären ja Serie 3,2 GHz bei meiner CPU, der höchste Turbotakt 3,8 GHz wenn ich's gerade richtig im Kopf hab.
Auf alle Fälle geht er mit dem Takt zwar rauf, auch über den normalen Basistakt, aber eben nicht ganz rauf.

Bei den Energiesparplänen muss definitiv mehr im Busch sein als das was man einstellen kann, da stimme ich dir zu. Und wenn die Server-OS da anders reagieren würde mich das auch nicht unbedingt wundern, gerade mit dem Support von Prozessorgruppen etc. dürften da doch einige Unterschiede tief im System stecken.

EDIT: Ich frage mich aber auch in wie weit da ggf. installierte Treiber einen Einfluss nehmen können.
 
Zuletzt bearbeitet:

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
Wie gesagt hier Sandy und Haswell-E in einen Topf zu werfen bringt meiner Meinung nach nix.

Ohne Hyperthreading tritt das Problem bei Haswell-E auch auf. Mit weniger Kernen (4 statt 6) tritt es bei Haswell-E noch stärker auf. Ist auch nachvollziehbar, weil dann ein Prozess wie SuperPi z.B. Von einem noch laufenden HWInfo noch öfter weggeschubst wird.

Bei Haswell-E hat es eindeutig was mit festpinnen / Switching zu tun. Ohne Switching, kein Problem - steht aber auch oben.

Zwischen Standardtakt und Maxturbo gibt's übrigens bei Haswell-E keine Zwischenstufen. Halb kann da nix zünden.

Das mit den Treibern ist eine gute Frage, ob die dafür verantwortlich sind. Können dann aber nur die Inf-Treiber sein eigentlich.

Lt. c't Redakteur ist Windows Server auch betroffen.

Das Hochleistungsprofil ist nicht flotter, es vermeidet nur die Stufen zwischen min und max. Eben das was Speedstep aus auch macht.
 

ceti

Enthusiast
Mitglied seit
17.06.2010
Beiträge
136
Ort
Bremerhaven
Ich habe es bemerkt bei Fifa 14, im „ausbalanciertem Zustand“ war es nicht richtig Flüssig, im Energieplan „Höchstleistung“ schon. Bei Fifa15 und Crysis und anderen Games ist das Problem nicht vorhanden. Was mir mit meinem Asrock aufgefallen war: wenn ich die Kerne auf 3,6 im Bios fest Einstelle, also der Standart Turbo Takt meines 5820K, dann tacktet er nur auf Maximal 3,4 GHZ Maximaltakt….auch bei Prime etc….nur wenn ich die Threads begrenze ging er bis auf 3,6 ghz, wie im Bios eingestellt, hoch. Wenn ich nun mehr o. weniger Takt als 3,6 ghz im Bios Eingestellt hatte war alles wie gewollt. Sprich; eingestellt auf 3,5 ghz im Bios, Max. Takt in Windows (Prime etc…) auch dann 3,5 ghz auf alle Kerne. Ich sah das Problem dann eher im UEFI von Asrock?
 
Zuletzt bearbeitet:

G3cko

Enthusiast
Mitglied seit
06.05.2005
Beiträge
3.196
Unverständlich das haswell-e soviel im idle mehr verbrauchen muss. der ramtakt scheint ja auch häufig noch Probleme zu machen. Nun auch noch das taktproblem bei nur einem Kern. Das begeistert einem ja total zum kauf einer schon so gut wie veralten CPU-Architektur.
 

ceti

Enthusiast
Mitglied seit
17.06.2010
Beiträge
136
Ort
Bremerhaven
Genau das war auch das was mich erstaunt hatte. Default verbraucht der PC, also Strommesser am Kaltstromkabel, im Idle immer an die 80 Watt (beim Z-97 war es mit einer i5 @ 4 GHZ knapp 50 Watt gleiche komponenten). Da der PC, ca. 12 von 15 Stunden sich im Idle befindet, fand ich das schon wichtig dass er da auch nicht so viel Verbraucht. Was er beim Daddeln oder Benchen verbraucht ist mir Egal. DDR@ 2666mhz CPU@ 4GHZ, Cache@ 3,4 oder 3,5….auch um die 70 Watt. Habe ihn Testweise nun auf 3,6 cpu (– 0,8v Offset) und 3,3 Cache (-0,2v Offset) mit DDR 2133@1,8v und Eingangsspannung auch -0,8v Offset und SA -1,0v, andere Spannung Fix laut UEFI Standard, laufen. Da verbraucht er im Idle knapp über 50 Watt, was für mich i.o. ist. Auch die Gesamtperformance ist soweit i.o. Was er @ DDR 2800 oder 3000 mit 4,4 GHZ verbraucht hat, habe ich nicht gemessen, wobei wie gesagt der Verbrauch im „Power Modus“ mir Egal ist, aber halt die Geschichte im Idle. Auch wenn DDR2666mhz eigestellt ist, ist der Minimal takt vom Cache im Idle noch 14x also 1400mhz, bei ddr 2133 geht er auf 12x runter. Genau so wie die SA, die muß mindestens + 1,8v Offset laufen damit er Bootet. Alles in allem schon komisch, wobei dann auch logischerweise der Verbrauch im Idle steigt:sick:
 
Zuletzt bearbeitet:

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
Ich hab gerade mal Höchstleistung und ausbalanciert im Vergleich getestet. Und mir das jeweilige Taktverhalten in HWInfo angeschaut. Ob ich Höchstleistung oder Ausbalanciert an habe ist vollkommen egal. Lediglich die Minimale Prozessorleistung 100% oder 5% ist relevant. Mit 5% gibt es die Zwischenstufen beim Takt, mit 100% gibt es nur min / max. Die Stromaufnahme ist auch identisch. Ist also auf den ersten Blick das selbe wie Speedstep aus und inakzeptabel. ;)
 

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
nur wenn ich die Threads begrenze ging er bis auf 3,6 ghz, wie im Bios eingestellt, hoch. Wenn ich nun mehr o. weniger Takt als 3,6 ghz im Bios Eingestellt hatte war alles wie gewollt. Sprich; eingestellt auf 3,5 ghz im Bios, Max. Takt in Windows (Prime etc…) auch dann 3,5 ghz auf alle Kerne. Ich sah das Problem dann eher im UEFI von Asrock?

Das hab ich nicht verstanden. ;)

Was meinst du mit Threads begrenzen?

@Ceti du hast oben bei den Spannungen was falsch. Die CPU braucht um die 1V auf Standard -0,8 geht nicht und die SA ist unter ein Volt Standard +1,8V geht somit auch nicht, das gibt höchstens eine gegrillte CPU. ;)

Was meinst du mit mehr oder weniger eingestellt? Ich hab z.B. 4,3 für alle Kerne eingestellt und jeder Kern taktet einzeln wie er lustig ist.
 
Zuletzt bearbeitet:

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
@ceti
Kann es vielleicht sein dass deine CPU wenn sie auf 3,6 GHz bei voller Auslastung auf allen Cores nicht die 3,6 GHz macht einfach zu warm wird oder ein ein Powerlimit läuft? Das Powerlimit kann man im UEFI aber normalerweise höher schrauben.

@nemihome
Ich seh auch mit dem Energiesparplan "Höchstleistung" das auf Min 5 / Max 100 verstellt ist beim Sandy-E dass er ab und zu nicht die vollen 4,5 GHz fährt sondern schon durchaus auch mal die 4,2 GHz, aber er schaltet wesentlich schneller ganz hoch auf 4,5 GHz.

Der Idle-Takt ist mit 1,2 GHz der gleiche wie mit "Ausbalanciert" und er springt wenn das System auf dem Desktop steht auch mal auf allen möglichen Frequenzen zwischen 1,2 GHz und 4,5 GHz rum. (1,8, 2,3, 2,8, 3 GHz usw).
Ich hab also nicht den Eindruck dass ihm irgendwelche Zwischenstufen fehlen, er reagiert nur deutlich schneller mit Taktänderungen auf bereits sehr kleine Lastanforderungen.

In "Ausbalanciert" kann ich das so nicht beobachten, wenn der Desktop ruht und ich nur ins HWiNFO schaue wirkt er wie auf 1,2 GHz fest genagelt, da muss dann schon mehr passieren als sich nur die Maus bewegen dass er hoch taktet (Programm starten o.ä.), nur braucht's da eben schon einiges damit er auf die 4,5 GHz geht.

Ich muss das am Montag mal auf meinem Ivy-E Xeon in der Arbeit beobachten, ob der da vergleichbar reagiert.
 

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
Dann Verhalten sich der E und Sandy auch bei den Einstellungen im Energiesparplan unterschiedlich oder es spielen wirklich noch UEFI oder Treiber rein. Bei mir gibt's mit 100% nur vollen Turbo oder eben nicht (also 4,4 und 1,2 aktuell). Das steigert dann den Idle Verbrauch wieder um 10-20 Watt. Eben genau das was Speedstep auch macht.
 
Zuletzt bearbeitet:

ceti

Enthusiast
Mitglied seit
17.06.2010
Beiträge
136
Ort
Bremerhaven
Hi, thx für die Hinweise….und sorry war zu schnell bei den Zahlen. Also System Agent hab ich nun auf -0,100….geht von minus 0,300 bis + 0,600 im UEFI. Wie hoch der Realwert ist kann ich nicht sagen, habe ihn halt bei Minus 0,100v Offset eingestellt, weiß nicht wo ich den Realwert auslesen kann (HWiNFO muss ich noch mal schauen ob ich es dort finde). System Agent genehmigt sich bei Default und DDR 2666mhz +0,300.
Bei Vcore Offset meinte ich Minus 0,080v und Input CPU auf auch auf Minus 0,080v.
Temperaturprobleme hab ich keine, @3,8 GHZ hab ich bei Prime keine 50 Grad…ist eine fertig Kühlung Enermax ELC240 mit 4x120 Lüfter, die laufen auf 600-800 U/min absolut im Silent und da ist auch noch Luft nach oben. Die Limits (1000) brauche ich erst bei über 4ghz setzen, im Moment sind sie @ Default.
Mit „mehr oder weniger“ meinte ich; setze ich „all cores“ im Bios auf 36x also 3,6ghz verhält er sich wie beschrieben max. 3,4ghz. Nur bei weniger Threads in Prime (z.b drei) geht er auch auf 3,6ghz. Stelle ich nun irgendein anderen Wert im Bios ein, all cores@ x35 oder x37 und höher (haupsache keine 36x) nimmt er auch den tatsächlichen Wert bei Prime auf allen Kernen, also auch mit 6 Kernen.

Muss(te) auch erst richtig den X99 kennen lernen, er Reagiert auf jeden Fall auch sehr komisch, auch DDR@3000mhz laufen, nächsten Tag wieder nicht mehr. Das Bios muss nach zu vielen Veränderungen immer wieder „Bios Reset“ haben, sonst läuft’s absolut instabil, UEFI Default reicht meist nicht aus das er alles wieder vernünftig macht. Ich warte von Seitens Asrock schon länger auf ein vernünftiges Bios, fahre noch das 1.30, das aktuellste 1.50 ist nicht der Hit…..aber das gehört hier ja nicht her, wollte nur nochmal loswerden.
 
Zuletzt bearbeitet:

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
Achso, ich vermute mal bei Standard musst du "All Core auf Enabled" oder wie auch immer das bei dir heißt stellen. Das nicht alle Kerne den Maxturbo machen ist normal mit Standardsettings, ohne besagte Einstellung.
 
G

Gelöschtes Mitglied 172838

Guest
Bitte zum Thema zurück!

Das Problem ist, man merkt die Leistungseinbußen auch im Alltag. Zu erst ist es mir in CoH1 während des Spiels aufgefallen. In stressigen Situationen kam es zu deutlich Rucklern, die ich von meinem i7 4790K System nicht kannte.
Jetzt ist die Frage: Liegt es am Taktunterschied (4,2GHz vs. 3,5GHz,. oder daran, dass der i7 5820 nicht ordentlich hochtaktet?

Da beide CPU der Haswell Generation entspringen und ich der Meinung bin, dass 3,5GHz reichen sollten für ein Spiel von 2006, gehe ich eher von einem Turboproblem aus.

In Cinebench R15 habe ich dadurch im single core benchmark auch sehr niedrige Leistungswerte. Oft nur 113 Punkte. Mein i5 4300U aus meinem Tablet ist in diesem Test praktisch gleich schnell! Wenn ich nebenher CPU-Z anmache (Rechtsklick auf das Fenster) sieht man schön, wie die Last von Kern zu Kern springt. Der einzelne Kern taktet dabei mit ca. 3,4-3,5GHz. Die restlichen sind bei 1,2GHz. Das Hauptfenster scheint etwas träge zu sein. Hier bleibt es bei 0,762V und 1,2GHz die meiste Zeit über. Der Taskmanager zeigt anscheinend einen "Phantasiewert" an: 2,6-2,8GHz. Nimmt Windows hier einen Mittelwert?

Wenn ich auf "Höchstleistung" stelle bekomme ich um die 140 Punkte. Ist auch klar, weil dann alle Kerne mit vollem Takt laufen und das "Springen der Last" keine Auswirkung mehr hat. In CoH1 habe ich dann auch keine Ruckler mehr. Aber das ist für mich nur eine schlechte Interimslösung.
 
Zuletzt bearbeitet von einem Moderator:

ceti

Enthusiast
Mitglied seit
17.06.2010
Beiträge
136
Ort
Bremerhaven
@nemihome

nein.... stelle die Kerne dann selber ein. Wie gesagt auf Manuel eingestellte x36 verhält er sich dann einfach so als ob´s im "Auto Modus" Turbo 36x ist, obwohl ich sie ja Manuel auf x36 gestellt habe. Stelle ich dort nun alles andere ein außer 36x verhält er sich so wie ich das möchte. Also habe ich ihn nun auf x38 gestellt, damit ich immer 3,8ghz habe und nicht wenn weniger Kerne Arbeiten, wie es bei Prime zu sehen war. Auch 3,5 GHZ und 3,7 GHZ und alles was drüber war verhält sich normal, also ganze Power auf allen Kernen.

zu spät....sorry:eek:
 
Zuletzt bearbeitet:

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
Am besten lässt sich das Turbo-Verhalten beim Zocken beobachten indem man den CPU Takt von HWiNFO im OSD von RTSS anzeigen lässt.
Beim Haswell-E ist dabei aber zu beachten dass wohl jeder Kern einen anderen Turbo Takt fahren kann weshalb es dann wohl unerlässlich ist den Takt von wirklich jedem Kern im OSD anzeigen zu lassen.
 

ceti

Enthusiast
Mitglied seit
17.06.2010
Beiträge
136
Ort
Bremerhaven
Unbenannt.jpgCinebench R15 mit 1 Thread zeigt bei mir im Taskmanager +/- 10% auslastung an, auch sehr schön zu sehen in Aida, wo der Takt auf fast immer 1,2ghz bleibt und alle Kerne sich die Arbeit teilen.....
 

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
Die teilen sich die Arbeit nicht. Der Taskmanager stellt das nur so dar. Das ist besagtes Switchen. Eine Singlecoreanwendung kann zu einer Zeit nur auf einem Kern laufen. ;) der Aida Takt ist keine gute Referenz (wenn man sich nur der Allcoretakt anzeigt), da muss man auch jeden Kern einzeln betrachten.
 

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
10% Auslastung gesamt oder 10% Auslastung auf dem Core auf dem Cinebench arbeitet?
Nagel doch mal mit dem Taskmanager den Cinebench-Prozess auf einen Kern fest und beobachte die Auslastung dieses Kerns.

Zum Auslesen des Takts solltest du ein Tool verwenden das den Takt jedes einzelnen Kerns getrennt anzeigt (HWiNFO kann das z.B.), da der Haswell-E nämlich die P-States der Kerne individuell fahren kann (nur der belastete Kern taktet hoch, der Rest bleibt auf Idle-Takt) und man nicht weiß den Takt welches Kerns Aida anzeigt kann es recht schnell zu Auslesefehlern kommen.
 

Santa

Enthusiast
Mitglied seit
24.08.2002
Beiträge
145
Die von mir gepostete „Notlösung“ funktioniert sowohl bei Sandy-E als auch bei Ivy-E. Zu Haswell-E kann ich nichts sagen, da ich kein entsprechendes System besitze.

Auf jeden Fall kann ich H_M_Murdock Beobachtung bestätigen: Die Energiesparpläne von Windows 7 unterscheiden sich nicht nur in den für den Benutzer sichtbaren Optionen. Wie H_M_Murdock geschrieben hat, macht es (zumindest bei Sandy-E und Ivy-E) einen deutlichen Unterschied, ob man den Energiesparplan“Höchstleistung“ an „Ausbalanciert“ anpasst oder umgekehrt. Leider habe ich keinen Weg gefunden, wie man auf die versteckten Optionen/Einstellungen Zugriff erhält. Vielleicht hat ja jemand von Euch eine Idee...
 

ceti

Enthusiast
Mitglied seit
17.06.2010
Beiträge
136
Ort
Bremerhaven
10% für die CPU allgemein im Taskmanager, und bei Aida sieht man die unterschiedlichen Prozente jedes Kerns, wenn das dann so stimmt was Aida anzeigt (warscheinlich dann wohl nicht). Hab das als Gadget oben auf dem Desktop. Probiere es aber nachher mal mit dem "Realtakt" des Kerns.
 

Phantomias88

Banned
Mitglied seit
19.04.2008
Beiträge
8.459
Ort
StuggiTown
Die von mir gepostete „Notlösung“ funktioniert sowohl bei Sandy-E als auch bei Ivy-E. Zu Haswell-E kann ich nichts sagen, da ich kein entsprechendes System besitze.

Auf jeden Fall kann ich H_M_Murdock Beobachtung bestätigen: Die Energiesparpläne von Windows 7 unterscheiden sich nicht nur in den für den Benutzer sichtbaren Optionen. Wie H_M_Murdock geschrieben hat, macht es (zumindest bei Sandy-E und Ivy-E) einen deutlichen Unterschied, ob man den Energiesparplan“Höchstleistung“ an „Ausbalanciert“ anpasst oder umgekehrt. Leider habe ich keinen Weg gefunden, wie man auf die versteckten Optionen/Einstellungen Zugriff erhält. Vielleicht hat ja jemand von Euch eine Idee...
https://bitsum.com/parkcontrol/
Ganz runter scrollen, dann den "DOWNLOAD REG TWEAK" Link anklicken und danach ausführen (hinzufügen).

:)
 

nemihome

Enthusiast
Mitglied seit
11.10.2003
Beiträge
1.710
So, genug geredet. Mal ein paar Beweisfotos ;)

Mit SuperPi geht das auch so, wie mit jeder anderen Singlecoreanwendung auch.

Windows 7 - Worker nicht fixiert:


Windows 7 - Worker fixiert (das der 5930K nicht führt liegt daran, dass ich einen Moment gebraucht habe um den Prozess zu fixieren):


Windows 10 - Worker nicht fixiert:


Windows 10 - Worker fixiert (das der 5930K nicht führt liegt daran, dass ich einen Moment gebraucht habe um den Prozess zu fixieren):


HWInfo lief jeweils im Hintergrund. Bei den nicht fixierten werden war sowohl in Windows 7 als auch in Windows 10 nur ab und an der Maxturbo mal kurz zu sehen.

Edit: kleine Ergänzung noch, da das ja bei den Sandys teilweise scheinbar Probleme macht. Es liegt mit der Fixierung durchgehend der Maxturbo auf dem einen Kern an!
 
Zuletzt bearbeitet:

H_M_Murdock

Urgestein
Thread Starter
Mitglied seit
29.10.2007
Beiträge
8.555
Ort
München
Ja das liegt wohl daran dass das hin & her gespringe des Taks zwischen den Cores der CPU der CPU kaum genug Zeit lassen den Turbo zu zünden bevor der Task wieder wo anders ist.

Evtl. ist das beim Haswell noch übler als beim Sandy und Ivy da beim Haswell nur der Kern im Turbo läuft der auch unter Last steht. Ist aber nur eine Vermutung.

EDIT:
Das mit dem Park Control klingt interessant, das muss ich mir näher ansehen.
 
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Oben Unten