[Sammelthread] Die sparsamsten Systeme (<30W Idle)

Deine Annahme, dass der Strom gleich hoch ist bei beiden Netzspannungen ist falsch.
Habe geschrieben, dass die Leistung in Watt gleich bleibt…
Natürlich ändert sich der Strom bei unterschiedlichen Spannungen.
Das Netzteil muss lediglich so dimensioniert sein, dass es die Ströme packt.
Wir reden hier von Switches in den Bereichen 150-400 Watt bei möglicher Volllast. Das auch noch bei Spannungen zwischen 110-220 Volt.
Das sind keine hohen Ströme. Meine 48 Volt Akkus von der PV Anlage haben etwas dickere Kabel 😉

Somit ist das Thema erledigt. THX.
 
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
MSI Mortar B660M DDR4
Hey! Sorry for replying in english.
I am trying to optimise my system with the same motherboard.
My specs are:

CPU: i5-13500
MB: MSI Mortar B660M DDR4
RAM: 64GB Crucial 3200MHZ DDR4
NVME: Samsung 980 PRO 1TB and Crucial P3 500G
HDD: 4 x 8TB WD Red Plus

The issue I am facing is that 2 PCI Bridges, the ethernet (RTL8125) and SATA (ASM1062) controller have ASPM disabled.
Did you face this same issue? If so how did you manage to solve it?
Attached is the output of the lscpi command
 

Anhänge

  • lscpi_output.jpeg
    lscpi_output.jpeg
    510,9 KB · Aufrufe: 92
The issue I am facing is that 2 PCI Bridges, the ethernet (RTL8125) and SATA (ASM1062) controller have ASPM disabled.
Did you face this same issue? If so how did you manage to solve it?
Attached is the output of the lscpi command
Did you activate the ASPM-Settings in the UEFI? Or did you just leave it default and likely deactivated?
 
Müssen eigentlich alle Geräte das ASPM dann aktiviert haben, dass der Rechner in C8 gehen kann? Verstehe es leider noch nicht so richtig.
Beitrag automatisch zusammengeführt:

Thank you for the quick reply.
These are some of the settings I changed:
Great settings. How are the C-States looking now? Did you try powertop --autotune already?
 
Müssen eigentlich alle Geräte das ASPM dann aktiviert haben, dass der Rechner in C8 gehen kann? Verstehe es leider noch nicht so richtig.
Beitrag automatisch zusammengeführt:


Great settings. How are the C-States looking now? Did you try powertop --autotune already?
Yes I ran both --configure and --autotune, the system now only reaches C3
 
Hi,
for the Realtec NIC you can try:
Code:
echo 1 | sudo tee /sys/bus/pci/drivers/r8169/0000:04:00.0/link/l1_2_aspm
The ASM1062 doesn't support ASPM according to lspci. You can only disable it.
 
Hi,
for the Realtec NIC you can try:
Code:
echo 1 | sudo tee /sys/bus/pci/drivers/r8169/0000:04:00.0/link/l1_2_aspm
The ASM1062 doesn't support ASPM according to lspci. You can only disable it.
Thank you. I will try this.
Does this mean that unless a driver comes out for ASM1062 that supports it I cannot reach C states lower than C3?
 
Thank you. I will try this.
Does this mean that unless a driver comes out for ASM1062 that supports it I cannot reach C states lower than C3?
I just deactivated "Native ASPM" in BIOS, now ASPM is enabled on the NIC!!! :) Thank you for the help!!
I think the only component preventing the system from reaching higher C-states is the SATA controller, but it looks like it's unsupported, what's your advice?
 

Anhänge

  • Screenshot 2024-02-18 at 23.01.40.jpg
    Screenshot 2024-02-18 at 23.01.40.jpg
    507 KB · Aufrufe: 51
Großen Dank an Mor9oth für sein Post.
  • Mainboard: Kontron K3842-Q mATC
  • RAM: 1x 16GB Crucial DDR5-4800 DIMM CL40 Single
  • CPU: INTEL Core i3-14100T 2.7GHz FC-LGA16A
  • Lüfter CPU: Noctua Kühler NH-L9i 1700
  • PSU: Corsair SF600
  • SSD: 1x WD Red SN700 NVMe 500GB

Messgerät: ELV Energy Master Basic

  • BIOS update
  • BIOS Einstellungen für Stromsparen optimiert
  • Neue TrueNas Scale installation
  • In der Konsole powertop --auto-tune
IDLE Power Werte
  • Mit Tastatur und TV per DisplayPort und 1x SSD SATA 2.5 = ca. 11.5W
  • Ohne Display = ca. 7.6W
Fast die gleichen Werte mit der M2 NVMe SSD.
Das aber nur weil ASPM im BIOS auf L1 eingestellt ist (wird von der WD SN700 unterstützt).
Leider erzeugt das die nachfolgende Fehlermeldung. Mit L0s ist die Fehlermeldung weg, aber der IDLE Wert auf 15.5W gestiegen.

Ich hab die NVMe in den zweiten M2 slot gebaut und siehe da, 7.6W idle und ASPM aktiviert ohne Fehlermeldung 🥳

Je 2.5 HDD kommen noch mal ca 0.7-1W im IDLE dazu.

IMG_2040.jpeg


Mit der NVMe erhalte ich eine Fehlermeldung.
Weiss jemand mehr darüber?

PCIe Bus Error: severity=Corrected, type=Physical Layer, (Receiver ID)
device [15b7:5006] error status/mask=00000001/0000e000


Hier
hat jemand geschrieben das er den UPS driver geändert hat. Was ist UPS?


Das K3842-Q Motherboard gibt es in zwei Varianten:

  • K3842-Q1 (single LAN) mit 1000 MBit (F5110-V191)
  • K3842-Q2 (Dual LAN) mit 1000 MBit + 2500 MBit (F5110-V189)
 
Zuletzt bearbeitet:
IDLE Power Werte
  • Mit Tastatur und TV per DisplayPort und 1x SSD SATA 2.5 = ca. 11.5W
  • Ohne Display = ca. 7.6W
Fast die gleichen Werte mit der M2 NVMe SSD.
Beeindruckend wie LGA1700 doch stromsparsam sein kann. Kannst du mal die C-Werte hier als Screenshot bringen? Kommt der Rechner in den C8 oder bleibt er im C3 stecken? Hoffentlich kommst du noch ins Betriebssystem, nicht das der Festspeicher nicht mehr läuft.
 
Beeindruckend wie LGA1700 doch stromsparsam sein kann. Kannst du mal die C-Werte hier als Screenshot bringen? Kommt der Rechner in den C8 oder bleibt er im C3 stecken? Hoffentlich kommst du noch ins Betriebssystem, nicht das der Festspeicher nicht mehr läuft.
Das Mainboard macht auch viel aus, was das Stromsparen angeht. Ich weiss nicht ob man diese idle Werte so leicht mit einem Gaming Board oder 0815 schafft.

Powertop zeigt nur bis C3 an. Hab gelesen, dass liegt daran das Powertop zu alt ist und die CPU nicht unterstützt.
#gefährliches-halbwissen
 
Zuletzt bearbeitet:
Bei den Gaming-Brettern sind noch viele Zusatzcontroller, wie USB-Hubs, Thunderbolt und viele weitere. Die müsste man alle abschalten, soweit es geht. Bei deinem Brett oder auch den Server-Brettern ist weniger Anschluss-IO da und damit muss auch nicht soviel deaktiviert werden. Denke das wird es vor allem sein.
 
Großen Dank an Mor9oth für sein Post.
  • Mainboard: Kontron K3842-Q mATC
  • RAM: 1x 16GB Crucial DDR5-4800 DIMM CL40 Single
  • CPU: INTEL Core i3-14100T 2.7GHz FC-LGA16A
  • Lüfter CPU: Noctua Kühler NH-L9i 1700
  • PSU: Corsair SF600
  • SSD: 1x WD Red SN700 NVMe 500GB

Messgerät: ELV Energy Master Basic

  • BIOS update
  • BIOS Einstellungen für Stromsparen optimiert
  • Neue TrueNas Scale installation
  • In der Konsole powertop --auto-tune
IDLE Power Werte
  • Mit Tastatur und TV per DisplayPort und 1x SSD SATA 2.5 = ca. 11.5W
  • Ohne Display = ca. 7.6W

Super! Kontron ist was stromsparende Lösungen angeht sehr weit.
 
Hallo,
kann mir jemand sagen wie viel Watt extra eine PCIexpress zu M2 NVMe Karte ca braucht?
Zum Beispiel die Asus HYPER M.2 X16

Hintergrund ist, das mein Kontron K3842-Q Mainboard zwei 2280 M2 Steckplätze hat.
Einer davon zieht die C Werte auf C3 runter.
Ich benötige aber 2 NVMe für ein Mirror für Truenas.
Es gibt noch einen M2 2230 Stellplatz. Den könnte man mit einem Adapterboard wie das hier nutzen, aber es kostet gleich viel wie das von Asus.
 
@bendim warum das teure Asus Teil?

Und den günstigen Adapter kannst du in x4, x8 und x16 stecken und schauen welcher Slot z.B. dann höhere P/C-States verhindert.

Stromverbrauch sollte das sein was die SSD eben verbraucht. Der Adapter ist ja nur die pins von klein auf groß umgesetzt.

Hast du verschiedene SSDs versucht? Kann auch die SSD sein und muss nicht am Steckplatz liegen.
Kann mir gar nicht vorstellen das ausgerechnet Kontron den zweiten M.2 so anschließt das ASPM nicht mehr geht.
 
Hallo Leute, nach langem mitlesen habe ich jetzt auch mal was zu berichten.

Ich war irgendwie inspiriert/angefixt von den tollen Ergebnissen die hier manche erzielen und hab das Glück ergattert gebraucht an ein Fujitsu Mainboard zu kommen.
Nach etwas basteln bin ich nun bei folgendem Ergebnis:

12,5-13,5W Idle-Verbrauch in Watt
46W Last-Verbrauch in Watt (TDP Limit 35W per BIOS)
Package C-States:
Code:
root@pve:~# cpupower monitor
    | Nehalem                   || Mperf              || Idle_Stats                                                 
 CPU| C3   | C6   | PC3  | PC6   || C0   | Cx   | Freq  || POLL | C1   | C1E  | C3   | C6   | C7s  | C8   | C9   | C10 
   0|  0.10|  0.53|  0.00|  0.00||  0.65| 99.35|  3478||  0.00|  0.81|  0.76|  0.11|  0.58|  0.00|  6.50|  0.00| 90.57
   1|  0.02|  0.00|  0.00|  0.00||  0.19| 99.81|  3449||  0.00|  0.02|  0.93|  0.03|  0.00|  0.00|  2.23|  0.00| 96.59
   2|  0.11|  0.40|  0.00|  0.00||  0.67| 99.33|  3454||  0.00|  0.81|  1.31|  0.13|  0.43|  0.00|  8.44|  0.56| 87.64
   3|  0.13| 23.95|  0.00|  0.00||  4.67| 95.33|  3504||  0.00|  0.03|  0.31|  0.35| 27.70|  0.00| 67.07|  0.00|  0.00
Intel i3-9100 CPU
Fujitsu/Kontron D3646-S ATX Mainboard
Fortron/Source FSP250-60EGA 250W 80+ Gold Netzteil
iGPU intel UHD 930 GPU
KD-202 Messgerät
2x Samsung M.2 nvme SSD 256GB
MZVLW256HEHP-00L7 als Systemlaufwerk (ZFS mirror) beide absichtlich (braucht weniger Strom) angebunden über PCIe x1 (PCIe > M.2 Adapter)
48GB (2x 16GB und 2x 8GB) Samsung ECC DDR4-2400 M391A2K43BB1 UDIMM RAM
Proxmox 6.5.13 + TrueNAS Core VM
1xGB LAN an der onboard i219LM, sonst keine Maus, Tastatur, Monitor, etc.
CPU Lüfter: Thermalright Assassin X 90 SE V2 (pwm), 4x Gehäuselüfter Thermalright TL-B8 (pwm), 1x Noctua Redux 120mm (pwm)

Mit zusätzlichen angeschlossenen und laufenden Festplatten (2x WD RED 8TB WD80EFAX-68LHPN0 und 2x Toshiba 20TB MG10ACA20TE) bin ich ohne Spindown bei einem Idle Verbrauch von 34-35W
 
Zuletzt bearbeitet:
Wirklich? woher hast du diese aussage? Wenn das tatsächlich so ist, finde ich das Ergebnis aber trotzdem nicht schlecht.
 
Ich habe letztes Jahr meine Liebe zu Proxmox entdeckt nachdem Unraid mich nicht überzeugen konnte.

Gekauft hatte ich mir einen Mini PC (BOSGAME B100) mit
N100 Chip
16 GB DDR4 3.200 RAM
512 GB M2
2,5GB Lan

Netzteil:
‎36W, Input AC 100~240V, 50/60Hz Output 12V/3A.

Als erster Einsatzzweck sollte nur Adguard dort laufen. Aber wie das so ist kommt mit zunehmender Beschäftigung immer mehr dazu.
Aktuell laufen:
Adguard
Emby
Audiobookshell und
TrueNAS Scale

1708678289652.png


Aufgerüstet hatte ich mit einer 1 TB Sata SSD die nächste Woche durch eine 4 TB ersetzt wird.

Im Idle liegt der Verbauch bei 4,5-6,3 Watt. Wenn TrueNAS Daten sichert kommt es auch mal auf 10-15 Watt hoch.
Insgesamt bin ich mit der Lösung sehr zufrieden und der Verbrauch ist mehr als Top.

Shelly Plug S:
1000050412.jpg
 
Zuletzt bearbeitet:
Das ist super und wir freuen uns alle mit dir,

diese Infos sind so aber weitestgehend nutzlos wenn du nicht wenigstens sagst WELCHER n100 mini pc das ist, welches netzteil, welches messgerät usw. (siehe erster post)
 
Zuletzt bearbeitet:
12,5-13,5W Idle-Verbrauch in Watt
46W Last-Verbrauch in Watt (TDP Limit 35W per BIOS)

Mit zusätzlichen angeschlossenen und laufenden Festplatten (2x WD RED 8TB WD80EFAX-68LHPN0 und 2x Toshiba 20TB MG10ACA20TE) bin ich ohne Spindown bei einem Idle Verbrauch von 34-35W
Schon beeindruckend und ein gutes Ergebnis. (y) Leider hat der 9100 halt auch keine Leistung. Gen 9 gefällt nicht so recht, da nur 1151v2. Die leisten alle nicht viel bzw. sehen richtig schwach ggü. 1700 wie ADL oder RPL aus.
 
Das ist super und wir freuen uns alle mit dir,

diese Infos sind so aber weitestgehend nutzlos wenn du nicht wenigstens sagst WELCHER n100 mini pc das ist, welches netzteil, welches messgerät usw. (siehe erster post)
Ich habe die Angaben ergänzt.
 
Schon beeindruckend und ein gutes Ergebnis. (y) Leider hat der 9100 halt auch keine Leistung. Gen 9 gefällt nicht so recht, da nur 1151v2. Die leisten alle nicht viel bzw. sehen richtig schwach ggü. 1700 wie ADL oder RPL aus.
naja dank intel gibt es seit gen9 leider nicht so viele bezahlbare alternativen wenn man auf ECC angewiesen ist. Mir reicht die Leistung, zumal die CPU Hardware Transcoding beherrscht und mein letzter Server bis vor kurzen mit einem zig mal langsameren AMD N40L gewerkelt hat. Der i3-9100 ist gefühlt 10x so schnell.
 
@bendim warum das teure Asus Teil?

Und den günstigen Adapter kannst du in x4, x8 und x16 stecken und schauen welcher Slot z.B. dann höhere P/C-States verhindert.

Stromverbrauch sollte das sein was die SSD eben verbraucht. Der Adapter ist ja nur die pins von klein auf groß umgesetzt.

Hast du verschiedene SSDs versucht? Kann auch die SSD sein und muss nicht am Steckplatz liegen.
Kann mir gar nicht vorstellen das ausgerechnet Kontron den zweiten M.2 so anschließt das ASPM nicht mehr geht.
Die Asus Karte kann 4x NVMe. Die von dir nur eine, so wie ich das sehe.

Ich habe WD SN700 an dem ersten und zweiten M2 Steckplatz ausprobiert. Beide mal L1 aktiviert. Beim ersten Steckplatz hat TrueNas kontinuierlich einen Fehler ausgegeben. Im Beitrag von Mor9oth beschreibt er das gleiche Problem.
 
Die Asus Karte kann 4x NVMe. Die von dir nur eine, so wie ich das sehe.

Ich habe WD SN700 an dem ersten und zweiten M2 Steckplatz ausprobiert. Beide mal L1 aktiviert. Beim ersten Steckplatz hat TrueNas kontinuierlich einen Fehler ausgegeben. Im Beitrag von Mor9oth beschreibt er das gleiche Problem.
Das glaube ich nicht. Die Kann sicherlich auch x4.
Ich hab eine noch billigere und selbst die kann schon x4 https://www.amazon.de/dp/B0B9B8DL3G

Zum Thema Verbrauch: eine per x4 angebundene nvme hat bei mir einen unterschied von ca. 2-2,5W gemacht. Eine per x1 angebundene nvme ca 0,5W. Das ist auch der Grund warum ich beide bei mir absichtlich in x1 PCIe Slots mit dem oben verlinkten Adapter betreibe.
Beitrag automatisch zusammengeführt:

Wenn ich schon gerade dabei bin schreibe ich hier der Vollständigkeit halber auch gleich über mein zweites System dass ich zuerst gebaut hab, bei dem ich aber vom Verbrauch nicht so überzeugt war, weshalb ich überhaupt auf Fujitsu gegangen bin:

Das System war auf Basis des aktuell heiß diskutierten Gigabyte MJ11-EC1 Serverboards.

Das sind Werte Ohne Undervolting und untertakten:

24-25W Idle-Verbrauch in Watt (ca 6-7W davon entfallen allein auf IMPI)
~22-22,9W sind mit Undervolting+untertakten machbar (zenstates)
~55W Last -Verbrauch in Watt
Package P1 bis P3 States (AMD)
AMD EPYC 3151
CPU (wenn passiv gekühlt, bitte beim Lüfter unten angeben)
Gigabyte MJ11-EC1 Mainboard
SeaSonic 300W SSP-300SFG 80+Gold SFX Netzteil (Lüfter umgebaut auf GDSTIME GDA8015 80x15mm mit Hydrolager)
nur Management ASPEED GPU
KD 202 Messgerät
1x 1TB Samsung PM981 nvme SSD, angebunden mit x4
64GB (4x16GB)
SK Hynix HMA42GR7MFR4N-TF RDIMM ECC Reg DDR4-2133 ECC RAM
Proxmox/TrueNAS Scale als OS (verbrauch identisch da beide Debian basiert)
2xGbit LAN (onboard I210-AT) angeschlossen, sonst keine Maus, Tastatur, Monitor, etc.
Jonsbro N3 Gehäuse Backplane mit stock 2x100mm Lüftern auf "5V" (in Serie) + 2x 80mm Thermalright TL-8015 @600rpm + 1x 80mm Thermalright TL-B8 @600rpm (CPU)
 
Zuletzt bearbeitet:
Hi Leute,

ich habe mir ein System mit B760I AORUS PRO als Mainboard zusammengebaut. Ich würde gern das WiFi deaktivieren, habe hierfür aber keine Option im UEFI gefunden. Kann jemand aushelfen? Messwerte liefere ich nach, bin noch am optimieren.

Dass ich mit der Mellanox MCX314A-BCCT ConnectX-3 Pro nicht unter C3 komme ist normal, oder?

Betriebssystem ist Proxmox VE.
 
In der Regel würde es ausreichen den Rechner runterzufahren, die Karte auszubauen und wieder hochfahren. So wie es aussieht kann man die Karte nicht so einfach von der Hauptplatine lösen. Du könntest noch den Rechner runterfahren, die Hautpplatine ausbauen dann die Verkleidung der Rückanschlussblende abschrauben und hoffen das du links vom Prozessor an die Karte kommst und sie dann wie andere M.2-Geräte abstecken kannst.

Edit: Wow du hast tatsächlich eine 40G-NW-Karte gekauft? Am Zielrechner auch oder? Und werden die 40G mittels Proxmox oder der VM drüber gegenüber dem Zielrechner erreicht?
 
Zuletzt bearbeitet:
Ich baue hier momentan einen Proxmox Cluster mit zwei Nodes und einem QDevice auf. Die beiden Nodes sind direkt miteinander verbunden und zusätzlich geht je Node ein Uplink später zum (Q)SFP+ Switch. Der muss aber noch bestellt werden. Der Backup-Server und ein Client werden bei Zeiten auch noch 40G Karten erhalten. :d
 
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Zurück
Oben Unten refresh