Alltagstaugliche Desktop-Systeme mit 6W Idle-Verbrauch (inkl. Haswell Beispiel)

So, ich hab jetzt mal das basissystem beisammen:
cpu: i5 13400
mb: GIGABYTE B760M Gaming DDR4
ram: Crucial, 3200 32GB Crucial CT32G4DFD832A 1.2V
storage: HP EX950 2TB
cpu lüfter: Noctua NH-L12 Ghost S1 Edition
psu: shitty 500 Watt Sharkoon WPM500

das ganze hab ich jetzt mal testweise auf einen china plug mit integrierter messfunktion gesteckt (ehrfahrungsgemäss +-3W genauigkeit) aber für die erste Einschätzung reicht es.
Das System is im idle (proxmox+home assistant) auf 21-23W
Ich hab auch 3 Gehäuselüfter drin (3PIN) die aber alle auf stop sind, solange die Temperatur unter 40 Grad sind, was auch nicht erreicht wird im normalen Betrieb
Als nächstes werde ich dann das Netzteil auf ein Seasonic Prime TX-450 Fanless wechseln, mal sehen, was das für einen Unterschied bringt.
Im BIOS habe ich alle power settings aktiviert und die soundkarte deaktiviert. An den settings der CPU ist noch alles standard.

Wo ich mich jedoch nicht auskenne ist wie genau powertop funktioniert.
Ich hatte erst die 2.14 aus dem debian repo, die jedoch nur bis C3_ACPI ging bei den Pkg states
dann hab ich mir die 2.15 kompiliert und nun sieht das so aus.. die Pkg sind nun bis C10 angeführt, aber alles auf 0%..
ich weiss nicht, ob ich da was falsch eingestellt habe, oder ob die config so einfach nicht unterstützt wird
1709909355119.png


Verbrauch ist für mich ~OK~ aber sollte ich ihn nicht weiter drücken können, werde ich die GTX3060 nicht weiter in Erwägung ziehen erstmal. Da habe ich dann mit ~15W zusätzlich zu rechnen vermute ich.

Edith: habe diesen schönen Threads gefunden
https://forums.unraid.net/topic/138498-gigabyte-b760m-gaming-x-ddr4-messung-und-sata-erweiterung/Und werde Mal BIOS Updaten und schauen ob ich das replizieren kann. Ich sollte ohne SATA und pcie Karte doch auf weniger kommen..
 
Zuletzt bearbeitet:
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Führe erstmal In der commandline folgendes aus: powertop --auto-tune

Und dann schau nochmal das normale Powertop an ob du jetzt was siehst. Wenn da immer noch nix gutes steht dann stimmt mit hoher Wahrscheinlichkeit was im BIOS nicht.
 
ok, jetzt hab ichs glaub ich mal auf einen Wert geschafft, mit dem ich gut leben kann.
Im BIOS hatte ich die diversen C states auf auto, aber muss auf enabled
mit auto-tune bin ich dann auf 19/21W gekommen (headless/hdmi) aber auch nur C3 als maximalen C-State
mit seagate PSU dann auf 15.5W (headless)
mit abgeschalteten onboard NIC dann auf ~13,5 (hdmi) und die C-States gingen bis C8.
dann hab ich ASPM brutal dem realtek treiber aufgezwungen ->
Code:
echo 1 | sudo tee /sys/bus/pci/drivers/r8169/0000\:03\:00.0/link/l1_2_aspm
und jetzt komm ich headless auf C10 und so 12.2 W
Alle Geräte scheinen jetzt auch ASPM eingeschalten haben:
Code:
root@proxmox:~# lspci -vv | awk '/ASPM/{print $0}' RS= | grep --color -P '(^[a-z0-9:.]+|ASPM )'
00:06.0 PCI bridge: Intel Corporation 12th Gen Core Processor PCI Express x4 Controller #0 (rev 02) (prog-if 00 [Normal decode])
                LnkCap: Port #5, Speed 16GT/s, Width x4, ASPM L1, Exit Latency L1 <16us
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes, Disabled- CommClk+
00:1c.0 PCI bridge: Intel Corporation Device 7a38 (rev 11) (prog-if 00 [Normal decode])
                LnkCap: Port #1, Speed 8GT/s, Width x1, ASPM L0s L1, Exit Latency L0s <1us, L1 <4us
                LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes, Disabled- CommClk-
00:1c.2 PCI bridge: Intel Corporation Device 7a3a (rev 11) (prog-if 00 [Normal decode])
                LnkCap: Port #3, Speed 8GT/s, Width x1, ASPM L1, Exit Latency L1 <64us
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes, Disabled- CommClk+
pcilib: sysfs_read_vpd: read failed: No such device
01:00.0 Non-Volatile memory controller: Silicon Motion, Inc. SM2262/SM2262EN SSD Controller (rev 03) (prog-if 02 [NVM Express])
                LnkCap: Port #0, Speed 8GT/s, Width x4, ASPM L1, Exit Latency L1 <8us
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes, Disabled- CommClk+
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8125 2.5GbE Controller (rev 05)
                LnkCap: Port #0, Speed 5GT/s, Width x1, ASPM L0s L1, Exit Latency L0s unlimited, L1 <64us
                LnkCtl: ASPM L1 Enabled; RCB 64 bytes, Disabled- CommClk+
Super, danke für die ganzen tollen Beiträge hier, bin happy.
 
Ich habe eine Idee um den Idleverbrauch ohne Softwareänderung weiter zu senken.

Ich hab jetzt auch noch mal Debian ohne alles getestet.
Da hab ich 1.4 Watt.
Und die 1.7 Watt sind mit KD-302 an der Steckdose gemessen.

Bei diesen Werten hat das Netzteil vielleicht noch eine Effizienz von 50%.

Der ProDesk benötigt 20V. Einfach eine Batterie daszwischen schalten, die erst bei 20% mit maximalen Strom auf 80% geladen wird. Das Netzteil hat dann seine beste Effizienz von 89%.

Der Idle Tagesverbrauch sollte sich dann nochmal halbieren.
 
Das wird nicht funktionieren. Laden und Entladen der Batterie ist nicht besonders effizient und verursacht zusätzliche Verluste/Kosten. Halbwegs aktuelle Netzteile haben allerdings einen Burst-Mode. Bei dem arbeiten sie nur ein paar Millisekunden, laden die Ausgangskondensatoren nach und legen sich dann wieder schlafen. Wichtiger ist es daher, das Netzteil nicht überzudimensionieren. Die restlichen Verluste (EMV, Schutzbeschaltungen, ect.) wird man kaum vermeiden können.
 
Hallo, habe mich dazu entschieden, mein altes B85+4790k NAS durch was neues zu ersetzen. Wenn ich mir meine letzten Posts anschauen, dann ist das tatsächlich 10 Jahre her...

Dieses System hier teste ich gerade:

MB: Gigabyte H610I DDR4
CPU: Intel Core i5-13400
RAM: Crucial Ballistix 2x32GB DDR4-3600 CL16 (2666@1.2V)
SSD: Intel SATA 530 120 GB
Netzteil: PicoPSU 150 XT + Leicke ULL 156W 12V 13A
OS: Debian 12
Messgerät: Energy Check 3000

Angeschlossen ist nur LAN und Strom. Kein Monitor, Maus usw.

Der Verbrauch ist ungefähr bei 3 W. Schwankt zwischen 2.8 und 3.2 W. Setze ich den RAM auf 3200@1.35V bin ich zwischen 3.0 und 3.4 W. Windows 10 und Debian 12 sind da ziemlich gleich beim Verbrauch.

Ein Cinebench R23 bringt das System auf ungefähr 150 W. Prime95 sogar auf 180 W (getestet mit FSP FlexGURU 300 W). Ich möchte die PicoPSU hier gerne durch was Leistungsstärkeres ersetzen, finde aber leider kein gescheites Netzteil, das bei geringer Last effizient arbeitet. Habe mir das FSP FlexGURU 300 bestellt, weil das von den Werten her recht gut aussah (87.58 % Effizienz bei 20 % Last) doch während die PicoPSU 5.4 W verbraucht, benötigt das FlexGURU 10.9 W (gleiches Setup). Hätte gerne mal das RM550x ausprobiert, ist aber leider nicht verfügbar. Hat da vielleicht jemand einen Tipp? Hat vielleicht jemand mal das Cooler Master MWE 400 mit Lasten < 20 W ausprobiert?

Die PicoPSU macht mittlerweile optisch keinen guten Eindruck, da sie auch mit dem älteren B85+4790k System immer wieder mal an ihre Grenze gekommen ist. Bei 150 W werden die Stecker brutal heiß.
 

Anhänge

  • 1.jpg
    1.jpg
    995,1 KB · Aufrufe: 116
  • 2.jpg
    2.jpg
    925,8 KB · Aufrufe: 119
  • 3.jpg
    3.jpg
    85,3 KB · Aufrufe: 96
  • 4.jpg
    4.jpg
    177,5 KB · Aufrufe: 106
Kann man PL1 und PL2 nicht im BIOS begrenzen?
 
Zuletzt bearbeitet:
Die PicoPSU macht mittlerweile optisch keinen guten Eindruck, da sie auch mit dem älteren B85+4790k System immer wieder mal an ihre Grenze gekommen ist. Bei 150 W werden die Stecker brutal heiß.
Bei nem 24/7 System könntest Du auch die 12V vom ext. Netzteil "direkt" mit dem CPU Stromstecker verbinden d.h. vor dem PicoPSU eingang die 12V abzwacken Y-Adapter oder so.

Oder halt auf sparsam trimmen. Brauchst Du beim server den turbo-Mode? Der erhöht den Spitzverbrauch brutal. Beid er Konfig sollten unter 100W vollast möglich sein, wenn Du nicht das max. raus quetschen musst
 
Hallo, habe mich dazu entschieden, mein altes B85+4790k NAS durch was neues zu ersetzen. Wenn ich mir meine letzten Posts anschauen, dann ist das tatsächlich 10 Jahre her...

Dieses System hier teste ich gerade:

MB: Gigabyte H610I DDR4
CPU: Intel Core i5-13400
RAM: Crucial Ballistix 2x32GB DDR4-3600 CL16 (2666@1.2V)
SSD: Intel SATA 530 120 GB
Netzteil: PicoPSU 150 XT + Leicke ULL 156W 12V 13A
OS: Debian 12
Messgerät: Energy Check 3000

Angeschlossen ist nur LAN und Strom. Kein Monitor, Maus usw.

Der Verbrauch ist ungefähr bei 3 W. Schwankt zwischen 2.8 und 3.2 W. Setze ich den RAM auf 3200@1.35V bin ich zwischen 3.0 und 3.4 W. Windows 10 und Debian 12 sind da ziemlich gleich beim Verbrauch.

Ein Cinebench R23 bringt das System auf ungefähr 150 W. Prime95 sogar auf 180 W (getestet mit FSP FlexGURU 300 W). Ich möchte die PicoPSU hier gerne durch was Leistungsstärkeres ersetzen, finde aber leider kein gescheites Netzteil, das bei geringer Last effizient arbeitet. Habe mir das FSP FlexGURU 300 bestellt, weil das von den Werten her recht gut aussah (87.58 % Effizienz bei 20 % Last) doch während die PicoPSU 5.4 W verbraucht, benötigt das FlexGURU 10.9 W (gleiches Setup). Hätte gerne mal das RM550x ausprobiert, ist aber leider nicht verfügbar. Hat da vielleicht jemand einen Tipp? Hat vielleicht jemand mal das Cooler Master MWE 400 mit Lasten < 20 W ausprobiert?

Die PicoPSU macht mittlerweile optisch keinen guten Eindruck, da sie auch mit dem älteren B85+4790k System immer wieder mal an ihre Grenze gekommen ist. Bei 150 W werden die Stecker brutal heiß.
Das be quiet! PURE POWER 12 M 550W ist gerade bei Notebooksbilliger im Angebot.
Alternative wäre PL1 und PL2 zu begrenzen. Die Einstellung gibt es ja im BIOS.

Ich habe mir jetzt aus den Warehouse Deals ein Gigabyte H610I DDR4 bestellt.

Mein Testsystem:
- Gigabyte H610I DDR4 (aktuellstes BIOS F30)
- Intel i3 12100 boxed (Turbo deaktiviert)
- 1x 16GB Crucial DDR4-3200 @ DDR4-2400
- PicoPSU 160W + Leicke ULL NT03015 12V 120W
- Samsung 840 Pro 128 GB

Ich komme aber auf minimal 4,7 Watt mit Package-State C10 mit Debian 12 nur mit Netzwerkkabel und einer SSD.
Wie kommst du auf 3 Watt? Hast du noch etwas außer den Standardsachen wie C-States und ERP im BIOS eingestellt?
Außerdem habe ich das Problem, dass lspci -vvv bei mir keine detaillierte Informationen wie den ASPM Status anzeigt.
 
Danke für eure Antworten. Ich denke, ich werde es erst mal bei der PicoPSU belassen und drosseln. Vielleicht kommen ja demnächst mal effizientere Netzteile.

Ich komme aber auf minimal 4,7 Watt mit Package-State C10 mit Debian 12 nur mit Netzwerkkabel und einer SSD.
Wie kommst du auf 3 Watt? Hast du noch etwas außer den Standardsachen wie C-States und ERP im BIOS eingestellt?
Außerdem habe ich das Problem, dass lspci -vvv bei mir keine detaillierte Informationen wie den ASPM Status anzeigt.
Bei mir war ein "powertop --auto-tune" notwendig, ansonsten war der Verbrauch ca. 2 W höher. Ich weiß jetzt nicht, wie effizient der i3-12100 im Vergleich zu dem i5-13400 ist. Laut diesem Test hier, ist der i5-13400 sparsamer als der i3-13100. Wie sich der i3-12100 da einreiht, kann ich nicht sagen. Jedenfalls sollte er sparsamer sein, als in dem verlinkten Test.

Ich habe im BIOS die üblichen C-states eingeschaltet. Ausgeschaltet habe ich noch Audio device, GNA, Power loading und IO ports. ErP habe ich erst nach dem Test eingeschaltet, das sollte aber nur für Power-Off relevant sein. Unter Linux war es auch nicht relevant, ob ich VMD einschalte. Unter Windows ließ sich der RST Treiber nicht ohne VMD installieren. Lüfter sind bei mir bei niedrigen Temperaturen aus.

Nachtrag: Es stellt sich auch die Frage, wie genau wir hier eigentlich messen. Vielleicht misst dein Messgerät 1 W zuviel und meins 1 W zu wenig. Wenn ich den Thread hier sehe, dann zeigt das Energy Check 3000 wohl zu wenig in dem Bereich an.
 
Zuletzt bearbeitet:
Danke für eure Antworten. Ich denke, ich werde es erst mal bei der PicoPSU belassen und drosseln. Vielleicht kommen ja demnächst mal effizientere Netzteile.
Könntest ja auch auf ein größeres Modell wechseln: z.B. M4-ATX

oder hdplex-200w-dc-atx-power oder HDPLEX 500W HiFi DC-ATX

Ich habe das 800W Modell im Schrank, aber noch keine zeit das mal bzgl. Wirkungsgrad im Bereich unter 10W zu messen. Man braucht halt ein gutes Netzteil auf der anderen Seite, um konkurrieren zu können. Ein paar Diagramm gibt es auf der Website
 
oder hdplex-200w-dc-atx-power oder HDPLEX 500W HiFi DC-ATX

Ich habe das 800W Modell im Schrank, aber noch keine zeit das mal bzgl. Wirkungsgrad im Bereich unter 10W zu messen. Man braucht halt ein gutes Netzteil auf der anderen Seite, um konkurrieren zu können. Ein paar Diagramm gibt es auf der Website

Mich würde die Idle Effizienz <10W der HDPLEX Modelle im Vergleich zu einer 160er PicoPSU sehr interessieren, hat dazu jemand Erfahrung?

https://hdplex.com/hdplex-fanless-250w-gan-aio-atx-psu.html
Das Modell wäre perfekt wenn es mit der Effizienz einer PicoPSU im Idle mithalten kann. Kein externes Netzteil mehr.
 
Es gibt hier auch eine Tabelle zu dem HDPlex 250w GAN. Da fällt mit niedriger Last die Effizienz auch rapide ab.
 
Moin moin,
ich hab in dem Thread hier schon recht viel zu den N100 Boards von ASrock und von Komplettsystemen aus China gelesen. Eventuell hab ich es auch übersehen, aber hat jemand mal eins von den China Boards mit 4 Nics und 6 Sata Anschlüssen von Topton o.Ä. durchgemessen?
 
Ich hänge bei meinem ProDesk 400 G5 mit Proxmox und einer HomeAssistant VM bei 5W fest.

Das Power-Management des 8169 NIC habe ich durch:

GRUB_CMDLINE_LINUX_DEFAULT="quiet pcie_aspm=force pcie_aspm.policy=powersupersave r8168.aspm=1"

aktivieren können, aber powertop PKG HW kommt nicht unter C3



Code:
Pkg(HW)  |            Core(HW) |            CPU(OS) 0
                   |                     | C0 active   0.6%
                   |                     | POLL        0.0%    0.0 ms
                   |                     | C1          0.2%    0.2 ms
2 (pc2)    1.9%    |                     |
3 (pc3)   94.5%    | C3 (cc3)    0.0%    | C3          0.0%    0.2 ms
6 (pc6)    0.0%    | C6 (cc6)    0.1%    | C6          0.1%    0.5 ms
7 (pc7)    0.0%    | C7 (cc7)   98.4%    | C7s         0.0%    0.0 ms
8 (pc8)    0.0%    |                     | C8          2.2%    2.6 ms
9 (pc9)    0.0%    |                     | C9          0.2%    6.2 ms
10 (pc10)  0.0%    |                     |


Kann mir da jemand einen Tip geben?

Update:
Das "echo" hat auch hier funktioniert. Hatte ich überlesen.

Nun geht es immer unter 5W. Im Schnitt so 4.6W

Bash:
echo "1" > /sys/bus/pci/drivers/r8169/0000\:02\:00.0/link/l1_aspm


Code:
Pkg(HW)  |            Core(HW) |            CPU(OS) 0
                    |                     | C0 active   1.3%
                    |                     | POLL        0.0%    0.0 ms
                    |                     | C1          0.0%    0.0 ms
C2 (pc2)    7.1%    |                     |
C3 (pc3)    8.3%    | C3 (cc3)    0.0%    | C3          0.0%    0.2 ms
C6 (pc6)    0.8%    | C6 (cc6)    0.3%    | C6          0.3%    0.6 ms
C7 (pc7)    0.0%    | C7 (cc7)   97.8%    | C7s         0.0%    0.0 ms
C8 (pc8)    8.8%    |                     | C8          5.1%    2.4 ms
C9 (pc9)    0.8%    |                     | C9          0.9%   19.0 ms
C10 (pc10) 67.6%    |                     |
                    |                     | C10        92.6%   24.2 ms
                    |                     | C1E         0.2%    0.4 ms

Jetzt geht auch die CPU Temperatur von 40 Grad (mit performance (default) frequency govenor) auf fast 30 Grad runter
 
Zuletzt bearbeitet:
Mit ein bisschen basteln habe ich meinen neuen HP Prodesk 400 G5 Mini (Intel i5-9500T, 16GB Ram, 256GB NVMe) auf C10 und weit unter 5W (vermutlich 1-3W, TS011F kann so niedrige Ströme nicht) bringen können.
Verbunden ist dabei
  • Strom
  • LAN
  • 2x8GB RAM
  • 256GB NVMe
  • Lüfter
und es handelt sich um eine nackte Proxmox 8.2 Installation.
Hier schön zu sehen, dass ab ca. 13 Uhr mit dem Fix des Realtek ASPM Fehlers die Werte von ~5 Watt auf kaum messbar im Idle gegangen sind.
1714125217739.png


Hier eine kleine Anleitung:
  1. BIOS (Version: R23 Ver. 02.07.01) - aus alles aus was nicht gebraucht & energiesparende Optionen an was geht
  2. Proxmox 8.2 installieren
  3. Helper Scripte https://tteck.github.io/Proxmox/
    1. Proxmox VE Post Install & Proxmox VE CPU Scaling Governor
  4. grub anpassen
    1. Code:
      nano /etc/default/grub
    2. Diese Zeile entsprechend anpassen
      Code:
      GRUB_CMDLINE_LINUX_DEFAULT="quiet pcie_aspm=force pcie_aspm.policy=powersupersave"
    3. Code:
      update-grub
  5. Realtek r8169 verhindert alles größer C3 Fix (mein Hauptproblem)
    1. Code:
      crontab -e
    2. So anpassen
      Code:
      reboot (sleep 60 && echo "powersave" | tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor && echo "1" > /sys/bus/pci/drivers/r8169/0000\:02\:00.0/link/l1_aspm)
  6. Powertop
    1. Code:
      apt-get install powertop
      powertop --auto-tune
  7. Code:
    Reboot
  8. Ein paar Minuten warten (5. wird erst nach 60s aktiv)
Danach sollte
Code:
powertop
in etwa so aussehen
1714057922083.png


Das der Lüfter dauerhaft an ist, macht so natürlich keinen Sinn - hat jemand das Ding auf passiv oder teilpassiv umgebaut?
Einfach abstöpseln geht leider nicht - das sorgt für eine BIOS Meldung bei jedem Boot, die bestätigt werden will.
 
Zuletzt bearbeitet:
Gibt es eigentlich bei den Micro PCs große Verbrauchsunterschiede zwischen den Herstellern? Ich habe selbst einen HP Pro Desk G5, mich würden aber die Dell-Micros interessieren.
Leider finde ich im Internet wenige konkret Beispiele zu Optiplex 3070, 3080, 7070, 7010 usw. Habt ihr Erfahrungswerte?
 
Gibt es eigentlich bei den Micro PCs große Verbrauchsunterschiede zwischen den Herstellern? Ich habe selbst einen HP Pro Desk G5, mich würden aber die Dell-Micros interessieren.

Dell habe ich nicht aber Fujitsu Esprimos im 30W Thread:
Klick Mich

Der Link oben ist für einen Fujitsu Esprimo Q556/2. Ich habe auch noch einen Q957 der identische Werte liefert (aber wegen Intel Netzwerk Chip unproblematischer bzgl. ASPM ist).

2,7W im Idle.
 
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Zurück
Oben Unten refresh