Aktuelles
  • Hallo Gast, heute Nacht ab ca. 0 Uhr stehen geplante Wartungsarbeiten am Server von Hardwareluxx an. Es wird eine kurze Downtime von ca. 20 bis 60 Minuten geben.

Samsung 980 Pro Treiber Frage ( PM9A1 Firmware OEM, Write Performance Fix)

Kullberg

Computer Schach Freak
Thread Starter
Mitglied seit
18.02.2005
Beiträge
5.112
Ich hab mir eine Samsung 980 Pro für mein neues X570 Mobo gegönnt. Die funktioniert soweit auch einwandfrei. Nur wenn ich versuche, den NVMe Treiber von Samsung zu installieren, kommt die Meldung, es sei keine entsprechende SSD vorhanden. Hab die neueste Version 3.3 auch versucht.
Was läuft da falsch?
 
Lösung

Mo3Jo3

Experte
Mitglied seit
01.08.2017
Beiträge
2.893
Ort
ganz im Westen
Hast du es mit Magician versucht? Falls ja, mach es mal über den Gerätemanager und manuellem Download.
 

Anhalter

Enthusiast
Mitglied seit
11.03.2007
Beiträge
870
Ort
München des Ostens
Ähnliches Problem hier.
Die 980Pro kommt laut Magician auf 6800 read 1100 write
Die SN750 kommt auf 3200 read 3000 write
IOPS bei beiden um die 300k/300k

Hängen beide am PCIE 4 auf einem X570 mit 5900X.

Wenn du ne Lösung findest, lass es mich bitte wissen. Ich werde das ebenso handhaben.

beste Grüße.
 

Mo3Jo3

Experte
Mitglied seit
01.08.2017
Beiträge
2.893
Ort
ganz im Westen
@Anhalter
Hast du die Slots mal getauscht. Eine SSD läuft über den Chipsatz und eine über die CPU.
Und aktuellen Chipsatztreiber installiert?
 

Anhalter

Enthusiast
Mitglied seit
11.03.2007
Beiträge
870
Ort
München des Ostens
@Mo3Jo3 Slots getauscht noch nicht, die 980 Pro ist aber im 1er M.2. Das ist der, welcher direkt an der CPU hängt. Da das auch die Systemplatte versuche ich auch erstmal andere Mittel.
Chipsatztreiber etc habe ich gestern (nochmal) alles aktuelle installiert was ich finden konnte. Keine Veränderung.
 

Mo3Jo3

Experte
Mitglied seit
01.08.2017
Beiträge
2.893
Ort
ganz im Westen
War grade nochmal auf der Samsung Seite. Es gibt tatsächlich noch keinen Treiber zum Downloaden? Welcher Treiber wird denn bei Windoof installiert? Ist da schon ein vorläufiger Treiber verfügbar gewesen?
 

Andy_20

Enthusiast
Mitglied seit
12.01.2004
Beiträge
1.989
Habe seit heute auch eine 980 Pro im System, die 970 EVO Plus hat den 3.3.0.2003 Samsung NVMe-Treiber, die 980 Pro hat "Standardmäßiger NVM Express-Controller" von Microsoft Version 10.0.19041.546. Die Werte in Magician oder anderen Programmen sind aber wie zu erwarten, an einer "noch" mit PCIe 3 angeschlossener SSD.
 

firebull

Experte
Mitglied seit
03.12.2014
Beiträge
40
Welcher Treiber ist das genau "RST Premium Intel NVME Treiber" bzw wo finde ich den?
Habe einen HP ProDesk 400 G6 mit Intel Core i7 - da sollte der Treiber ja dazu passen mit der neuen 980 Pro, aber ich habe keine Anhnung wo ich den passenden Treiber finde.

Danke!
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Wer Intel nutzt, sollte die 980 Pro derzeit über den RST Premium Intel NVME Treiber laufen lassen, dieser ist um einiges performanter als dieser generische Standard NVME Treiber, der bei Windows 10 dabei ist.

AMD X570 nutzer haben keine Wahl, also bis Samsung mal nen Treiber bringt der die 980 Pro auch unterstützt. Ich habe keine Performanzprobleme, mit dem Intel RST Premium Treiber komme ich auf maximale PCIe 3.0 Werte, wie in dem einen Bild, die PCIe 4.0 Werte auf dem X570 Brett zeigt das andere Bild, wobei ich X570 nicht mehr besitze bzw. wieder verkauft habe.

Geht doch mit Samsung Treiber für die 980Pro und PM9A1, wenn man den roh Treiber aus dem install-exe bekommt.

Und zwar so:


Den original Samsung Driver 3.3, aus dem Link oben, kann man installieren und funktioniert. An der Performance tut sich nicht viel. Samsung Magician kann dann die Temperatur nicht mehr lesen und bietet auch keine weiteren Feature an. CrystalDiskInfo kann die Temperatur aber immer noch lesen.

Hier Tests mit PM9A1 2T (OEM 980pro)

Mit Samsung Treiber.

1612281339382.png


Mit generischem Treiber:
1612281383793.png


Mit gedrosselt auf PCIe3 wird die SSD nicht so heiß:

1612281433634.png



BTW: Der zweite M.2 Port am X570 mit PCIe4 x2 ist langsamer als PCIe3 x4.
(Ich habe PCIe3x4 oder PCIe4x4 über die PCI Slot am X570 noch nicht getestet. Könnte dort auch so langsam sein)

2021-02-02 17_04_27-CrystalDiskMark 8.0.1 x64 [Admin].jpg



PS: Die PM9A1 ist wohl bei RND4k nicht so stark. An 4000 kommt bei mir kein Test ran. Hängt immer unter1600
 
Zuletzt bearbeitet:

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Die zweiten M.2 Slots von den MB's sind nichts für PM9A1.
Da kommt bei zwei verschiedenen X570 MB's nur PCIe4x2 bzw. PICe3x4 an.

Über eine PCI Karte für mehrere M.2 bekommt man fast die volle PCIe4 x4 Performance.

Das Gute: Auch eine 3 Jahre alte PCI Karte für 2 M.2 schafft PCIe4 x4.



2021-02-02 22_43_23-CrystalDiskMark 8.0.1 x64 [Admin].jpg
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Ich habe gerade bemerkt, das die PM9A1 im Windows Safe-Mode bei RND4K Q32T16 60% schneller ist.

Und ich habe bemerkt das meine System PM9A1 beim Schreiben langsam geworden ist, egal ob im Safe oder normal Windows.
Als ob der SLC Cache voll ist und er nicht aufgeräumt wird.

Habe schon Disk Optimieren (trim) ausgeführt und auch die standard Treiber versucht. Kein Unterschied.,
 

Anhänge

  • 2021-02-05 15_36_46-CrystalDiskMark 8.0.1 x64 [Admin] SafeMode PCIe4x4 PCI-Karte.jpg
    2021-02-05 15_36_46-CrystalDiskMark 8.0.1 x64 [Admin] SafeMode PCIe4x4 PCI-Karte.jpg
    39,4 KB · Aufrufe: 164
  • 2021-02-05 15_47_30-CrystalDiskMark 8.0.1 x64 [Admin] SafeMode M2_1.jpg
    2021-02-05 15_47_30-CrystalDiskMark 8.0.1 x64 [Admin] SafeMode M2_1.jpg
    39,4 KB · Aufrufe: 164

Holt

Legende
Mitglied seit
05.07.2010
Beiträge
24.671
im Windows Safe-Mode bei RND4K Q32T16 60% schneller ist.
Sie schreibt ja sequentiell auch schneller, vrmutlich war bei dem Test im normalen Modus der Pseudo-SLC Schreibcache voll. Zum Benchen macht man am Besten einen Reboot, wartet bis die Hintergrundprozesse sich beruhigt haben (ggf. den Netzwerkstecker vorher ziehen, damit nicht im Hintergrund ein Update läuft) und dann Bencht man einmal.

Schau Dir auch mal wie stark die 4k Q1T1 Lesend gestiegen sind. Dies liegt daran das im Abgesicherten Modus viele Energiespareinstellungen nicht aktiv sind. Übrigens dient das Feld ganz unten zum Schreiben eines Kommentars der dann auf dem Screenshot erscheint, so dass man in genau solchen Fällen die Schreinshots dann auch einfach unterscheiden kann.
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Bin nicht alleine bezüglich des Slow-Writes:


Der SLC ist voll und die SSD will ihn nicht mehr leer machen. Wenn ihr die 980Pro wirklich benutzt, dann sollte das nach so 2 Wochen soweit sein. Gibt noch keine Lösung. Also warten auf Firmwareupdate.
 
Zuletzt bearbeitet:

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Im abgesicherten Modus hat sie das aber offenbar, da schreibt sie ja deutlich schneller als es ohne Pseudo-SLC Cache geht.
Moment, das sind 2 ssd. Sieht man am image file namen, dem füllstand und dem laufwerks namen. Hatte beide in safe gebencht.
 

Holt

Legende
Mitglied seit
05.07.2010
Beiträge
24.671
Dann beschreibe bitte künftig besser was genau wie gebenchmarkt wurde. Wie gesagt gibt es dazu unten eine Feld für Kommentare.
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Ich habe den Grund für den Unterschied RND4K zwischen Safe und Standard-Windows 10 gefunden.

Das ist das useplatformclock setting im bcdedit. Einfach bcdedit eingeben um zu sehen ob es gesetzt ist.

Irgendwas hat das in meinem System gesetzt.
Muss irgendein tool, monitor oder benchmark gewesen sein.
Keine Ahnung was es war. Ich habe es selbst jedenfalls nie gesetzt.

Ich habe es mit:
bcdedit /set useplatformclock false

zurückgesetzt. Und nun sehen die RND4K super aus.

Ich attache mal die Bilder für die System-PM9A1 C: und die, noch neue, Datenbank-PM9A1 D: auf einer PCI-Karte.
BTW: 1G Testsize oder 64G machen keinen Unterscheid in den Testergebnissen. Ich nutze nur noch 1G, damit ich den SLC Cache von D nicht so schnell fülle.

Die System-PM9A1 will beim Schreiben aber nicht mehr schneller als 2G/s werden.

Die Tests sind mit dem Standard NVME gemacht, da mir die Samsung NVME Driver nach dem Drop der Write-Performance suspekt wurden. Samsung Magician hat mit denen auch Probleme, wie z.B. keine Temperatur und ganz falscher freier Platz.




2021-02-07 04_40_17-CrystalDiskMark 8.0.1 x64 [Admin] Std useplatformclock no C.jpg
2021-02-07 04_46_20-CrystalDiskMark 8.0.1 x64 [Admin] Std useplatformclock no D PCI-Karte .jpg
 
Zuletzt bearbeitet:

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Das mit den 2G/s bei der Systemplatte ist "normal"

https://www.tomshardware.com/reviews/samsung-980-pro-m-2-nvme-ssd-review

"After half an hour of idle time, Samsung's 980 Pro only recovered 6GB of the TurboWrite cache. So, instead of immediately recovering, it may take a few hours of idle time to refresh fully."

Denke mal, das eine System-Platte nie idle ist, und so sich der TurboWrite nicht mehr recovern kann.
Ich lege meinen PC auch in sleep, wenn ich ihn nicht mehr benutzte.
Ob man irgendwie die PCIe devices weiter mit Strom versorgen kann?
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Das Problem mit den "nur" 2G/s auf der Systemplatte ist gelöst.

Ein Sichern und Überschreiben der 2T erst mit dd, was leider nicht funktioniert hatte, und dann mit System Restore hat die PM9A1 wieder schnell gemacht.


2021-02-10 05_14_44-CrystalDiskMark 8.0.1 x64 [Admin] Std after Re-Imaging C.jpg


Ich würde davon abraten, den Samsung NVME Treiber für die 980 Pro oder PM9A1 zu benutzen.

Ich vermute, das der Treiber in der SSD Sachen einstellt, die dort so nicht funktionieren.
 

thb

Enthusiast
Mitglied seit
25.07.2006
Beiträge
788
Es hat auch sicherlich seine Gründe, warum Samsung den Treiber noch nicht für die 980Pro freigegeben hat.
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Hatte vorgestern wieder den Drop auf nur 2G/s. Nach 19 Tagen ruhe. Hatte jeden Tag einen Test gemacht.
Ist zwischen zwei Writetests nach 5G/s auf 2G gefallen. Da hatte ich gerade wieder den Samsungtreiber genutzt.

Ein SystemRestore hats wieder gerichtet.

Nutze jetzt den Intel Data Center IaNVME Treiber. Ist ein Tick schneller bei Q1T1 und aktiviert alle 130 Irq's wie der Samsung Treiber und unterstützt nvme 1.3
 

MoBo 01/04

Enthusiast
Mitglied seit
26.06.2004
Beiträge
2.971
Ort
HH
Er hat doch eine P9MA1, also ein OEM-Modell. Direkt von Samsung dürfte es dafür keine Firware-Updates geben. Ist dir eine andere Quelle bekannt?
 

thb

Enthusiast
Mitglied seit
25.07.2006
Beiträge
788
Samsung hat jetzt immerhin wahrgenommen, dass einige der 980Pro ein Problem mit dem Leeren des SLC Cache haben und dann dauerhaft nur noch eine deutlich verringerte Schreibrate haben.
 

Holt

Legende
Mitglied seit
05.07.2010
Beiträge
24.671
Es gibt bei der 980 und 980 Pro wohl jetzt mit dem neusten Magician die Möglichkeit die Energiesparoptionen zu deaktivieren, was die Leistung steigert und vielleicht hilft das der Pseudo-SLC Schreibcache schneller geleert wird und damit die Schreibgeschwindigkeit dann schneller wieder hoch ist.
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Das kann man sicher auch durch den PowerSettingsExplorer im Windows Powerprofil setzten.

Da gibts einige Nvme und ssd pcie settings.

Hatte alle Hidden Settings aktiviert und dann kann man die im Standard Advance Power Options setzen/ändern.
Da kann man z.B. setzten das eine pcie ssd nur von host ins schlafen gehen darf, und nicht von sich selbst.
Und sowas ab wieviel Millisekunden die ssd in verschiede Sleepstates wechselt.
 

King Bill

Administrator Xenforodeluxx
Hardwareluxx Team
Mitglied seit
16.06.2005
Beiträge
30.254
Nutze jetzt den Intel Data Center IaNVME Treiber. Ist ein Tick schneller bei Q1T1 und aktiviert alle 130 Irq's wie der Samsung Treiber und unterstützt nvme 1.3

Hast du einen Link?

Hatte bisher noch keine Leistungseinbrüche mit der PM9A1 und dem Standard Microsoft NVME Treiber.
 

SimonX200

Profi
Mitglied seit
07.07.2019
Beiträge
171
Intel Data Center Driver


Ich lasse den IaNVME als Intel(R) SSD Pro 7600p/760p/E 6100p Series gegen die PM9A1 laufen.
Hab mir über Geizhalse das ausgesucht, was NVME 1.3 verstehen würde.


2021-03-19 00_37_39-CrystalDiskMark 8.0.1 x64 [Admin] IaNVME+PM9A1 retest C.jpg

Bezüglich der Power Options im Window Power Plan:

Habe
- Hard disk / NVME NOPPME / "on" (glaube: default war "off")
- Hard disk / AHCI Link Power Managemt / "HIPM/DIPM" (default war "HIPM")
- Hard disk / AHCI Link Power Management - Adaptive / 100ms

eingestellt.

Seit dem 25.2 kein Einbruch mehr.
 
Zuletzt bearbeitet:
Oben Unten