Aktuelles

Netzwerkgeräte funktionieren nicht Ubuntu (Hardy)

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
System ist ein Samsung R510 Melroi mit ubuntu-8.04.1-desktop-i386

Die Installation klappte, allerdings geht es jetzt daran so simple dinge wie Netzwerk und Grafik zum laufen zu bekommen.


Marvell Technology Group Ltd. 88E8055 PCI-E Gigabit Ethernet Controller (rev 13)

Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)

Das sind die beiden Netzwerkschnittstellen die mir zumindest die Hardwareüberprüfung unter Ubuntu anzeigt. Aber weder tut sich was an der Lan Schnittstelle noch kann ich meine Wlan Daten eintragen...weil das einzige was unter Netzewerk sichtbar ist quasi sowas wie Modem...

Kann mir jemand helfen? Vorallem, kann ich ja ohne netz quasi gar nicht auf quellen zugreifen:(
 
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
Die Marvellösung mit dem Marvell Yukon-sk98lin-Treiber für Kernel-Version 2.6.24-19-generic, habe ich schon probiert, der treiber taucht auf unter den diesen eingeschränkten treibern, wo auch der Atheros auftaucht und man diesen Nvidia 3d noch freischalten müsste....

klappt aber immer noch nicht....
---
das mit dem ndiswrapper werde ich heute abend mal testen
 

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
Ich kriege es nicht, es wurmt mich schon ständig, wieder hier auf vista neustarten, damit ich im netz weitersuchen kann :S

Weiß jemand ein Dateinpacket und eine dazupassende Befehlsliste?
 

d1no

Neuling
Mitglied seit
04.05.2007
Beiträge
892
Ort
Paderborn
wlan auch nicht? normalerweise ist das nur folgende schritte:

sudo apt-get install ndiswrapper-utils-1.9 ndisgtk

installieren

dann untere system das installatierte ndis programm starten.

treiber auswählen und es sollte gehen.

damit es bei systemstart immer geladen wird dann noch folgendes machen:

sudo gedit /etc/modules

und dort ndiswrapper hinzufügen und fertig.
 

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
wlan auch nicht? normalerweise ist das nur folgende schritte:

sudo apt-get install ndiswrapper-utils-1.9 ndisgtk

installieren

dann untere system das installatierte ndis programm starten.

treiber auswählen und es sollte gehen.

damit es bei systemstart immer geladen wird dann noch folgendes machen:

sudo gedit /etc/modules

und dort ndiswrapper hinzufügen und fertig.

jetzt blöde gefragt, bevor ich hier jetzt wieder linux boote, verlang apt-get nicht auch wieder eine funktionierende internetverbindung?

Wie gesagt, ich hab gar kein Netzwerk, so dass ich den Laptop unter Linux auch nur irgendwie ins Internet bringen könnte...
 

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
bevor du ndiswrapper-opfer wirst, versuchs mal mit einem aktuellen madwifi-treiber. tolle anleitung scheint hier zu sein:

http://madberry.org/2008/08/how-to-get-atheros-ar242x-wireless-to-work-2/

again, ich habe unter linux momentan kein Netzwerk, so das ich das Notebook sich aus den Repositorys [oder wie die heißen mögen] etwas nachinstallieren kann.

Ich hab nur die nackte, netzwerklose Version, die ich nach der CD Installation des ubuntu-8.04.1-desktop-i386 habe.

Es ist ein Teufelskreis :S
 

d1no

Neuling
Mitglied seit
04.05.2007
Beiträge
892
Ort
Paderborn
jetzt blöde gefragt, bevor ich hier jetzt wieder linux boote, verlang apt-get nicht auch wieder eine funktionierende internetverbindung?

Wie gesagt, ich hab gar kein Netzwerk, so dass ich den Laptop unter Linux auch nur irgendwie ins Internet bringen könnte...

die sachen sind auch glaube ich auf der ubuntu cdrom enthalten. sonst eben unter windows auf einen usbstick downloaden..
 

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
die sachen sind auch glaube ich auf der ubuntu cdrom enthalten. sonst eben unter windows auf einen usbstick downloaden..

Was muss ich dann noch ändern, dass er auf die CD-Rom oder USB Ordner nach diesen Paketen oder was ich immer ändern?

Wie kann ich rausfinden, ob da noch abhängigkeiten hinterhängen?

Ich hab halt nur ein Halbwissen was Linux betrifft und mein letzer Ausflug mit meinem Desktopsystem vor ca einem jahr und ubuntu 7.10 fand auch irgendwann ein ende...nur funkionierte wenigstens die Lan-Schnittstelle au ga-x38-dq6 damals, so das ich unter linux wenigstens nach löungen im netz suchen konnte.
 

gimliy

Neuling
Mitglied seit
07.12.2006
Beiträge
103
packages.ubuntu.com

da stehen auch die abhängigkeiten. lieber ein paar mehr ziehen, als zu wenig :)

danach mit "sudo dpkg -i <paket>.deb" das paket installieren.
 

Kavendish

Enthusiast
Thread Starter
Mitglied seit
05.08.2007
Beiträge
459
Ort
Berlin
Tada, die Anleitung von Gimly hat funktioniert, allerdings muss man wirklich ja jedem Update des System die letzen schritte wiederholen.

und halt sich unter packages.ubuntu.com

die buid essential holen.

Ich werde das mal quasi als ein Paket zusammenpacken und hier uppen, wird ja sicherlich auch andere betreffen, bzw helfen.
 
Zuletzt bearbeitet:
Oben Unten