Seite 146 von 147 ErsteErste ... 46 96 136 142 143 144 145 146 147 LetzteLetzte
Ergebnis 3.626 bis 3.650 von 3669
  1. #3626
    Flottillenadmiral Avatar von hugoLOST
    Registriert seit
    05.05.2007
    Ort
    Wuppertal
    Beiträge
    5.742


    • Systeminfo
      • Motherboard:
      • Asus ROX Strix Z390-F
      • CPU:
      • Intel I9 9900K
      • Kühlung:
      • Be Quiet Silenloop 360
      • Gehäuse:
      • Coolermaster Mastercase 6 Pro
      • RAM:
      • 2x8GB Corsair DDR4 3200MHz
      • Grafik:
      • Asus ROG Strix RTX2070 Advance
      • Storage:
      • 500GB Samsung 970 Pro / 1TB Curcial MX500
      • Monitor:
      • Iiyama B2783QSU
      • Netzteil:
      • Coolermaster Silent Pro 800W
      • Betriebssystem:
      • Win 10
      • Photoequipment:
      • Canon EOS 1300D
      • Handy:
      • Xiaomi Mi A2 128GB

    Standard

    User pi ist der root User und das Password dafür ist raspberry.

    Gesendet von meinem Mi A2 mit Tapatalk
    SYS1: Intel Core I9 9900k, Asus ROG Strix Z390-F, 2x8GB DDR4 Corsair Vengeance 3200Mhz CL16 , Asus ROG Strix 2070 Advanced , Crucial M550 1TB, Coolermaster Silent Gold 800W

  2. Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

  3. #3627
    Obergefreiter
    Registriert seit
    31.05.2005
    Ort
    Mainz
    Beiträge
    86


    Standard

    @HLuxx: Auf /root darf nur root schreiben. Wenn du dich aber via putty verbinden kannst, dann wäre entweder ein "sudo vi /root/etc/openvpn/server.conf" eine Variante um die Datei vor Ort zu erstellen, oder wenn es lieber ist die Datei mit WinSCP nach /tmp oder so kopieren und dann via putty mit "sudo cp /tmp/server.conf /root/etc/openvpn/server.conf" an die richtige Stelle kopieren. Evtl. müssten dann noch via chown & chmod der Owner und die Rechte angepasst werden.

  4. #3628
    Korvettenkapitän Avatar von towatai
    Registriert seit
    12.04.2006
    Ort
    Bremen
    Beiträge
    2.466


    Standard

    Um Dateien unter WinSCP editieren/erstellen/löschen zu können kann man unter den Advanced Settings folgendes einstellen:

    sudo.JPG
    Corsair HX520 | Xeon E3-1230V3 @ 3,7GHz | Cooler Master Nepton 240M AiO WaKü | ASRock Fatal1ty H87 Performance | 8GB RAM | MTRON 32GB SLC / 2x 256GB Crucial M4 | Zotac 1070 ti Mini@Accelero Mono - 1950/4450 - 0,962V| 24" Dell 2408WFPb | X-Fi Forte @ OPAmp-MOD | Win 10 Pro

  5. #3629
    Oberleutnant zur See Avatar von HLuxx
    Registriert seit
    13.07.2014
    Beiträge
    1.444


    • Systeminfo
      • Motherboard:
      • Asus Strix Z270G
      • CPU:
      • Intel I7-7700K
      • Kühlung:
      • Alpenföhn K2
      • Gehäuse:
      • Lian Li V359 (Rot/Schwarz)
      • RAM:
      • G.Skill TridentZ 16GB 3200 MHz
      • Grafik:
      • EVGA GTX 1080 FTW2 iCX
      • Storage:
      • PM981 2TB, MX500 2TB, MX300 750 GB, MX100 512 GB
      • Monitor:
      • Asus PB277Q
      • Netzwerk:
      • Synology DS 918+|QNAP TS-231P
      • Sound:
      • HyperX Cloud Alpha Pro, Creative T20
      • Netzteil:
      • BeQuiet! E9 480 Watt CM
      • Betriebssystem:
      • Win 10 64 Bit
      • Sonstiges:
      • Sidewinder X4, Logitech MX Master, AE 5
      • Notebook:
      • Lenovo T480s
      • Photoequipment:
      • D7200 | Sigma 18-35 Art F1.8 | Nikon Nikkor 50 MM F1.8 G
      • Handy:
      • Galaxy S9 | One Plus X

    Standard

    Hi

    Danke für eure Antworten und sorry, dass ich solange nicht geantwortet habe. Viel mit Arbeit am Hut, wer kennt es nicht. Zum Thema:

    Ich werd´zum Elch, man ey. Was stimmt denn nicht Ich habe den Pi komplett zurück gesetzt: SD Karte raus, formatiert, mit Etcher neues ISO drauf. Alles geupdatet und dann PiVPN installiert (und nur das, um Inkompatibilitäten mit anderen Sachen auszuschließen). Habe nicht einmal das Passwort des Users "pi" geändert. As Stock as possible, quasi. In WinSCP habe ich den Tipp von towatai auch beherzigt, auch wenn das Layout bei mir leicht anders ist (Version 5.15.2 Build 9590)

    cl494sjx.jpg

    Aber irgendwie, tja, ich bin zu blöd denn der Fehler, er bleibt bei mir. Ganz treu

    f8qmie5d.jpg

    Anbei einfach mal ein Screenshot der jetzigen server.conf Datei. Vielleicht erkennt ja einer direkt den Fehler. Dann weiß ich zumindest woran es liegt, auch wenn ich es nicht ändern könnte

    nm82fuc2.jpg

    Ich bin euch sehr dankbar für die ganze Hilfe. Ich habe echt keine Idee mehr warum es so hakt. Das komische ist, dass bei mir zuhause genau das gleiche Set-Up läuft: RPi 3B+, PiVPN (plus Kleinkram). Und da bin ich Schritt für Schritt durch das Kuketz-IT PiVPN Tutorial gegangen, ohne Probleme. Und bei den Eltern, wo man auch nicht jeden Tag ist, gibt es massig Probleme. Klar, muss ja so sein, sonst macht es auch keinen Spaß

    Freue mich über jeden weiteren Tipp. Hoffe, dass wir den Pi gemeinsam noch gefügig bekommen

    LG
    Geändert von HLuxx (20.06.19 um 16:23 Uhr)
    Editing & Gaming:
    Intel i7 7700k / EKL K2 / EVGA GTX 1080 FTW2 iCX / Asus Strix Z270G / G.Skill TridentZ 16GB CL14 3200 MHz / SSD only / be quiet E9 480 Watt CM
    QNAP TS-231P / DS 216 Play (Lesertest) / DS 918+ / Asus Xonar U7 / Asus PB277Q

  6. #3630
    Leutnant zur See
    Registriert seit
    17.10.2011
    Ort
    Hamburg
    Beiträge
    1.048


    Standard

    Hatte die selben Probleme bei mir. Hatte auch nach der Anleitung gearbeitet - DietPi und PiVPN mit PiHole. Verbindung mit VPN Server aber trotzdem kein Internetzugriff.
    Schau mal, ob bei dir net.ipv4.ip_forward=1 gesetzt ist in /etc/sysctl.conf.

  7. #3631
    Oberleutnant zur See Avatar von HLuxx
    Registriert seit
    13.07.2014
    Beiträge
    1.444


    • Systeminfo
      • Motherboard:
      • Asus Strix Z270G
      • CPU:
      • Intel I7-7700K
      • Kühlung:
      • Alpenföhn K2
      • Gehäuse:
      • Lian Li V359 (Rot/Schwarz)
      • RAM:
      • G.Skill TridentZ 16GB 3200 MHz
      • Grafik:
      • EVGA GTX 1080 FTW2 iCX
      • Storage:
      • PM981 2TB, MX500 2TB, MX300 750 GB, MX100 512 GB
      • Monitor:
      • Asus PB277Q
      • Netzwerk:
      • Synology DS 918+|QNAP TS-231P
      • Sound:
      • HyperX Cloud Alpha Pro, Creative T20
      • Netzteil:
      • BeQuiet! E9 480 Watt CM
      • Betriebssystem:
      • Win 10 64 Bit
      • Sonstiges:
      • Sidewinder X4, Logitech MX Master, AE 5
      • Notebook:
      • Lenovo T480s
      • Photoequipment:
      • D7200 | Sigma 18-35 Art F1.8 | Nikon Nikkor 50 MM F1.8 G
      • Handy:
      • Galaxy S9 | One Plus X

    Standard

    Zitat Zitat von sno0k Beitrag anzeigen
    Hatte die selben Probleme bei mir. Hatte auch nach der Anleitung gearbeitet - DietPi und PiVPN mit PiHole. Verbindung mit VPN Server aber trotzdem kein Internetzugriff.
    Schau mal, ob bei dir net.ipv4.ip_forward=1 gesetzt ist in /etc/sysctl.conf.
    Danke, war aktiviert.

    Habe nun zumindest mal raus weshalb ich bei WinSCP stets Probleme hatte: Standardmäßig verbindet sich WinSCP per SFTP mit dem Pi. Dafür ist in den Einstellungen / Erweitert unter den Protokolloptionen beim SFTP Server die Option "Standard" gewählt.

    8nvcbyn9.jpg

    Dort könnte auch ein Zugriff als "sudo su -c /bin/sftp-server" ausgewählt werden, was dann wohl root Zugriff ermöglichen müsste, zumindest meinem Verständnis nach.

    3575249x.jpg

    Versucht man sich damit dann einzuloggen (also mit "sudo su -c /bin/sftp-server" statt "Standard") erhalte ich den nächsten Fehler, es gäbe keinen SFTP Server auf dem Pi. Ok, whatever.

    emm7uv9o.jpg

    Problem nun umgangen und erfolgreich root Zufriff auf die Dateien indem mich halt einfach per SCP statt SFTP verbinde.

    Jetzt nur noch herausfinden was dem PiVPN nicht passt.

    Edit: 40 Minuten später, bin mit meinem Latein am Ende. Viel mit server.conf gespielt, neue OVPN erstellt, importiert, reboot, probieren, fail - and again. Keine Idee was ich noch tun soll
    Geändert von HLuxx (21.06.19 um 17:03 Uhr)
    Editing & Gaming:
    Intel i7 7700k / EKL K2 / EVGA GTX 1080 FTW2 iCX / Asus Strix Z270G / G.Skill TridentZ 16GB CL14 3200 MHz / SSD only / be quiet E9 480 Watt CM
    QNAP TS-231P / DS 216 Play (Lesertest) / DS 918+ / Asus Xonar U7 / Asus PB277Q

  8. #3632
    Vizeadmiral Avatar von 1337_alpha
    Registriert seit
    02.03.2008
    Ort
    Großherzogtum Baden
    Beiträge
    7.867


    • Systeminfo
      • Motherboard:
      • Maximus II Formula
      • CPU:
      • Intel Q6600
      • Systemname:
      • The White Darkness
      • Kühlung:
      • Wasserkühlung
      • Gehäuse:
      • Lian Li V2010b
      • RAM:
      • Corsair Dominator 8GB DDR2-106
      • Grafik:
      • EVGA GTX260
      • Storage:
      • Western Digital Green Caviar 1TB
      • Monitor:
      • Samsung T240HD
      • Sound:
      • Logitech Z-5500
      • Netzteil:
      • Corsair HX620
      • Betriebssystem:
      • Windows 7
      • Photoequipment:
      • Sony DSC-W290
      • Handy:
      • Sony Ericsson K850i

    Standard

    Kennt sich hier jemand mit crontabs aus?

    Ich hab fürs Studium eine Feinstaub Station mit Werteerfassung, LCD Display usw programmiert. Die Feinstaub Station soll an der Hochschule ausgestellt werden, Vorraussetzung dafür ist aber ja dass das jeweilige Python Skript sich mindestens einmal in der Minute selbst ausführt (wenn es abgebrochen wurde), falls mal ein Reboot ausversehen ausgeführt wird oder die WLAN Verbindung abbricht. Ich komm leider seit gestern abend absolut nicht weiter. Das ganze Projekt ist eigentlich schon fertig, es scheitert nur daran.



    So sieht das aus, ich hab allerdings schon gefühlt tausend andere Sachen ausprobiert und er macht einfach garnix.
    Gibt es für so etwas eine Alternative zum cronjob oder übersehe ich eine Kleinigkeit? Wäre ärgerlich wenn es jetzt daran scheitert aber ich bin mit meinem Latein am Ende.
    chmod usw hab ich auch schon ausprobiert.

  9. #3633
    Kapitän zur See Avatar von Daunti
    Registriert seit
    23.01.2012
    Ort
    Dromund Kaas
    Beiträge
    3.762


    • Systeminfo
      • Motherboard:
      • MSI Z370 A
      • CPU:
      • Intel i7 8700k
      • Systemname:
      • Dieter
      • Kühlung:
      • Alpenföhn Olymp
      • Gehäuse:
      • Nanoxia DS6
      • RAM:
      • 16GB Corsair Vengeance LP
      • Grafik:
      • GTX 1070 Asus Strix
      • Storage:
      • 250GB 960 Evo, Sandisk Ultra II 960GB, 2TB HDD
      • Monitor:
      • Asus ROG Swift PG278Q
      • Netzwerk:
      • Fritzbox 6490
      • Sound:
      • BD MMX300 Gen 2 600Ohm, Xonar Phoebus
      • Netzteil:
      • Be Quiet E9 480 Watt CM
      • Betriebssystem:
      • Windows 10 Pro
      • Notebook:
      • HP Elitebook X360/Thinkpad T440p
      • Photoequipment:
      • Sony Alpha 380
      • Handy:
      • Galaxy S9+

    Standard

    Warum überhaupt nen Pi für so ne Aufgabe. Lieber nen ESP.
    Es kann keinen Kompromiss geben. Gnade, Mitgefühl, Loyalität: All diese Dinge halten Euch nur davon ab, zu beanspruchen, was Euch rechtmäßig zusteht.

    Mikrocontroller Sammler

  10. #3634
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    Bin da bei Daunti. Aber warum hast du überhaupt die ganzen cd's vor dem Python Befehl?

    Spricht etwas gegen
    * * * * * python3 ~/luftdaten-python/custom_main.py
    ?
    Geändert von ebastler (23.06.19 um 12:42 Uhr)
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  11. #3635
    Vizeadmiral Avatar von 1337_alpha
    Registriert seit
    02.03.2008
    Ort
    Großherzogtum Baden
    Beiträge
    7.867


    • Systeminfo
      • Motherboard:
      • Maximus II Formula
      • CPU:
      • Intel Q6600
      • Systemname:
      • The White Darkness
      • Kühlung:
      • Wasserkühlung
      • Gehäuse:
      • Lian Li V2010b
      • RAM:
      • Corsair Dominator 8GB DDR2-106
      • Grafik:
      • EVGA GTX260
      • Storage:
      • Western Digital Green Caviar 1TB
      • Monitor:
      • Samsung T240HD
      • Sound:
      • Logitech Z-5500
      • Netzteil:
      • Corsair HX620
      • Betriebssystem:
      • Windows 7
      • Photoequipment:
      • Sony DSC-W290
      • Handy:
      • Sony Ericsson K850i

    Standard

    Zitat Zitat von Daunti Beitrag anzeigen
    Warum überhaupt nen Pi für so ne Aufgabe. Lieber nen ESP.
    Projektvorgaben

    @ebastler
    Danke ich probiers mal aus. Das mit dem cd war eine Nötlösung da ich auch gefühlt alles andere schon ausprobiert hab.
    Ich werde deinen Befehl mal testen aber ich bin mir fast sicher, dass auch dieser nicht ausgeführt wird.

    An was könnte das liegen oder wie kann ich dem auf die Spur kommen?

    edit: Wenn ich den Befehl von oben ausführe dann kommt auch ne Fehlermeldung, daher hab ichs wie siehe oben erst mit cd ins Home verzeichnis gemacht und gehe dann in den Ordner rein.


    Letztenendes tut ja aber beides nicht
    Geändert von 1337_alpha (23.06.19 um 12:45 Uhr)

  12. #3636
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    Ich habe was editiert, da ich einen Knoten im Kopf hatte beim Schreiben des Befehls, Achtung!

    Ist dein Befehl im User oder root cron? Falls letzteres läuft mein Pfad so nicht...

    Falls er im User cron ist, braucht dein Python Script vielleicht root Rechte?
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  13. #3637
    Kapitänleutnant Avatar von sky^xs
    Registriert seit
    26.02.2004
    Ort
    woher ich komme? aus überzeugung!
    Beiträge
    1.962


    • Systeminfo
      • Motherboard:
      • asus rampage iv formula
      • CPU:
      • intel i7-4930k
      • Systemname:
      • tlc18
      • Kühlung:
      • ddc, kyros next, 2x480, 1x240
      • Gehäuse:
      • silverstone tj07
      • RAM:
      • 32gb gskill ares
      • Grafik:
      • gainward rtx 2080ti phoenix gs
      • Storage:
      • 500g samsung 970 evo, 512g samsung 850
      • Monitor:
      • lg 32ud59-b, asus vw246h
      • Netzwerk:
      • chenbro rm414b storage server
      • Sound:
      • jbl esc 300 @ harman kardon avr51
      • Netzteil:
      • be quiet! dark power p10 750w
      • Betriebssystem:
      • w10 pro 64bit, w2012r2, osx
      • Sonstiges:
      • fujitsu kb910, roccat kone +, wacom intuos, xbox 360 controller pc, xbox360, ps4pro, ps3, ps2, psx
      • Notebook:
      • hp zbook, macbook pro 15"
      • Photoequipment:
      • sony f828
      • Handy:
      • iphone SE 64gb, iphone 4 32gb

    Standard

    Kannste das Skript nicht direkt ausführen? Also ohne den CD mumbojumbo? Und bau vielleicht ne Zeile in deinem Skript ein, die
    irgendwas an die Konsole ausgibt, was du dann ggf. mitloggen kannst - oder in eine lokale Datei (z.B. Timestamp des letzten
    Durchlaufs oder so).
    Sitting there watching that powder-blue and orange 917 barreling down the Mulsanne and getting squirrelly
    under braking was the exact moment when I stopped thinking Corvettes were the coolest cars on earth.
    - Don Holloway / Holloway Corvettes

  14. #3638
    Vizeadmiral Avatar von 1337_alpha
    Registriert seit
    02.03.2008
    Ort
    Großherzogtum Baden
    Beiträge
    7.867


    • Systeminfo
      • Motherboard:
      • Maximus II Formula
      • CPU:
      • Intel Q6600
      • Systemname:
      • The White Darkness
      • Kühlung:
      • Wasserkühlung
      • Gehäuse:
      • Lian Li V2010b
      • RAM:
      • Corsair Dominator 8GB DDR2-106
      • Grafik:
      • EVGA GTX260
      • Storage:
      • Western Digital Green Caviar 1TB
      • Monitor:
      • Samsung T240HD
      • Sound:
      • Logitech Z-5500
      • Netzteil:
      • Corsair HX620
      • Betriebssystem:
      • Windows 7
      • Photoequipment:
      • Sony DSC-W290
      • Handy:
      • Sony Ericsson K850i

    Standard

    Zitat Zitat von ebastler Beitrag anzeigen
    Ich habe was editiert, da ich einen Knoten im Kopf hatte beim Schreiben des Befehls, Achtung!

    Ist dein Befehl im User oder root cron? Falls letzteres läuft mein Pfad so nicht...

    Falls er im User cron ist, braucht dein Python Script vielleicht root Rechte?
    Hab deinen Befehl von oben probiert aber er geht leider auch nicht.
    Meinst du mit root Rechte chmod? Hab ich ihm eigentlich gegegeben.



    Zitat Zitat von sky^xs Beitrag anzeigen
    Kannste das Skript nicht direkt ausführen? Also ohne den CD mumbojumbo? Und bau vielleicht ne Zeile in deinem Skript ein, die
    irgendwas an die Konsole ausgibt, was du dann ggf. mitloggen kannst - oder in eine lokale Datei (z.B. Timestamp des letzten
    Durchlaufs oder so).
    Das Skript gibt theoretisch soviel aus an das LCD Display und auch an die Konsole, dass das garnicht zu übersehen wäre.


    Gibt es ne ganz ganz einfache Möglichkeit wie man übe rprüfen kann ob cron funtkioniert? Weil ich hab die Vermutung dass der allgemein einfach nichts macht
    Geändert von 1337_alpha (23.06.19 um 13:30 Uhr)

  15. #3639
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    * * * * * echo `date` >> ~/log.txt

    Sollte dir jede Minute das aktuelle Datum in ein Textfile namens "log.txt" in deinem home-Verzeichnis anhängen.

    Was ich mit root oder nicht root meinte: Wenn du als user crontab -e ausführst, editierst du den crontab deines Benutzers. Wenn du vorher mit su in den root-Account wechselst und dann crontab -e eingibst, änderst du das des root-Accounts (wovon ich außer in Ausnahmefällen abraten würde).
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  16. #3640
    Hauptgefreiter
    Registriert seit
    11.12.2018
    Beiträge
    233


    Standard

    Zitat Zitat von 1337_alpha Beitrag anzeigen
    Gibt es ne ganz ganz einfache Möglichkeit wie man übe rprüfen kann ob cron funtkioniert? Weil ich hab die Vermutung dass der allgemein einfach nichts macht
    bestimmt, aber bevor du dir darueber gedanken machst, schau lieber zu, dass dein script auch da liegt, wo du es suchst.

    steht sogar in deinem screenshot:
    Zitat Zitat von 1337_alpha Beitrag anzeigen
    das angegebene file gibts gar nicht. was vermutlich daran liegt, dass du unter
    /home/pi/home/pi/...
    suchst.

    EDIT: diese lustige schlange ~ heisst btw tilde und zeigt auf das home-verzeichnis des aktuellen nutzers. deshalb wird aus ~/home/pi/ /home/pi/home/pi/.
    Geändert von pillenkoenig (23.06.19 um 13:16 Uhr)
    KING PILL, der Pillenkoenig.

    Ich, Ich, Ich, und nach mir die Sinnflut! Waehlen auch Sie jetzt konservativ!

    Zitat Zitat von Flatsch Beitrag anzeigen
    Was von Eiern erzählen aber Becks Gold kaufen

  17. #3641
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    Ich glaube das ~/home/pi kam daher, dass ich in meinem Beispiel erst den Pfad absolut angeben wollte, dann umentschieden hab und die ~ davor gepackt hab und vergessen hab das /home/pi wegzunehmen. Hab ich erst später editiert als es mir aufgefallen ist.
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  18. #3642
    Vizeadmiral Avatar von 1337_alpha
    Registriert seit
    02.03.2008
    Ort
    Großherzogtum Baden
    Beiträge
    7.867


    • Systeminfo
      • Motherboard:
      • Maximus II Formula
      • CPU:
      • Intel Q6600
      • Systemname:
      • The White Darkness
      • Kühlung:
      • Wasserkühlung
      • Gehäuse:
      • Lian Li V2010b
      • RAM:
      • Corsair Dominator 8GB DDR2-106
      • Grafik:
      • EVGA GTX260
      • Storage:
      • Western Digital Green Caviar 1TB
      • Monitor:
      • Samsung T240HD
      • Sound:
      • Logitech Z-5500
      • Netzteil:
      • Corsair HX620
      • Betriebssystem:
      • Windows 7
      • Photoequipment:
      • Sony DSC-W290
      • Handy:
      • Sony Ericsson K850i

    Standard

    So, ich hab das mal angepasst - hatte es nur von ebastler abgeschrieben und da nichts hinterfragt



    edit: (Scheint aber ohnehin auch nicht von jedem Verzeichnis aus zu funktionierten sie hier )

    Aber wie gesagt - ich hab ja schon gefühlt 1000 andere Befehle ausprobiert und von denen hat ja auch nie einer geklappt.

    sudo crontab -e hab ich auch getestet, damit komme ich ja in eine andere crontab Datei, da passiert aber ebenfalls nix.
    Geändert von 1337_alpha (23.06.19 um 13:43 Uhr)

  19. #3643
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    Hm, dann schreib ein kurzes bash script, das erst in den order cd't und dann das Python File ausführt, Gib dem File mit chmod +x ausführbarkeit und führe über cron das File aus.

    #!/bin/bash

    PATH=*dein pfad wo das Script liegt*
    FILENAME=*dateiname.py*

    cd $PATH
    python3 $FILENAME

    exit 0
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  20. #3644
    Hauptgefreiter
    Registriert seit
    11.12.2018
    Beiträge
    233


    Standard

    Zitat Zitat von 1337_alpha Beitrag anzeigen
    edit: (Scheint aber ohnehin auch nicht von jedem Verzeichnis aus zu funktionierten sie hier )
    sieht fuer mich aus, als wuerde dein script schon ausgefuert werden.
    und in zeile 35 deines scriptes machst du irgend etwas mit einer config.yml. welche dann aber nicht da liegt, wo dein script sie sucht.

    das ist mMn jetzt aber kein problem mit cron, sondern deinem script.
    KING PILL, der Pillenkoenig.

    Ich, Ich, Ich, und nach mir die Sinnflut! Waehlen auch Sie jetzt konservativ!

    Zitat Zitat von Flatsch Beitrag anzeigen
    Was von Eiern erzählen aber Becks Gold kaufen

  21. #3645
    Vizeadmiral Avatar von 1337_alpha
    Registriert seit
    02.03.2008
    Ort
    Großherzogtum Baden
    Beiträge
    7.867


    • Systeminfo
      • Motherboard:
      • Maximus II Formula
      • CPU:
      • Intel Q6600
      • Systemname:
      • The White Darkness
      • Kühlung:
      • Wasserkühlung
      • Gehäuse:
      • Lian Li V2010b
      • RAM:
      • Corsair Dominator 8GB DDR2-106
      • Grafik:
      • EVGA GTX260
      • Storage:
      • Western Digital Green Caviar 1TB
      • Monitor:
      • Samsung T240HD
      • Sound:
      • Logitech Z-5500
      • Netzteil:
      • Corsair HX620
      • Betriebssystem:
      • Windows 7
      • Photoequipment:
      • Sony DSC-W290
      • Handy:
      • Sony Ericsson K850i

    Standard

    Nein wirds leider nicht, nochmal, wenn ich das Skript ganz normal starte dann läuft ja alles einwandfrei - Daten werden angezeigt und gleichzeitig an 2 Webseiten übertragen.
    Da hatte ich ja nur mit dem Verzeichnis experimentiert.
    Der Screenshot zeigt ja nicht die Aktivität des Cron an, das war ich selbst - manuell.

    @ebastler deine Tips probier ich gleich aus.

    edit:

    Jetzt sieht das sh Script so aus, passt das so?


    Probiere es gleich aus
    Geändert von 1337_alpha (23.06.19 um 14:41 Uhr)

  22. #3646
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    Nicht ganz, ich hab hier mit variablen gearbeitet um es etwas eleganter zu lösen. Die beiden unteren Zeilen mit CD und python3 greifen nur auf die oben deklarieren Variablenwerte zu, die musst so lassen wie bei mir. Die Pfade oben sollten passen.
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  23. #3647
    Vizeadmiral Avatar von 1337_alpha
    Registriert seit
    02.03.2008
    Ort
    Großherzogtum Baden
    Beiträge
    7.867


    • Systeminfo
      • Motherboard:
      • Maximus II Formula
      • CPU:
      • Intel Q6600
      • Systemname:
      • The White Darkness
      • Kühlung:
      • Wasserkühlung
      • Gehäuse:
      • Lian Li V2010b
      • RAM:
      • Corsair Dominator 8GB DDR2-106
      • Grafik:
      • EVGA GTX260
      • Storage:
      • Western Digital Green Caviar 1TB
      • Monitor:
      • Samsung T240HD
      • Sound:
      • Logitech Z-5500
      • Netzteil:
      • Corsair HX620
      • Betriebssystem:
      • Windows 7
      • Photoequipment:
      • Sony DSC-W290
      • Handy:
      • Sony Ericsson K850i

    Standard



    das hätte ich ja selbst sehen können, ist nicht so dass ich Variablen erst seit heute kenne.....

    Aber danke jedenfalls, werde dir heute nachmittag bericht erstatten obs geklappt hat. Du bist jedenfalls eine echte Hilfe! Bin langsam echt verzweifelt weil vom Projekt ansich ja alles fertig ist und es scheiter nur daran

  24. #3648
    Lesertest-Fluraufsicht Avatar von Woozy
    Registriert seit
    19.10.2009
    Ort
    127.0.0.1
    Beiträge
    6.667


    • Systeminfo
      • Motherboard:
      • Asus Z9PE-D8 WS
      • CPU:
      • 2x E5-2690
      • Systemname:
      • Odin
      • Kühlung:
      • CoolerMaster MasterLiquid 120
      • Gehäuse:
      • Corsair Carbide 900D
      • RAM:
      • 128GB DDR3
      • Grafik:
      • 2x GTX1080
      • Storage:
      • SSDs ohne Ende, einige HDDs
      • Monitor:
      • 3x AOC 28" 4k
      • Netzwerk:
      • 1Gbit
      • Sound:
      • Onboard
      • Netzteil:
      • Cooler Master V750
      • Betriebssystem:
      • Windows 10 Pro 64bit
      • Sonstiges:
      • Krasses System! :D
      • Notebook:
      • Thinkpad T440p + X240s, Acer G752VY
      • Photoequipment:
      • Sony DSC H300
      • Handy:
      • Huawei Mate 10 Pro + M5 8"

  25. #3649
    Kapitän zur See Avatar von ebastler
    Registriert seit
    13.04.2014
    Beiträge
    3.418


    • Systeminfo
      • Motherboard:
      • Gigabyte X99 SOC Champion
      • CPU:
      • Intel i7 5960X
      • Kühlung:
      • Customloop
      • Gehäuse:
      • Anidees AI Crystal
      • RAM:
      • 4*8GB TridentZ DDR4-3200 CL15
      • Grafik:
      • Sapphire R9 290X Ref
      • Storage:
      • Samsung PM961 1 TB
      • Monitor:
      • Dell U2715H
      • Netzteil:
      • Antec HCP1200
      • Betriebssystem:
      • Win 10 Education
      • Notebook:
      • Thinkpad T450s, Thinkpad X61s
      • Photoequipment:
      • EOS 600D
      • Handy:
      • Oneplus 3, Nexus 5

    Standard

    Immer noch n weirder Broadcom Videocore basierter SOC, aber sonst sehr interessante Specs. Wobei ich mir einmal mDP gewünscht hätte.

    Und eine serial debug console in den USB C Anschluss geführt, wie es beim Pi Zero und dem Orangepi Zero der Fall ist. Die meisten Pis laufen glaub ich headless und da nicht jedes Mal beim Einrichten oder wenn es Probleme gibt einen Monitor dran zu klemmen ist Gold wert...

    Die mit Debugging klemmt man einfach für Versorgung + Laden an einen USB Port des Desktops und hat direkt vollen Zugriff auf eine Shell. Wobei für den wohl auch die Leistung eines USB Ports nicht mehr reicht.
    Everything changes, it all stays the same
    Everyone guilty, no one to blame.

    Ian "Lemmy" Kilmister, Love me Forever

  26. #3650
    Kapitän zur See Avatar von Daunti
    Registriert seit
    23.01.2012
    Ort
    Dromund Kaas
    Beiträge
    3.762


    • Systeminfo
      • Motherboard:
      • MSI Z370 A
      • CPU:
      • Intel i7 8700k
      • Systemname:
      • Dieter
      • Kühlung:
      • Alpenföhn Olymp
      • Gehäuse:
      • Nanoxia DS6
      • RAM:
      • 16GB Corsair Vengeance LP
      • Grafik:
      • GTX 1070 Asus Strix
      • Storage:
      • 250GB 960 Evo, Sandisk Ultra II 960GB, 2TB HDD
      • Monitor:
      • Asus ROG Swift PG278Q
      • Netzwerk:
      • Fritzbox 6490
      • Sound:
      • BD MMX300 Gen 2 600Ohm, Xonar Phoebus
      • Netzteil:
      • Be Quiet E9 480 Watt CM
      • Betriebssystem:
      • Windows 10 Pro
      • Notebook:
      • HP Elitebook X360/Thinkpad T440p
      • Photoequipment:
      • Sony Alpha 380
      • Handy:
      • Galaxy S9+

    Standard

    Nimm doch nen USB/Seriell Wandler und steuere den Pi
    Es kann keinen Kompromiss geben. Gnade, Mitgefühl, Loyalität: All diese Dinge halten Euch nur davon ab, zu beanspruchen, was Euch rechtmäßig zusteht.

    Mikrocontroller Sammler

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •