Ethernet geht nicht, Sound auch nicht, WLAN macht Probleme... Bios Update?

Raido

Einsteiger
Thread Starter
Mitglied seit
06.11.2023
Beiträge
48
Hallo,

Nun steht er endlich da, mein neuer PC. Leider steht er jetzt aber auch in der Ecke rum, weil ich den Ethernetanschluss nicht nutzen kann.

Ich habe mehrere Linux Distributionen getestet und alle melden, dass das Internet nicht zur Verfügung steht. Das ist wirklich mehr als ärgerlich. Auch Sound geht nicht, WLAN macht ebenfalls Probleme.

Frage :
Kann die Ursache hierfür eine veraltete Bios Version sein? Auf dem Mainboard zurzeit installiert ist die Version: 0220, First Release. Aktuell ist die Version : 0507.
Meines Erachtens müssten doch solche Dinge wie Ethernet auch mit einer älteren Bios Version funktionieren?

Beim Mainboard handelt es sich um ein ASUS z790 Formula:

Was kann sonst noch der Grund sein, warum mein Ethernet Anschluss am neuen Pc nicht funktioniert?

Vielen Dank für eure Unterstützung!
 
Zuletzt bearbeitet:
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Meines Erachtens müssten doch solche Dinge wie Ethernet auch mit einer älteren Bios Version funktionieren?
Ja, aber man braucht auch dann einen passenden Treiber, damit sie funktionieren. Leider schreibst Du nicht welche Linux Versionen Du probiert hast, aber auf der Downloadseite des Mainboard finden sich nur Downloads für Win 10 und Win 11, aber keine für Linux. Laut der Produktseite hat das Mainboard:
Dummerweise steht da nicht welcher Chip das genau ist, aber auf der Realtek Seite für die Treiberdownloads findet sich ja auch nur ein "Unix (Linux)" Treiber für "2.5G/5G Ethernet LINUX driver r8125 for kernel up to 6.4", der dürfte es wohl sein. Da dort "for kernel up to 6.4" steht, würde ich mal vermuten das dieser Treiber danach im Kernel aufgenommen wurden und daher empfehlen am Besten eine Distribution zu nehmen die einen Kernel ab 6.5 enthält, worauf auch solche Einträge hinweise:

 
Ja, aber man braucht auch dann einen passenden Treiber, damit sie funktionieren. Leider schreibst Du nicht welche Linux Versionen Du probiert hast,
Hey Holt,

Vielen Dank das du mir bei dem Problem beistehst. Ich bin schon ganz frustiert :)

Ich habe das offizielle Plasma IDE Manjaro installiert:

Die Datei heisst : manjaro-kde-23.1.0-231215-linux66.iso
Das müsste eigentlich die Kernel Version 6.6 und der Treiber müsste da in dem Falle deinen Infos nach enthalten sein.

Der Ethernet Anschluss wird jedoch nicht erkannt. Hast du mir irgendeinen Tipp, was ich sonst noch probieren könnte?

ps : Es wurde doch eine 14900K :) Danke nochmals das du mir per PM damals geholfen hast, die richtige Entscheidung zu treffen.
 
Das müsste eigentlich die Kernel Version 6.6 und der Treiber müsste da in dem Falle deinen Infos nach enthalten sein.
Ja der Realtek r3125 Treiber müsste da enthalten sein, aber ist da wirklich ein Realtek R3125 NIC verbaut? Da steht ja Realtek 5Gb Ethernet in den Spezifikationen des Mainboards und der da verbaut ist? Leider ist Google da wenig hilfreich wenn man nach einer 5Gbs Variante des R3125 sucht, da 2.5Gbs dann ja auch das Suchpattern erfüllt. GH gibt "1x 2.5GBase-T (Intel I226-V)" an, aber das dies nicht stimmen kann, sieht man ja sofort wenn man da auf den Link "Info beim Hersteller" geht und wo "Realtek 5 Gb Ethernet mit ASUS LANGuard" steht. Solche Fehler sind in den technischen Daten bei GH leider keine Ausnahmen.

Aber ich habe beim Googlen haben ich dies gefunden:
. Leider finde ich dafür keinen Linux Treiber, ja noch nicht einmal einen Windows Treiber zum Download, außer vermutlich dem auf der Downloadseite des Mainboards. Wobei ich den Runtergeladen habe, aber nicht auf die Schnelle sehen konnte für welche NICs der überhaupt ist. Aber vielleicht ist ja der 8126 verbaut und der neuste Treiber für den 8125 unterstützt den auch, probiere es doch mal mit dem Treiber von der Realtek Seite.

Sollte das nicht klappen oder doch ein anderer NIC verbaut sein, musst Du mal schauen ob es einen Linux Treiber dafür gibt, sonst wirst Du Dir wohl eine einfache Gigabit Karte holen müssen, nimm eine für die es einen Linux Treiber gibt (da die Chips darauf wohl alle recht alt sind, dürfte dies weniger ein Problem sein), der der Linux Treiber für den Onboard NIC erscheint. Die 2,5Gbs Karten kosten auch nicht so viel mehr als Gigabit Karten, wobei die billigen zwar auch den Realtek RTL8125B verbaut habe, aber der Treiber für den sollte ja im Kernel vorhanden sein.

Fürs nächste mal: Wenn Du Hardware für Linux oder generell ein anderes OS als Windows kaufst, schau immer vorher nach den Treibern!
 
Zuletzt bearbeitet:
Führ bitte erst mal ein `lspci -v` im Terminal aus, damit wir wissen, was für ein Netzwerkchip da jetzt wirklich verbaut ist.
 
Hey Holt,

Es hat geklappt!

Ich konnte den Treiber in der Linux Mint Distro ausführen. (y)

Leider hat es noch nicht bei Manjaro geklappt. Grund hierfür ist, dass für die Kompilierung des Treibers das Programm "make" benötigt wird. In der Linux Mint Distro war dieser bereits im installierten System enthalten, während bei Manjaro das nicht der Fall ist (leider).

Ich hab mir grad einen WLAN USB Adapter geholt:

Dieser hier soll laut ubuntuforum direkt unterstützt werden. Damit sollte ich dann den Treiber aus dem AUR Repository, der dort eingepflegt wurde, installieren können.

Ich berichte wieder wies ausgeht :)

Auch dir herzlichen Dank für die Unterstützung, fax668.
 
Grund hierfür ist, dass für die Kompilierung des Treibers das Programm "make" benötigt wird. In der Linux Mint Distro war dieser bereits im installierten System enthalten, während bei Manjaro das nicht der Fall ist (leider).
Make wird sich aber doch bestimmt nachinstallieren lassen, wenn man das passende Paket installiert. Vvermutlich ist es base-devel. Aber ohne Netzwerktreiber ist es natürlich blöd wenn dies nicht auf dem Installationsmedium enthalten ist.
 
Make wird sich aber doch bestimmt nachinstallieren lassen, wenn man das passende Paket installiert. Vvermutlich ist es base-devel. Aber ohne Netzwerktreiber ist es natürlich blöd wenn dies nicht auf dem Installationsmedium enthalten ist.
Hey Holt,

In der Tat, base-devel ist nicht in der Grundinstallation von Manjaro vorhanden. Ich konnte jedoch den Treiber über das AUR Repository dank der Unterstützung der Mitglieder eines Manjaro Forums nach installieren. Das heisst ich hab ein funktionierendes Manjaro mit Netzwerk.
 
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Zurück
Oben Unten refresh