Ergebnis 1 bis 9 von 9
  1. #1
    Hauptgefreiter
    Registriert seit
    04.11.2009
    Beiträge
    180


    Standard Trim funkrioniert nicht: Intel HDD-Raid0 + Single SSD am selben Intel Controller

    Hallo zusammen,

    Musste leider feststellen, dass ich nach einer Weile relativ mies Schreibwerte habe, da bei mir Trim nicht funktioniert ( Neue Methode zum Feststellen, ob TRIM funktioniert | SSDblog ):

    Vorher:

    Nachher:


    Mainboard: ASRock Z87 Extreme6, Bios 2.10 (12.5 RST Firmware)
    Intel Sata Modus: "Raid"
    RST-Treiber Version: 12.6

    Das Betriebssystem (Win7) ist auf einer einzelnen Samsung 840Pro 256GB installiert. Am selben Controller hängt noch ein Raid0 aus 2x3TB Hitachi Festplatten.
    fsutil behavior query DisableDeleteNotify ergibt auch den Wert 0. Intel unterstützt ja schon eine ganze Weile Trim (bei Win7 über den SCSI-Filtertreiber iaStorF.sys) für SSDs, die sich im Raid0 befinden. Die Frage ist nun: Gilt das auch für Single SSDs, die sich an einem Raid-konfigurtierten Intel Sata-Controller befinden? Und wenn nicht, könnt ich dem Abhilfe schaffen, in dem ich einfach ne 2. SSD kaufe, und die ebenfalls in RAID0 schalte? Welche anderen Möglichkeiten gibts noch (außer geplante "Optimierungen" über die Samsung Magician Software), Trim zu aktivieren?

    mfg Oli

    Edit: Ich seh grad auf den ASS Screens, dass der iaStorA.sys-Treiber benutzt wird. Im Gerätemanager stehen allerdings beide Treiberdateien drin, also iaStorA.sys und iaStorF.sys. Hat das jetzt was zu sagen?

    ---------- Post added at 16:54 ---------- Previous post was at 15:19 ----------

    Kommando zurück, Trim funktioniert. War wohl bei meinen 2 Überprüfungen zu voreilig. Stellt sich aber immer noch die Frage, warum die SSD so extrem einbricht? Kann ich mich bei meiner alten Intel G2 Postville nicht dran erinnern, die ist immer höchsten von 100MB/s auf 70MB/s eingeknickt.

    mfg Oli
    Geändert von qiller (05.08.13 um 17:49 Uhr)

  2. Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

  3. #2
    Admiral
    Registriert seit
    05.07.2010
    Beiträge
    17.955


    Standard

    Nimm doch TrimCheck 0.4 um die Funktion von TRIM zu prüfen, der macht zwar intern auch nichts anderes, aber es eliminiert eben Fehlerquellen, wenn das automatisch abläuft. Dann muss man mindestens zweimal laufen lassen und sollte dazwischen etwas warten.

    Die Performance kann so start einbrechen, weil die SSD sehr voll ist, eine andere Treiberversion oder ein anderer Virenscanner verwendet werden, um nur die häufigsten Ursachen zu nennen. Wie voll ist die SSD? Benche mal im abgesicherten Modus, von Windows wie sieht es dann aus? Verwendest Du noch den gleichen Rechner, die gleiche Windows Version und läuft was im Hintergrund.

  4. #3
    Hauptgefreiter
    Registriert seit
    04.11.2009
    Beiträge
    180
    Themenstarter


    Standard

    Thx für den Hinweis auf das Tool. Trim funktioniert auf jeden Fall. Ich habe jetzt die Firmware der Samsung SSD nochmal aktualisiert (auf der Samsung-Seite stand was von "improve performance on dirty drive") und 2x das Magician Tool optimieren lassen und jetzt passen die Werte erstmal wieder. Musste aber fürs Firmware-Update auf AHCI-Modus im UEFI umstellen und weiß daher nicht, ob jetzt nach dem Zurückstellen auf den Raid-Modus die Leistung wieder einbricht. Ich werde das beobachten.

    mfg Oli

  5. #4
    Admiral
    Registriert seit
    05.07.2010
    Beiträge
    17.955


    Standard

    Bei den Samsung 830 und 840 schneidet AS-SSD dummerweise im gerne mal den entscheidenden Teil der FW Information ab. Wenn Du noch die erste Version hattest, dann kann das klar der Grund gewesen sein. Komischerweise gab es das schon bei der 830, dass die mit der ersten FW Version mit der Zeit wirklich an Performance verloren hat.

    Ob TRIM jetzt im RAID Modus wieder geht, kannst Du ja gleich mal mit dem Tool testen und es wäre auch gut, wenn Du AS-SSD noch mal laufen lässt, denn der Treiber kann da auch einigen Einfluss haben. Das wirst Du ja dann sehen, oder hast Du jetzt auch schon im RAID Modus gebencht?

  6. #5
    Hauptgefreiter
    Registriert seit
    04.11.2009
    Beiträge
    180
    Themenstarter


    Standard

    Ja, hatte 2 Versionssprünge bei der FW. Das Tool funktioniert super, erspart einen das manuelle Rumfummeln per Hex-Editor - und man kann da kaum Fehler machen^^. Raid-Modus ist schon wieder an, aber wie gesagt, es ging ja nicht um SSDs im Raid0-Modus, sondern um Single-SSD + HDD-Raid0 am selben Intel-Controller. Benchmark-Ergebnisse sehen wieder normal aus (wegen den paar MB/s mach ich mich nicht nass):



    SSD ist auch relativ voll, von daher sind die Werte vollkommen ok.

    mfg Oli

  7. #6
    Admiral
    Registriert seit
    05.07.2010
    Beiträge
    17.955


    Standard

    Geht TRIM denn nun? TRIM mit RAID wurde ja von Intel in zwei Stufen eingeführt, während es bei AMD meines Wissens bis heute nicht geht. Zuerst ging ja auch bei Intel TRIM im RAID Modus überhaupt nicht, dann war TRIM für SSDs möglich, die selbst nicht Teil des RAIDs waren. Seid der Version 11.5 (Treiber und passendes OROM im BIOS) geht nun auch TRIM für SSDs die Teil eines RAID 0 sind.

    Das eine SSD nicht selbst Teil eines RAIDs ist, sagt also nicht automatisch, dass TRIM auch funktionieren muss, es ist bei Intel aber relativ wahrscheinlich, wenn man kein ganz altes System hat. Ob dabei nur die Treiberversion eine Rolle spielt oder auch eine bestimmte OROM Version im BIOS nötig ist, kann ich aber jetzt nicht sagen.

  8. #7
    Oberstabsgefreiter Avatar von Fernando
    Registriert seit
    27.01.2007
    Beiträge
    417


    • Systeminfo
      • Motherboard:
      • ASUS P8Z77-V
      • CPU:
      • Intel Core i5 3570K
      • Systemname:
      • Eigenbau
      • Kühlung:
      • Scythe Mugen 3
      • Gehäuse:
      • GEH Cooltek K3 Evolution USB 3
      • RAM:
      • 2x4 GB Corsair XMS3 DDR3-1600
      • Grafik:
      • Intel HD Graphics 4000
      • Storage:
      • 2x256 GB Samsung 840 Pro SSDs als RAID0
      • Monitor:
      • iiyama ProLite
      • Netzwerk:
      • Fritz!Box 7270
      • Sound:
      • Intel HD Audio
      • Netzteil:
      • Rasurbo RAP Modular 650 W
      • Betriebssystem:
      • Windows 8 x64

    Standard

    Zitat Zitat von Holt Beitrag anzeigen
    Seid der Version 11.5 (Treiber und passendes OROM im BIOS) geht nun auch TRIM für SSDs die Teil eines RAID 0 sind.
    Das ist nicht ganz richtig. TRIM im RAID0 funktioniert mit allen Intel RST-Treibern ab v11.0 (einzige Ausnahme: v12.5.0.1066), sofern sich im BIOS ein dazu "passendes" Intel RAID ROM befindet. Leider hat Intel dieses Feature in den Original-OROMs nur für Intel Chipsätze ab der 7-Serie freigeschaltet. Nach entsprechender Modifizierung des Intel RAID ROM können jedoch auch Besitzer eines älteren Systems mit einem Intel Chipsatz der 5- und 6-Serie TRIM im RAID0 nutzen.

  9. #8
    Banned
    Registriert seit
    25.11.2012
    Ort
    ...wenn ich das wüsste :D
    Beiträge
    347


    • Systeminfo
      • Motherboard:
      • Asus P8P67 Rev. 3.0
      • CPU:
      • Core i7-2600 K, 4500 MHz
      • Kühlung:
      • Corsair H50
      • Gehäuse:
      • NZXT H630
      • RAM:
      • TeamGroup 4x4 GB 1333er
      • Grafik:
      • Radeon 5870 E6, Antec 620 Wakü
      • Storage:
      • G2 80 GB RAID0, Hitachi 1000er u. 500er 2,5 Zoll
      • Monitor:
      • Yuraku 24 Zoll
      • Netzwerk:
      • onboard
      • Sound:
      • Auzentech X-Fi Forte
      • Netzteil:
      • Enermax Infinity 650 W

    Standard

    Das ist auch nicht ganz richtig. Bei mir funktioniert TRIM mit dem Original ROM v10.5.0.1034 und der RST v11.2.0.1006 in Verbindung mit der SSD Toolbox ab Version 3.0.2.

  10. #9
    Oberstabsgefreiter Avatar von Fernando
    Registriert seit
    27.01.2007
    Beiträge
    417


    • Systeminfo
      • Motherboard:
      • ASUS P8Z77-V
      • CPU:
      • Intel Core i5 3570K
      • Systemname:
      • Eigenbau
      • Kühlung:
      • Scythe Mugen 3
      • Gehäuse:
      • GEH Cooltek K3 Evolution USB 3
      • RAM:
      • 2x4 GB Corsair XMS3 DDR3-1600
      • Grafik:
      • Intel HD Graphics 4000
      • Storage:
      • 2x256 GB Samsung 840 Pro SSDs als RAID0
      • Monitor:
      • iiyama ProLite
      • Netzwerk:
      • Fritz!Box 7270
      • Sound:
      • Intel HD Audio
      • Netzteil:
      • Rasurbo RAP Modular 650 W
      • Betriebssystem:
      • Windows 8 x64

    Standard

    Zitat Zitat von Ismirlangweilich Beitrag anzeigen
    Das ist auch nicht ganz richtig. Bei mir funktioniert TRIM mit dem Original ROM v10.5.0.1034 und der RST v11.2.0.1006 in Verbindung mit der SSD Toolbox ab Version 3.0.2.
    Wie müsste denn die Aussage lauten, um 100%ig richtig zu sein?
    Es geht nicht darum, was Deine Intel SSD Toolbox mit Deinen Intel SSDs kann (das ist ein absoluter Sonderfall), sondern welche Voraussetzungen für ein beliebiges SSD-RAID0 erfüllt sein müssen, damit der vom Betriebssystem abgeschickte TRIM-Befehl tatsächlich innerhalb des RAID-Verbundes ankommt und die mit Datenmüll versehenen Zellen schnell wieder nutzbar macht.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •