"zufällige" Abstürze mit Win10 und Win11 bei 8GB RAM

MarkF

Experte
Thread Starter
Mitglied seit
10.09.2018
Beiträge
28
Hallole,
ich habe zwei ältere Laptops mit SSD "verjüngt" und auf Win11 gebracht:
Dell E6400 und Dell E6410, jeweils 4GB RAM (jeweils 2x2GB), nix UEFI und der moderne Kram wie GPT und so. Sie liefen bislang mit HDD und Win7-64bit Ultimate erträglich. Dann auf SSD umgestellt und auf Win10-64 Pro gebracht (Dual-Installation, Win7-64 blieb weiter drauf): Keine Probleme. Dann auf Win11 gebracht - kostete etwas "Lebendigkeit", insbesondere im Vergleich mit Win7 auf SSD, aber immer noch deutlich besser als mit Win7 auf HDD. So weit, so gut.
Da 4GB RAM bei Win11 die unterste Grenze darstellt (was nicht stimmt, denn ich hatte versehentlich Win11 mit 2GB RAM installiert - ein Riegel war nicht richtig eingeschoben ;-)) habe ich den E6410 mit 2x4GB RAM auf 8GB aufgerüstet. Da DDR3 war es nicht teuer. Beim E6400 würde das vielleicht auch gehen, aber der braucht DDR2 und das ist dermaßen teuer, daß es sich nicht lohnt. Mit diesen überzogenen Preisforderungen schießen sich die DDR2-Verkäufer selbst ins Knie.
Und damit fingen die Probleme an: Win11 stürzte "zufällig", nicht reproduzierbar ab. Da ist kein System, keine Struktur zu erkennen und auch die Fehleranzeigen ergeben kein Muster. Sobald einer der 4GB-Riegel im System ist, egal in welcher Form und Kombi, passiert es früher oder später.
Also habe ich die 4GB-Riegel verdächtigt und memtest laufen lassen, über einen Tag non stop. Kein Fehler, kein Problem. Speziell an Win11 liegt es auch nicht, denn ich habe es auch mit dem mit 4GB problemlos laufenden Win10 ausprobiert: Gefühlt seltener, aber auch hier treten diese "zufälligen" Abstürze auf. Also doch die 4GB-Riegel?
Da bei diesen Abstürzen auch mal das System zerschossen bzw. nicht mehr gebootet wurde mußte ich eine Zeitlang mit dem alten Win7 weitermachen - und da traten trotz dieser 8GB RAM keine Abstürze auf. Also liegt es doch nicht an diesen RAMs?
Laut Dell-Spezifikation müssen DDR3 1066MHz-Riegel rein, also PC3-8500. Die 2GB-Riegel sind Samsung 2Rx8 PC3-8500S-07-10-F2, M471B5673FH0-CF8. Die 4GB-Riegel tragen die Bezeichnung Hynix 4GB 1066 MHZ PC3-8500S, D3S1066-D4G.
CPU-Z meldet für das laufende Gerät als DRAM-Frequenz knapp 530 MHz, FSB-DRAM 4:16, für CL, tRCD und tRP 8 clock, tRAS 20 clocks und tRFC 86 clocks (nur zur Anrundung, das kann ich ja ohnehin nicht ändern).
Ich bin jetzt ratlos, kriege das nicht zusammen. Daß RAM defekt sind - o.k. Daß Win11 mit mancher PC-Hardware nicht mag - o.k. Aber das hier ... 2x2GB o.k., 2x4GB aber nö, obbwohl mit Win7 o.k. ... verstehe ich nicht.
Habt ihr eine Idee, was die Ursache sein kann, wo ich spezifisch danach suchen kann?
 
Zuletzt bearbeitet:
BIOS Update hast du das aktuellste drauf?
Vom Fehlerbild würd ich auf fehlende/falsche Chipsatztreiber tippen und da krachts mit 8GB...
10 bzw 11 laufen ja vermutlich nur mit generischen Treibern?
 
Und wie sieht es mit 1x4GB bzw. 1x4+1x2GB oder 2x4GB und Memtest? :)

Win11 stürzte "zufällig", nicht reproduzierbar ab.
Error bzw. BSOD?

Sonst fällt mir gerade spontan noch Rank/Bank Problematik bei der RAM-Bestückung ein, was hier ggf. die Rolle spielen könnte, aber dann sollte es Problem bei Win7 genau so geben, wie bei 10 oder 11.
 
Zuletzt bearbeitet:
"Klassische" Speichertest-Tools wie Memtest86(+) <6.0 finden solche Fehler leider nicht immer. Da geht es dann um zu knappe Timings, die erst bei speicherlastigen Multithread-Lasten auffallen. Als "Hausmittel-Test" kann ich noch den Benchmark von 7-Zip empfehlen. Der hat mir mal innerhalb von Minuten Fehler um die Ohren gehauen, wo sich Memtest86+ und Prime95 stundenlang nicht beschwert haben. Gibt aber auch noch spezialisiertere Tools, da gibt's hier auch irgendwo einen Fred zu.
 
schau doch mal in der Ereignisanzeige von Windows direkt was die abstürze verursacht.
Muss ja nicht direkt am RAM liegen vielleicht auch der Chipsatztreiber u.s.w.

Wie kommst du überhaupt auf die idee Windows 11 auf einem uralten Laptop zu installieren ohne wirklich zu wissen was du da tust :d :d
Würde da eher ein Linux draufspielen ...
 
BIOS Update hast du das aktuellste drauf?

Ja, bei beiden. Aber "neu" ist natürlich relativ. Von 2017 ... immerhin. Ist aber letztlich auch nicht der maßgebliche Punkt. Da es mit Win7 läuft ....

Vom Fehlerbild würd ich auf fehlende/falsche Chipsatztreiber tippen und da krachts mit 8GB...

Das sind die "neuesten" Treiber von Dell. Müßten die Gleichen sein wie in Win7. Und da es bei Win7 funktioniert ... und Win10 weniger häufig abstürzt .... Aber das werde ich noch mal prüfen. Definitiv ist es bei Win10/11 aber das jüngste Chipsatztreiberpaket.
Warum ausgerechnet bei 8 GB? Jedenfalls der E6410 ist auch für 8GB vorgesehen und bei Win7 klappt es ja ... Und Besseres als das jüngste Chipsatztreiberpaket von Dell kann es ja wohl kaum geben.

10 bzw 11 laufen ja vermutlich nur mit generischen Treibern?

Jetzt mußt Du mir erklären, woran ich generische Treiber erkenne .... Win10/11 installieren von vornehrein bereits einige Treiber, bei dem Rest sind es hauptsächlich von Dell bereitgestellte Treiber, aber Win10/11 holen sich selbst auch ein paar Updates. Die Treiberliste ist bunt gemischt .... Habe mal die mit driverview erstelle Liste nach Herstellern sortiert als Textdatei angehängt. Sieh selbst ....

Und wie sieht es mit 1x4GB bzw. 1x4+1x2GB oder 2x4GB und Memtest? :)

Memtest habe ich nur mit 2x4GB laufen lassen, denn ich wollte/will ja 8GB drin haben und nicht 2 oder 4GB mit einem Riegel. Bei nur einem 4GB-Riegel scheint mir Absturzhäufigkeit zuzunehmen.


Bein Win10 BSOD, bei Win11 das Pendant (ist ja nicht mehr "B"). Mit wie gesagt einem bunten Strauß von Ursachen/Gründen, da ist alles dabei und so gut wie nichts wiederholt sich,

Sonst fällt mir gerade spontan noch Rank/Bank Problematik bei der RAM-Bestückung ein, was hier ggf. die Rolle spielen könnte, aber dann sollte es Problem bei Win7 genau so geben, wie bei 10 oder 11.

Gerade das ist der Grund, weswegen ich mir keinen Reim drauf machen kann. Anfänglich dachte ich noch, es sei ein Win11-Problem (wegen der alten Hardware bzw. angeblich speziellen Anforderungen von Win11, auch wenn man erwarten sollte, daß Probleme immer bzw, gerade bei nur 4GB und nicht bei 8GB auftreten), aber als es auch - wenn auch anscheinend in geringerem Umfang - mit Win10 auftrat ...

"Klassische" Speichertest-Tools wie Memtest86(+) <6.0 finden solche Fehler leider nicht immer. Da geht es dann um zu knappe Timings, die erst bei speicherlastigen Multithread-Lasten auffallen.

Die Abstürze treten nicht gerade bei hoher Belastung auf, also irgendwelchen "stressigen" Verrichtungen. Da ist z.B. gerade mal der Explorer auf und Chrome mit 10 Tabs und ich klicke auf einen Link. Allerdings stürzt insbesondere Win11 auch einfach so ab, im sog. "Leerlauf", ohne daß irgendetwas "geschieht". Aber sind denn nicht Tools wie z.B. memtest gerade dazu da, diese Schwachstellen aufzudecken?

Als "Hausmittel-Test" kann ich noch den Benchmark von 7-Zip empfehlen. Der hat mir mal innerhalb von Minuten Fehler um die Ohren gehauen, wo sich Memtest86+ und Prime95 stundenlang nicht beschwert haben. Gibt aber auch noch spezialisiertere Tools, da gibt's hier auch irgendwo einen Fred zu.

Einfach so laufen lassen oder gibt es eine empfehlenswerte Einstellung?
Habe es mal ausprobiert. Mit der Default-Einstellung gab es keine Probleme. Mit der größten möglichen/akzeptierten Wörtbuchlänge (256MB) gab es sofort den BSOD - "Memory Management" ... wer hätte das gedacht ;-). Mit Win7 gab es dagegen keine Probleme, nur beschwerte sich 7-ZIP manchmal bei bei einem der Durchläufe, daß das System nicht die benötigte Speichermenge zur Verfügung stellen könne. Aber das war nur ein Mal und kein BSOD trat auf.
Wenn es die Chipsatztreiber sein sollten - welche bzw. welche Systemkomponenten im Geräte-Manager wären da einschlägig, um dort gezielt andere Treiber auszuprobieren?
Dennoch verstehe ich nicht, warum es bei 2x2GB klappt. Habe es daher mal die RAMs gewechselt und es mit 2x2GB testen und da läuft der Bench von 7-ZIP mit der größtzulässigen 128MB Wörterbuchgröße bei Win10 endlos ohne Probleme..

schau doch mal in der Ereignisanzeige von Windows direkt was die abstürze verursacht.
Muss ja nicht direkt am RAM liegen vielleicht auch der Chipsatztreiber u.s.w.

Ereignisanzeige ... aha. In welcher Rubrik?

Wie kommst du überhaupt auf die idee Windows 11 auf einem uralten Laptop zu installieren ohne wirklich zu wissen was du da tust :d :d

Nun, da Win11 jedenfalls mit SSD absolut flüssig läuft und für das, was ich damit zu tun habe (einschließlich z.B. Videokonvertierung), für mich völlig ausreicht, zumal ich meine Zeit nicht mit Spielen vergeude, können die Geräte ungeachtet ihres wirklichen Alters jedenfalls "funktional" nicht "uralt" sein. Warum wegschmeißen, wenn ich nichts "besseres" brauche und alles Moderne für meine Bedürfnisse völliger overkill wäre?
Und warum soll ich nicht wissen, was ich tue? Oder anders: Was müßte ich wissen? Man muß kein IT-Experte sein um Windows zu installieren (zu Deiner Info: Ich habe schon in den 80ern mit "selbst gebauten" ZX81 und Apple II angefangen, dann die ersten PC von XT über AT, 386er, 486er, einschließlich Assemblerprogrammierung, die verschiedenen DOSse usw.). Und immerhin klappt das ja auch mit 4GB und falls es keine Lösung geben sollte, dann belasse ich es eben bei 4GB, mit SSD sind Auslagerungsdateien ja nicht mehr der Bremsklotz, jedenfalls solange MS es noch zuläßt, auf den Oldtimern mit Tricks Win11 zu betreiben.

Würde da eher ein Linux draufspielen ...

Was soll ich als DOS-Win-Gewächs mit Linux anfangen? Wäre Linux eine Alternative (und ich versuche es immer wieder), dann hätte ich schon längst MS hinter mir gelassen. Und vom Browser abgesehen Win in einer VM unter Linux ist erst recht keine Lösung, das packen die Oldtimer nicht mehr in einer akzeptablen Weise, es sei denn, es wäre WinXP. Aber so sehr ich mich damals gegen den Wechsel zu Win7 gesträubt habe ... mittlerweile muß es bei vielen Programmen, die ich benutze, Win7 sein, aber das ist in einer VM bei diesen Geräten eine Quälerei. Und würde ich ein neu(er)es Gerät kaufen, würde sich das Problem ja nicht stellen.
Es erscheint mir auch wenig sinnvoll, eine Zeitlang ein Live-Linux laufen zu lassen, denn wenn es gut geht, hilft das genauso viel und wenig, wie wenn es abstürzt: Den Win7 bereitet ja keine Probleme, da bringt ein Test mit Linux auch keine weitergehenden Erkenntnisse, oder?
 

Anhänge

  • Win10-1.txt
    45,1 KB · Aufrufe: 75
Zuletzt bearbeitet:
Hey würde mal unter dem Punkt Kritisch nachschauen ob Einträge vorhanden sind
1696073982628.png


Meine Erfahrung ist bei älteren Laptops nicht mehr höher als Win10 zu gehen.
Nein da hast du absolut recht win10 als emulation auf Linux ist :poop:
und umgekehrt lohnt sich ja auch nicht.

Es müsste aufjedenfall Einträge im Ereignisprotokoll zu finden sein
 
Hey würde mal unter dem Punkt Kritisch nachschauen ob Einträge vorhanden sind
Anhang anzeigen 925393
Habe ich. Jede Menge (ausschließlich)
"Das System wurde neu gestartet, ohne dass es zuvor ordnungsgemäß heruntergefahren wurde. Dieser Fehler kann auftreten, wenn das System "
betreffend Microsoft Kernel Power und unterschiedlichen BugcheckCode. Das hilft aber wohl auch nicht weiter.

Meine Erfahrung ist bei älteren Laptops nicht mehr höher als Win10 zu gehen.

Warum?

Es müsste aufjedenfall Einträge im Ereignisprotokoll zu finden sein

Wenn Du mir erklärst, wo ich wonach suchen soll ....

Bis jetzt erfolgten unter Win10 mit 8GB keine weiteren BSOD, obwohl 7-ZIP-Bench mit einigen zig Läufen (256MB) streßte.

btw: Bei Win7 und Win10 wird eine CPU-Auslastung von 330 bis 350% angezeigt, bei Win11 dagegen nur um die 80%. Was ist daraus zu folgern?
 
Habe ich. Jede Menge (ausschließlich)
"Das System wurde neu gestartet, ohne dass es zuvor ordnungsgemäß heruntergefahren wurde. Dieser Fehler kann auftreten, wenn das System "
betreffend Microsoft Kernel Power und unterschiedlichen BugcheckCode. Das hilft aber wohl auch nicht weiter.
Warum?
Darum, merkste ja WIn10 läuft
Wenn Du mir erklärst, wo ich wonach suchen soll ....

Bis jetzt erfolgten unter Win10 mit 8GB keine weiteren BSOD, obwohl 7-ZIP-Bench mit einigen zig Läufen (256MB) streßte.

btw: Bei Win7 und Win10 wird eine CPU-Auslastung von 330 bis 350% angezeigt, bei Win11 dagegen nur um die 80%. Was ist daraus zu folgern?
Auslesefehler.. Ansonsten ist doch Super und ein weiterer Vorteil um W10 zu nutzen, deine CPU gibt 350% Power anstatt wie bei W11 nur mit 80%.
Die CPU möchte dir wohl damit sagen, dass sie kein bock auf W11 hat :bigok:
 
Zuletzt bearbeitet:
Warum?
Darum, merkste ja WIn10 läuft
Aber auch mit sporadischen BSOD. Also stimmt etwas nicht. Und in zwei Jahren ist Schluß mit Win10. Andernfalls würde ich mich mit Win11 nicht befassen.
Auslesefehler.. Ansonsten ist doch Super und ein weiterer Vorteil um W10 zu nutzen, deine CPU gibt 350% Power anstatt wie bei W11 nur mit 80%.
Die CPU möchte dir wohl damit sagen, dass sie kein bock auf W11 hat :bigok:
Jaja. Aber ernsthaft: Wieso kann unter Win7 und Win10 die CPU 350% "Power" geben? Die angezeigte GIPS-Zahl ist aber etwas kleiner. Es ist ja auch nicht so, daß in Win11 irgendein anderer Prozeß jede Menge Rechenleistung schlucken würde. Im Leerlauf liegt bei laufendem Task-Manager laut dessen Angaben die Last bei 6-8%. Ohne laut DriveGleam bei vielleicht der Hälfte. Insofern kein Unterschied zu Win7 bzw. Win10.
Die Erklärung in der Hilfe verstehe ich nicht recht:
"Benchmark
The CPU Usage column shows the percentage of time the processor is working. It's normalized for a one-thread load. For example, 180% CPU Usage for 2 threads can mean that average CPU usage is about 90% for each thread."
Hier werkelt ein i5-520M, 4 Threats, und so ist auch der Benchmark eingestellt

Ich habe jetzt mal Win10/11 völlig neu und clean aufgesetzt, sukzessive die Treiber installiert und danach mit 7-ZIP-Benchmark geschaut, ob es wieder BSOD gibt. Bisher nicht. Nur manchmal werden Rechenfehler gemeldet. Was unter Win10 und Win7 nicht auftritt. Wie kann das sein? Ein defektes RAM muß doch immer zumindest Rechenfehler zeitigen.
 
Dann wird es wohl doch einer der automatisch aktualisierten Treiber sein, die sich nicht mit den Bauteilen vertragen. In der Datei stehen ja fast nur MS-Treiber drinnen und kaum was vom Teilehersteller.

Die CPU Usage addiert einfach die Last aller verwendeten Threads und kommt so auf einen lustigen % wert. Es laufen bei die halt 4 Tests synchron, mit rund 87% Auslastung, was dann mit deinen 350 angezeigt wird. Es ist halt ein Singlecoretest. Du könntest als Gegentest ja das Hyperthreading in den Einstellungen abschalten und dann schaun wie es aussieht.
 
Zuletzt bearbeitet:
Dann wird es wohl doch einer der automatisch aktualisierten Treiber sein, die sich nicht mit den Bauteilen vertragen. In der Datei stehen ja fast nur MS-Treiber drinnen und kaum was vom Teilehersteller.
Dann müßte es aber doch auch bei Win10 und vor allem mit 4GB der Fall (gewesen) sein. Für mich mit meinen - unstreitig - beschränkten Kenntnissen ergibt das alles kein schlüssiges Bild. Aber ist es nicht normal, daß die Mehrzahl der Treiberdateien von MS stammt? Nach devices aufgelistet mit z.B. DevManView bietet sich ein anderes Bild.

Die CPU Usage addiert einfach die Last aller verwendeten Threads und kommt so auf einen lustigen % wert. Es laufen bei die halt 4 Tests synchron, mit rund 87% Auslastung, was dann mit deinen 350 angezeigt wird. Es ist halt ein Singlecoretest. Du könntest als Gegentest ja das Hyperthreading in den Einstellungen abschalten und dann schaun wie es aussieht.

Hm. Was aber nicht den krassen Unterschied zwischen Win7/10 und Win11 erklärt. Bei identischer Einstellung (und Hardware) müßte das Ergebnis doch zumindest ähnlich sein. Man könnte den Eindruck gewinnen, daß bei Win11 trotz der 4-Thread-Einstellung der Test nur mit einem Thread läuft.
 
Update:
Da auch bei dem frisch installierten Win11 sporadisch die Abstürze erfolgten habe ich noch mal memtest86 laufen lassen. Zwar ohne Ausfälle, aber diesmal habe ich der Anzeige der RAM-Module erwas mehr Aufmerksamkeit geschenkt. Und da fiel mir auf, daß diese nicht mit 1066MHz angezeigt wurden, auch nicht als Hynix, sondern als 1333 von SpecTec. Da angeblich (auch wenn ich es nicht verstehe), jedenfalls kann man es hier und da im Netz lesen, nicht alle Module auf allen PC problemos langsamer getaktet werden können, habe ich nun doch ein anderes Paar 4GB-Module gekauft, die laut memtest86 angeblich von Samsung stammen und wirklich 1066er sein sollen. Und siehe da, 7Zip-Benchmark verursacht keine Abstürze und auch mit dem "problematischen" Win11-Win10-Upgrade gibt es auch nach mehreren Stunden einem Tag einer Woche Betrieb keinen BSOD.
 
Zuletzt bearbeitet:
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Zurück
Oben Unten refresh