Aktuelles

Toshiba M.2 wird von BIOS nicht erkannt, von Windows jedoch schon

TheFstX

New member
Thread Starter
Mitglied seit
29.04.2015
Beiträge
10
Ort
Deutsch Wagram
System
Details zu meinem Desktop
Prozessor
Intel Core i5-4690K
Mainboard
ASUS Maximus VII Gene
Kühler
AlphaCool Eisbaer LT360
Speicher
SK-Hynix HMT351U6EFR8C-PB
Grafikprozessor
ASUS Rog Strix RX480 (BIOS: RX580) 8G
Display
Samsung 32 Zoll
SSD
Samsung XP491
Gehäuse
be quiet! Pure Base 500
Netzteil
be quiet!
Keyboard
CM Storm Octane
Mouse
SPEEDLINK SL-680002-BKRD
Betriebssystem
Windows 10 Pro
Webbrowser
Firefox
Hallo Leute!

Ich hab da ein merkwürdiges technisches Problem, bei dem ihr mir hoffentlich helfen könnt!
Ich habe mir eine M.2 PCIe SSD gegönnt. Warum auch immer will mein BIOS diese nicht sehen bzw. wird vom BIOS nicht erkannt und nicht angezeigt.
Interessanterweise von Windows schon. 🤔 Fahre ich nämlich den PC mit meiner alten SSD hoch, sehe ich die M.2 im Geräte Manager, in der Datenträgerverwaltung
und kann sie mit CrytalDiskInfo auslesen.
Ich konnte auch Windows problemlos installieren, da das Windows Setup die M.2 ebenfalls erkennt. Nur kann ich nicht davon booten.

Mainboard: ASUS Maximus VII GENE
BIOS Version: 3503 Beta (26.04.2018)
M.2 SSD: Toshiba KBG30ZMV256G

Die dazugehörige Config im BIOS steht auch auf M.2 Mode, nicht Auto Mode. Boot Device Control steht auf UEFI.

Das BIOS habe ich jetzt auf alle möglichen Varianten zurückgesetzt.
Die M.2 wird nach wie vor nur von Windows erkannt, jedoch nicht vom BIOS.

Habt ihr vlt einen Tipp für mich?
Kann sich jemand einen Reim darauf machen? Ist schon eher strange. Die M.2 ist ja auch eine PCIe.

M.2_PCIe_2.PNG

M.2_PCIe_3.PNG

M.2_PCIe.PNG

IMG_20200119_104818.jpg
 
Zuletzt bearbeitet:
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

Mo3Jo3

Active member
Mitglied seit
01.08.2017
Beiträge
1.570
Ort
ganz im Westen
Die 90er Chipsätze unterstützen NVMe noch nicht nativ, jedoch mit einem Biosupgrade. Aktuellstes BIOS gibts hier.
ab 2601 wird NVMe unterstützt, am besten lädst du dir aber das aktuelle 3003 Bios.
Benutze mal nicht das Betabios
 

TheFstX

New member
Thread Starter
Mitglied seit
29.04.2015
Beiträge
10
Ort
Deutsch Wagram
System
Details zu meinem Desktop
Prozessor
Intel Core i5-4690K
Mainboard
ASUS Maximus VII Gene
Kühler
AlphaCool Eisbaer LT360
Speicher
SK-Hynix HMT351U6EFR8C-PB
Grafikprozessor
ASUS Rog Strix RX480 (BIOS: RX580) 8G
Display
Samsung 32 Zoll
SSD
Samsung XP491
Gehäuse
be quiet! Pure Base 500
Netzteil
be quiet!
Keyboard
CM Storm Octane
Mouse
SPEEDLINK SL-680002-BKRD
Betriebssystem
Windows 10 Pro
Webbrowser
Firefox
Die 90er Chipsätze unterstützen NVMe noch nicht nativ, jedoch mit einem Biosupgrade. Aktuellstes BIOS gibts hier.
ab 2601 wird NVMe unterstützt, am besten lädst du dir aber das aktuelle 3003 Bios.
Benutze mal nicht das Betabios
Hallo @Mo3Jo3

Zuerst war auch die BIOS Version 3003 installiert, ich habe dann testweise die Beta Version installiert.

Ich werde downgraden und sehen was passiert.

Könnte es vlt. daran liegen das der M.2 Port nur für PCIe 2.0 ausgelegt ist die M.2 SSD aber PCIe 3.0 ist?
Normalerweise ist das doch abwärtskompatibel? Oder kann der Chipsatz damit einfach nicht umgehen?

::UPDATE::

Ich hab das BIOS auf Version 3003 downgegraded. M.2 wird nach wie vor nicht erkannt. Der Menüpunkt für den NVMe Controller bleibt leider auch nach wie vor ausgegraut.
Fahre ich das Windows mit der normalen SSD hoch, wird die M.2 in Windows angezeigt. Bin echt ratlos.
 
Zuletzt bearbeitet:

Holt

Well-known member
Mitglied seit
05.07.2010
Beiträge
19.915
wird vom BIOS nicht erkannt und nicht angezeigt.
Wo im BIOS wird sie nicht angezeigt? Und ist das UEFI im UEFI oder im CSM/Legacy Modus? Die meisten UEFI haben nur im UEFI Modus ein NVMe Modul. Wenn derzeit der CSM/Legacy Mode aktiv ist, dann stelle das mal um und schau ob die erkannt wird. Die Windows Installation wirst Du aber wiederholen müssen, da die SSD wohl nach MBR partitioniert ist, für den UEFI Mode muss es aber GPT sein. Wenn sie die falsche Art der Partitionierung hat, dann kann man auch dort Windows nicht einfach neuinstallieren, sondern muss die Partitionierungsinformationen erst entfernen. Boote Dein Windowsinstallationsmedium und drücke dabei mehrfach die Tastenkombination Shift+F10 um eine Eingabeaufforderung zu öffnen, dort gib dann folgende Befehle ein:

  • diskpart
  • list disk
  • select disk x (x steht für die Nummer des Laufwerks aus list disk, die richtige Platte sollte an der Kapazität zu erkennen sein, sonst andere Platten besser vorher abklemmen um Datenverlust zu vermeiden, vor einer Windowsinstallation sowieso, damit der Bootloader nicht dort landet)
  • detail disk (nur um sicher zu gehen die richtige Platte ausgewählt zu haben)
  • clean (clean löscht alle Partitionierungsinformationen, clean all überschreibt alles mit 00 und dauert entsprechend länger, man kann danach auch nichts mehr wiederherstellen)
  • exit
Danach ist ggf. ein Reboot nötig und dann installieren Windows 10 nochmal neu und nimm keine zu alte Version von Win 10, sondern 1909 oder maximal 1903 und überlasse dem Installer die Initialisierung der SSD.
Könnte es vlt. daran liegen das der M.2 Port nur für PCIe 2.0 ausgelegt ist die M.2 SSD aber PCIe 3.0 ist?
Das spielt nur für die Performance eine Rolle.
 

TheFstX

New member
Thread Starter
Mitglied seit
29.04.2015
Beiträge
10
Ort
Deutsch Wagram
System
Details zu meinem Desktop
Prozessor
Intel Core i5-4690K
Mainboard
ASUS Maximus VII Gene
Kühler
AlphaCool Eisbaer LT360
Speicher
SK-Hynix HMT351U6EFR8C-PB
Grafikprozessor
ASUS Rog Strix RX480 (BIOS: RX580) 8G
Display
Samsung 32 Zoll
SSD
Samsung XP491
Gehäuse
be quiet! Pure Base 500
Netzteil
be quiet!
Keyboard
CM Storm Octane
Mouse
SPEEDLINK SL-680002-BKRD
Betriebssystem
Windows 10 Pro
Webbrowser
Firefox
Hallo @Holt :)

Wo im BIOS wird sie nicht angezeigt? Und ist das UEFI im UEFI oder im CSM/Legacy Modus? Die meisten UEFI haben nur im UEFI Modus ein NVMe Modul. Wenn derzeit der CSM/Legacy Mode aktiv ist, dann stelle das mal um und schau ob die erkannt wird. Die Windows Installation wirst Du aber wiederholen müssen, da die SSD wohl nach MBR partitioniert ist, für den UEFI Mode muss es aber GPT sein. Wenn sie die falsche Art der Partitionierung hat, dann kann man auch dort Windows nicht einfach neuinstallieren, sondern muss die Partitionierungsinformationen erst entfernen.
Sie wird im BIOS gar nicht angezeigt. Egal ob im Boot Menü oder den Festplatten! Also im BIOS steht prinzipiell alles auf UEFI. Anbei einige Fotos meines BIOS!
Hab mir jetzt testweise eine Samsung M.2 gekauft. Sollte morgen oder Donnerstag hier sein. Die M.2 ist 100% GPT partioniert. Es wird mir in Diskpart auch so angezeigt.

IMG_20200121_190618.jpg

IMG_20200121_190631.jpg

IMG_20200121_190651.jpg

IMG_20200121_190711.jpg

::UPDATE::

Wie am schreiben dieser Antwort war, hat es an der Türe geklopft und die Samsung M.2 ist eingetroffen. Hab sie sofort eingebaut und siehe da, sie wird vom BIOS erkannt und ich kann davon booten. 😲

Einziger Unterschied, die Anschlussleiste ist bei der Samsung durchgehend und bei der Toshiba nicht. Echt spannend. Anbei noch ein Foto der beiden M.2 SSDs.

IMG_20200121_191828.jpg
 
Zuletzt bearbeitet:

Holt

Well-known member
Mitglied seit
05.07.2010
Beiträge
19.915
Das ist eine Samsung XP941, eine uralte Samsung M.2 PCIe OEM SSD die nicht das NVMe sondern das AHCI Protokoll nutzt. Die hat M-Key statt B+M Key, weil sie 4 PCIe 2.0 Lanes hat, die Toshiba hat nur 2 Lanes, der B Key (also die Einkerbung in der Anschlussleiste die der Samsung fehlt, ist dort wo Pins für die 3+4 Lane sind, daher kann eine M.2 SSDs mit B+M Key nie 4 PCIe Lanes haben, sondern nur 2 oder eine SATA Anbindung.
 

TheFstX

New member
Thread Starter
Mitglied seit
29.04.2015
Beiträge
10
Ort
Deutsch Wagram
System
Details zu meinem Desktop
Prozessor
Intel Core i5-4690K
Mainboard
ASUS Maximus VII Gene
Kühler
AlphaCool Eisbaer LT360
Speicher
SK-Hynix HMT351U6EFR8C-PB
Grafikprozessor
ASUS Rog Strix RX480 (BIOS: RX580) 8G
Display
Samsung 32 Zoll
SSD
Samsung XP491
Gehäuse
be quiet! Pure Base 500
Netzteil
be quiet!
Keyboard
CM Storm Octane
Mouse
SPEEDLINK SL-680002-BKRD
Betriebssystem
Windows 10 Pro
Webbrowser
Firefox
Ich bedanke mich jedenfalls recht herzlichst für eure Hilfe! 8-)
 
Oben Unten