[Ungelöst] Mal wieder die Namensauflösung unter Win10

old-papa

Enthusiast
Thread Starter
Mitglied seit
22.10.2007
Beiträge
684
Hallo,

nicht zum ersten mal (hier wohl auch nicht) habe ich das Problem, dass aus heiterem Himmel die Namensauflösung (nennt man das so?) nicht mehr funktioniert.
Hintergrund: Ich will im Explorer ein Netzwerklaufwerk verbinden (zu einem meiner NAS) und es werden auch brav alle Netzgeräte angezeigt. Nur wenn ich z.B. auf "Raspi-NAS" (einem NAS) klicke erscheint jetzt nichtmehr die dahinter liegende Freigabe, sondern nach einigem Gerödel eine Fehlermeldung (Code 0x80070035)

Bis Vorgestern ging das noch problemlos, seit Gestern nicht mehr (habe nichts wirklich verändert!). Das Verhalten lässt sich auf mehreren PCs nachvollziehen, immer die gleiche Fehlermeldung.
Wenn ich das Netzlaufwerk über "\\IP-Adresse\Freigabe" verbinde, dann klappt das sofort!

Testweise habe ich die NAS mal angepingt und bin etwas irritiert: Wenn ich eines der NAS mit dem Namen (Raspi-Nas) anpinge werden mir sehr komische IP-Adressen und relativ lange Laufzeiten zurück gemeldet (s. Foto) Pinge ich das gleiche Gerät mit der eigentlichen IP-Adresse an, scheint das ok.
Woher kommen denn diese ulkigen IP-Antworten: "Antwort von 45.76.93.104: Bytes=32 Zeit=19ms TTL=56"?

Unter WinXP und davorliegende hatte ich solche Probleme nie, diese begannen zunächst bei Win7 und waren plötzlich auch mal wieder weg.

Old-Papa
 

Anhänge

  • Fehlercode 0x80070035.jpg
    Fehlercode 0x80070035.jpg
    61,9 KB · Aufrufe: 53
  • Ping-Konfus.jpg
    Ping-Konfus.jpg
    84,2 KB · Aufrufe: 48
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Hat nix mit Windows zu tun, jemand hat die domain fritz.box registriert (war nicht avm) und das macht bei den ganzen fritten Probleme, diese lösen fritz.box normal lokal auf, nun teils aber nicht mehr und greifen auf TLD DNS zurück.
Quelle
 
Hmmm, mit "fritz.box" im Browser hatte ich gelegentlich schon Probleme, schob das aber auf fehlende HTTPS-Unterstützung. Wenn ich die Fritze mit ihrer IP aufrufe, komme ich dort immer rein.
Doch was hat das nun mit meinen NAS zu tun? Diese liegen ja innerhalb meines IP-Bereiches. Andererseits: diese ulkige Antwort von 45.76.93.104: Bytes=32 Zeit=19ms TTL=56 irritiert schon. Warum kullert der Ping dorthin und zurück?
Wenn die URLs von Fritzen gekapert wurden, dann doch sicher nicht ausgerechnet vorgestern....
Oder verstehe ich den Artikel bei Golem falsch?

Old-Papa
 
1710449084162.png


Du versuchst den namen in der domäne fritz.box aufzulösen, wird dir durch fritzbox dhcp als lokale dns domäne teils mitgegeben, das kann/konnte ändern; hab aktuell keine fritte mehr sonst hätte ich dir nen screenshot gemacht wo genau. war unter heimnetz, lokales netz und dann irgendwo unter ip adressbereich zu finden (extra button nochmals)
 
Anhang anzeigen 980815

Du versuchst den namen in der domäne fritz.box aufzulösen, wird dir durch fritzbox dhcp als lokale dns domäne teils mitgegeben, das kann/konnte ändern; hab aktuell keine fritte mehr sonst hätte ich dir nen screenshot gemacht wo genau. war unter heimnetz, lokales netz und dann irgendwo unter ip adressbereich zu finden (extra button nochmals)
Verstehe nur Bahnhof....
Ich habe in der Fritze nichts verändert und diese ulkige IP findet sich darin natürlich nirgendwo.

Old-Papa
 
Normal hat die fritzbox sowas wie eine logische lokale (im heimnetzwerk) DNS domäne, namens fritz.box. Wenn jetzt aber außerhalb des Heimnetzes eine echte Domain (im Internetz) namens fritz.box existiert, dann kann die Namensauflösung anstatt lokal aufzulösen nach draußen in die freie Welt auflösen. Dann bekommst du als Rückmeldung nicht die IP vom NAS, sondern bpsw von einem dienst der unter der domäne fritz.box im Netz läuft.
 
Ggf kann man DNS Rebind dafür zweckentfremden.
Das sollte helfen.
Da mal RASPI-NAS.fritz.box eintragen
 
musst lokal an deinem pc noch den dns cache leeren.
win + r -> cmd -> dann ipconfig /flushdns
 
Hatte ich schon gemacht, erfolglos :-(

Old-Papa
 
Zeig' mal bitte ein ipconfig /all, ich habe den Verdacht, dass dein PC nicht deine Fritzbox als DNS-Server nutzt, sondern einen DNS-Server im Internet.
 
Nu denne...
Code:
C:\WINDOWS\system32>ipconfig /all

Windows-IP-Konfiguration

   Hostname  . . . . . . . . . . . . : *****-Asus-NB
   Primäres DNS-Suffix . . . . . . . :
   Knotentyp . . . . . . . . . . . . : Hybrid
   IP-Routing aktiviert  . . . . . . : Nein
   WINS-Proxy aktiviert  . . . . . . : Nein
   DNS-Suffixsuchliste . . . . . . . : fritz.box

Ethernet-Adapter LAN-Verbindung:

   Verbindungsspezifisches DNS-Suffix: fritz.box
   Beschreibung. . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physische Adresse . . . . . . . . : 14-DA-E9-55-F0-39
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja
   IPv4-Adresse  . . . . . . . . . . : 192.168.0.79(Bevorzugt)
   Subnetzmaske  . . . . . . . . . . : 255.255.255.0
   Lease erhalten. . . . . . . . . . : Donnerstag, 14. März 2024 13:24:30
   Lease läuft ab. . . . . . . . . . : Sonntag, 24. März 2024 23:34:00
   Standardgateway . . . . . . . . . : 192.168.0.1
   DHCP-Server . . . . . . . . . . . : 192.168.0.1
   DNS-Server  . . . . . . . . . . . : 192.168.0.1
   NetBIOS über TCP/IP . . . . . . . : Aktiviert

Drahtlos-LAN-Adapter Drahtlosnetzwerkverbindung:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix: fritz.box
   Beschreibung. . . . . . . . . . . : Atheros AR9285 Wireless Network Adapter
   Physische Adresse . . . . . . . . : D0-DF-9A-97-59-BA
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja

Drahtlos-LAN-Adapter LAN-Verbindung* 1:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter
   Physische Adresse . . . . . . . . : 12-DF-9A-97-59-BA
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja

Drahtlos-LAN-Adapter LAN-Verbindung* 2:

   Medienstatus. . . . . . . . . . . : Medium getrennt
   Verbindungsspezifisches DNS-Suffix:
   Beschreibung. . . . . . . . . . . : Microsoft Wi-Fi Direct Virtual Adapter #2
   Physische Adresse . . . . . . . . : 22-DF-9A-97-59-BA
   DHCP aktiviert. . . . . . . . . . : Ja
   Autokonfiguration aktiviert . . . : Ja

C:\WINDOWS\system32>

Old-Papa
 
Kannst du das NAS denn anpingen, wenn du

ping RASPI-NAS.local versuchst ?
Code:
C:\WINDOWS\system32>ping Raspi-Nas.local

Ping wird ausgeführt für Raspi-Nas [192.168.0.89] mit 32 Bytes Daten:
Antwort von 192.168.0.89: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.0.89: Bytes=32 Zeit=1ms TTL=64
Antwort von 192.168.0.89: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.0.89: Bytes=32 Zeit<1ms TTL=64

Ping-Statistik für 192.168.0.89:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 1ms, Mittelwert = 0ms

Da stimmt das dann
Beitrag automatisch zusammengeführt:

Überraschung!

Wie schon einige male, plötzlich kommt der Ärger und genauso plötzlich ist er wider weg.

Code:
C:\WINDOWS\system32>ping Raspi-Nas

Ping wird ausgeführt für Raspi-Nas.fritz.box [192.168.0.89] mit 32 Bytes Daten:
Antwort von 192.168.0.89: Bytes=32 Zeit=1ms TTL=64
Antwort von 192.168.0.89: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.0.89: Bytes=32 Zeit<1ms TTL=64
Antwort von 192.168.0.89: Bytes=32 Zeit<1ms TTL=64

Ping-Statistik für 192.168.0.89:
    Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
    (0% Verlust),
Ca. Zeitangaben in Millisek.:
    Minimum = 0ms, Maximum = 1ms, Mittelwert = 0ms

C:\WINDOWS\system32>

Verstehe nur Bahnhof, zumindest sind die Freigaben da und keine Fehlermeldung mehr.....

Old-Papa
 

Anhänge

  • Wieder-OK.jpg
    Wieder-OK.jpg
    14,4 KB · Aufrufe: 28
Zuletzt bearbeitet:
Ich habe das gleiche Problem.
NAS und Pihole sind nicht mehr über die in der Fritzbox vergebenen Hostnamen erreichbar.
Die Hostnamen im lokalen Netzwerk passen nicht zur lokalen IP und landen bei der externen IP 45.76.93.104
Das NAS ist zwar im Netzwerk sichtbar, verbindet sich aber nicht.
Erstelle ich eine Verbindung mit der IP vom NAS, kann ich darauf zugreifen.

Pinge ich die interne IP der Geräte, antworten die wie gewünscht.
Pinge ich den Hostnamen, wird hostname.fritz.box mit der IP 45.76.93.104 angepingt.

DNS extern habe ich im Router über einen Rasberry mit Pihole laufen.
Läuft DNS wieder über den Router, funktioniert wieder alles normal.
Beitrag automatisch zusammengeführt:

Kannst du das NAS denn anpingen, wenn du

ping RASPI-NAS.local versuchst ?
mit hostname.local meldet sich das NAS.
 
Hallo,
ich habe seit vorgestern auch einen Pi-Hole am Laufen, eben weil ich vermutete, dass die Namensauflösung irgendwie (irgendwohin)verbogen wurde.
Als ich den Pi-Hole installiert hatte, hatte ich wieder das Problem, dass sich ja gerade auf wundersame Weise aufgelöst hatte.

Doch auch das habe ich (hoffentlich) gelöst:
1. In der Fritzbox In den "Zugangsdaten -> DNS" ist jetzt wieder "vom Internetanbieter zugewiesene..." angehakt.
(Vorher hatte ich 1.1.1.1 drin)
2. Unter "Heimnetz -> Netzwerk -> Netzwerkeinstellungen" ist in der Fritze bei IPv4 als "lokaler DNS Server" die IP vom Pi-Hole drin (IPv6 habe ich nicht)

3. Im Pi-Hole unter "Settings -> DNS" habe ich wieder die IP der Fritzbox drin ("meist 192.178.0.1")

4. Außerdem habe ich im Pi-hole unter "Lokale DNS -> DNS-Records" noch meine NAS und andere bekannten Geräte (alle mit fester IP) mit Namen.fritz.box und ihrer IP eingetragen.
Ob das auch ohne ginge, habe ich nicht untersucht.

5. Als Weiteres habe ich im Pi-Hole noch unter "Settings -> DNS" ganz unten bei "Use Conditional Forwarding" den Haken gesetzt und dann bei

Local network in CIDR notation
192.***.0.0/24
IP address of your DHCP server (router)
192.***.0.1
Local domain name (optional)
fritz.box

(die IP und vor allem die *** durch Deine Ziffern ersetzen ;-))

Zumindest kann ich derzeit immer mit Namen auf die Geräte zugreifen und vor allem als Netzlaufwerke die Freigaben nutzen. Was davon nun wirkte (oder doppelt gemoppelt ist), kann ich nicht mit Bestimmtheit sagen.

Ich vermute, weil ich in der Fritze irgendwann mal auf einen anderen öffentlichen DNS-Server umgestellt hatte (1.1.1.1 für Cloudflare), kamen die Probleme (da hatte ich noch kein Pi-Hole). Mal ging es tagelang und plötzlich Ende. Jetzt mit der vom Internetanbieter zugewiesenen... (in Zugangsdaten), scheint das zu klappen.

Old-Papa
PS: Heute, 18.3.24, etwas ergänzt
 

Anhänge

  • Locale-DNS.jpg
    Locale-DNS.jpg
    22,1 KB · Aufrufe: 16
Zuletzt bearbeitet:

Schaut euch mal das Kapitel „Primäres DNS Suffix hinzufügen“ an.
Wenn ihr dort „local“ hinterlegt, sollte es passen.

Das müsste aber auch entsprechend bei einem PiHole irgendwo hinterlegbar sein.

 
Sorry, ich meine das nachfolgende Kapitel

Verwendung des primären DNS-Suffixes​

 
Super, so funktioniert das erst mal. Zumindest für das NAS.
Aber ne Lösung ist das auch nicht. Das Problem kommt vom Router.
Für SSH benötige ich weiterhin die IP.
Ist da nicht AVM in der Verantwortung?
Meiner Meinung nach war fritz.box schon immer eine schlechte Idee.
 
Im Pihole kannst du conditional forwarding (unter "DNS", ganz unten) aktivieren. Probier das mal. Dann sollte fritz.box auf wieder im lokalen Netz korrekt aufgelöst werden.
Die hier beschriebenen Probleme hatte ich die Tage ebenso.
 
Im Pihole kannst du conditional forwarding (unter "DNS", ganz unten) aktivieren. Probier das mal. Dann sollte fritz.box auf wieder im lokalen Netz korrekt aufgelöst werden.
Die hier beschriebenen Probleme hatte ich die Tage ebenso.
Stimmt, dass hatte ich auch so eingetragen. (füge ich in meiner Auflistung etwas weiter oben noch hinzu).

Old-Papa
 
Habe auch seit ein paar Tagen das Problem, aktuell habe ich es über die Hosts Datei gelöst. Werde mich mit AVM und meinem Internetprovider auseinandersetzen.. mal sehen.. Hier die Hostsdatei, ihr müsst nur eben anpassen: Ich habe das Problem nur auf einem PC.. von 3.
# 127.0.0.1 ist die Loopback-Adresse und verweist immer auf den lokalen Rechner

127.0.0.1 localhost
127.0.0.1 bigbabe
127.0.0.1 bigbabe.fritz.box

# Interne IP-Adressen

192.168.0.66 bigbabe
192.168.0.67 smallbabe
192.168.0.67 smallbabe.fritz.box
192.168.0.60 Babe
192.168.0.60 babe.fritz.box
192.168.0.60 fritz.box
192.168.0.69 mediababe
192.168.0.69 mediababe.fritz.box


# Domain external

192.168.0.69 vultrusercontent.com
192.168.0.69 45.76.93.104
192.168.0.69 twelve99.net
192.168.0.69 twelve99-cust.net
 
Antwort von AVM, .box ist eine neue TopLevelDomain, und fritz.box steht zum Verkauf. AVM kauft gerade diese Domain um die markenrechtliche Situation zu klären und auch die Probleme ihrer Kunden. Sie empfehlen in privaten Netzwerken ip basierend zu arbeiten und es tut ihnen leid dass sie verpennt haben diese Domain rechtzeitig zu erwerben. Demnächst wenn der Prozess abgeschlossen ist, wird alles wieder normalisiert. Es sollte auch "nur" exposed Hosts oder DMZ betreffen..
LG...
Beitrag automatisch zusammengeführt:

HIer was zu lesen was ich fand:


 
Zuletzt bearbeitet:

suchworte sind namensauflösung lokal fritzbox

liegt eher am nas, das die registrierung nicht klappt ?!
 
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Zurück
Oben Unten refresh