Altes NAS >>>KOMPLETT<<< auf SSDs umstellen?

Dunkeltier

Enthusiast
Thread Starter
Mitglied seit
25.04.2007
Beiträge
971
Ich benutze immer noch ein ein wenig in die Jahre gekommenes QNAP TS-h973AX NAS als Speicherhure. Ich bin damit sehr zufrieden, die Leistung reicht für die alltäglichen Backups und einen Teamspeak-Server sowie eine JDownloader-Instanz soweit immer noch vollkommen aus.

2434371-n0.jpg


Nun ist mir aber die Idee gekommen, alles auf SSDs umzustellen. Klar ist es bisher nur eine Idee, eine ziemlich teure noch dazu. Vorab möchte ich erwähnen, das ja schon bereits 4x SSDs (2x SATA, 2x U.2) in diesem NAS verbaut sind. Bei einen einer Umstellung von SSDs auf HDDs will man natürlich nicht zuviel Speicherplatz einbüßen, und ich hatte da eine Idee (oder besser gesagt einen Zufallsfund gemacht)...

Und zwar das hier (QNAP QDA-A2AR):
41c1OwebJBL._SL500_.jpg


Damit kann man 2x 2.5" SSDs auf einen 3.5" Laufwerksträger unterbringen! Ich habe allerdings KEINE Ahnung, ob sich damit dann auch ein RAID 5 aufbauen lässt? Weil nach außen sollen sich zwei SSDs als ein Laufwerk ausgeben können (z.B. JBOD oder RAID 0). Hat jemand Erfahrungen damit gemacht und kann berichten? Da ich mir SSDs ja gerne Morgens mit ins Müsli schütte, mir daraus einen Shelter baue oder damit ein NASA-Rechenzentrum betreibe, bleibt als letzten ja noch die Anschaffung der SSDs als letzt große Hürde. Ich würde dazu 3x SSDs zusammen klauen. Und zwar 2x aus dem SSD-Schacht 3+4 sowie die eine SSD aus meinen NUC/Mini-PC. Damit hätte ich dann 3x von 10x benötigten Laufwerken.

Da wollte ich dann auch nochmal nachfragen, ob ich mein ZFS-Volumen nachträglich um weitere Datenträger erweitern kann (Thick-/Thin-Volumen)? Ich würde mir dann erst mal nur initial 3 der insgesamt 7 benötigten Laufwerke zulegen wollen, weil schon die 15er und 30er ordentliche Löcher in meine Geldbörse gerissen haben. Momentan sind ja die zwei 7.68TB SSDs im NAS als RAID 0 für die ganzen anfallenden Downloads zusammen geschaltet. Damit die HDDs nicht ständig laufen. Naja, die würden dann halt durch zwei alte 2TB Crucial MX500 ersetzt werden. Da würde ich dann auch mit denen noch sinnvolle Resteverwertung betreiben.

---

Und die externe Backup-Einheit bräuchte dann auch ein Upgrade. Ich würde in diese dann 4x 20TB Toshiba HDDs stecken und diese als RAID 5 mit ~60TB laufen lassen. Das wäre ein Upgrade zum vorherigen RAID 0 in diesen. Naja, dafür steigt halt die Ausfallwahrscheinlichkeit im NAS durch die ganzen RAID 0 an. Eines Todes muss man sterben. Was habt ihr dazu für eine Meinung? Es sind wie bisher alles nur Hirngespinste und vielleicht setze ich es ja auch gar nicht um.

Der "Haupdatensatz" ist bei mir eh schon mehrfach abgesichert. Der liegt im Original und Backup auf meiner Workstation vor, wird nochmals auf die 2x U.2 SSDs im NAS gesichert und landet dann ja auch noch ein 4. mal auf dem Hauptspeicherplatz und ein 5. mal auf der externen Backup-Einheit des NAS. Was auf diesen Meer an SSDs und HDDs noch zusätzlich drauf wäre, sind dann halt Urlaubsfilme. Der Verlust dieser wäre zwar tragisch, aber verschmerzbar. Zumal ja das externe Backup dazu auch gleichzeitig den Löffel abgeben müsste.
 
Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.
Damit kann man 2x 2.5" SSDs auf einen 3.5" Laufwerksträger unterbringen! Ich habe allerdings KEINE Ahnung, ob sich damit dann auch ein RAID 5 aufbauen lässt? Weil nach außen sollen sich zwei SSDs als ein Laufwerk ausgeben können (z.B. JBOD oder RAID 0).
Das mit zwei Laufwerken im dem Rahmen kein internes RAID 5 geht, sollte klar sein, also meinst Du ja wohl ein RAID 5 auf übergreifender Ebene wo die beiden SSD in dem Rahmen dann Teil davon wären. Die NAS basieren ja meistens auf SW RAIDs und da sollte es kein Problem sein.
 
Ja, auf übergreifender Ebene. Ich würde die zwei Laufwerke im Laufwerksträger immer zu einen RAID 0 konfigurieren, so das sie sich nach außen als ein großes Laufwerk ausgeben. Und aus diesen fünf SSD-Doppelpacks im RAID 0 würde ich dann gerne ganz normal das RAID 5 aufbauen. So zumindest meine Idee, wenn ich die Beschreibung auf der QNAP-Webseite korrekt interpretiert habe...? ->https://www.qnap.com/de-de/product/qda-a2ar
 
Klingt soweit nachvollziehbar, aber durch diese Kombination der RAID0s steigt natürlich die Ausfallwahrscheinlichkeit. Wollts nur noch mal erwähnt haben.
 
aus diesen fünf SSD-Doppelpacks im RAID 0 würde ich dann gerne ganz normal das RAID 5 aufbauen.
Das sollte gehen, die Ausfallsicherheit ist natürlich nicht so gut als wenn es jeweils nur einzelne SSDs wären, denn wenn eine im RAID 0 ausfällt, ist das ganze RAID 0 weg. Lass Dir aber besser vorher noch mal vom Support bestätigen das es kompatibel ist, nicht das am Ende irgendeine Kleinigkeit wie Probleme mit dem Auslesen der S.M.A.R.T. Werte und damit das Ermitteln des Zustands der SSDs dann die Einrichtung des RAIDs verhindern. Das Auslesen der S.M.A.R.T. Werte einzelner Laufwerke hinter so einem SATA Port Multipiler mit RAID Funktion kann nämlich wie bei allen HW RAIDs problematisch werden.
 
Lt. Beschreibung kann das Ding "individual", womit jede SSD getrennt erkannt würde. Dann ist doch alles in Ordnung.
 
In der Einstellung sollte es normalerweise keine Probleme mit dem Auslesen der S.M.A.R.T. Werte geben, aber Dunkeltier wollte ja die RAID 0 Einstellung nutzen. Da erscheinen beide Laufwerke im Käfig dann wie ein einzelnes und damit ist die Frage, welche S.M.A.R.T. Werte sollen denn ausgelesen werden? Das es in Wahrheit zwei Laufwerke sind die da hinter dem einen stecken, wird ja bewusst verschleiert um sie als ein Einzellaufwerk nutzen zu können und deshalb können dann meist nur spezielle Tools der RAID Lösung die S.M.A:R.T. Werte der einzelnen Laufwerke des RAIDs auslesen.
 
"Individual" soll wohl nur mit 'nem SATA-Port-Multiplier funktionieren. Und ob das Auslesen der Werte noch mit dem JMICRON JMS562 Chip dazwischen zuverlässig funktioniert? I don't know...
 
Zuletzt bearbeitet:
also am großen Fluß gibt's dazu eine Produktrezension von 2021:

1,0 von 5 Sternen - Die Inbetriebnahme gestaltete sich als sehr umständlich.
Rezension aus Deutschland vom 12. April 2021
Verifizierter Kauf
Zu meinem Bedauern gibt es nicht viel Gutes zu berichten.
1. Die Anleitung finde ich eine Frechheit, es fehlen viele Erklärungen.
2. Der "individual Mode" wird nur unter Windows/Linux unterstützt. Jedoch nicht in meinem NAS von QNAP.
Kurz zur Erklärung der Individuelle Modus erlaubt das Durchreichen der einzelnen Festplatten auf Host-Ebene, sprich man kann jede Festplatte des Adapter-Raids über die NAS-Oberfläche selbst verwalten und zu weiteren RAIDS verknüpfen.
3. Die aktuellen Firmwaren ab 4.5.2.XXXX supporten den Adapter nicht mehr bzw. sind fehlerhaft. Die angeschlossenen Festplatten werden zum Teil gar nicht angezeigt oder nur sporadisch. Ein Stunden langes rumprobieren war die Folge.
Lösung war ein Firmware-Downgrade auf die 4.5.1.XXXX.
Fazit: Bei einem namhaften Hersteller wie Qnap hätte ich mehr Sorgfalt bezüglich der Firmware erwartet (Da die Problematik bereits seit 3 Firmware Updates zu bestehen scheint). Daher leider keine Kaufempfehlung - besonders bei dem doch nicht gerade geringen Preis welcher aufgerufen wird.

Ergo würde ich mir das nochmal überlegen...
 
Also das mit der Nicht-Unterstützung klingt irgendwie nicht so cool, auch weil QNAP selbst dies nirgends erwähnt. Damit würde mein Plan wie ein Kartenhaus in sich zusammen fallen. Allerdings kann der User auch schlichtweg inkompetent gewesen sein. Das klingt wieder nach einer harten Probier-Lösung (Try & Error), auf die ich eigentlich keinen Bock habe. Ich wollte das "Out of the box" einfach dahin zaubern.
 
2. Der "individual Mode" wird nur unter Windows/Linux unterstützt. Jedoch nicht in meinem NAS von QNAP.
Kurz zur Erklärung der Individuelle Modus erlaubt das Durchreichen der einzelnen Festplatten auf Host-Ebene,
Statt "unter Windows/Linux" meint er wohl am PC, aber leider wissen wir weder welche Hardware das war noch welches NAS er hat. Das Problem ist nämlich, dass der SATA Host Controller Port Multiplier auch unterstützten muss, dies ist nur optional und daher nicht bei allen der Fall. Die SATA Controller in den Intel Chipsätzen, keine Ahnung ob es bei den aktuellen noch so ist, aber bei älteren auf jeden Fall und in den NAS stecken ja oft recht alte CPUs drin, unterstützten aber leider keine Port Multiplier! Die AMD Chipsätze taten es früher, mein letztes AMD System war ein AM3 Board, machen es und da die SATA Controller seit Zen von ASMedia stammen deren SATA Host Controller ebenfalls Port Multiplier unterstützen, sollte dies auch immer noch der Fall sein. Deshalb habe ich das vorher gar nicht erwähnt, da es ja hier um ein QNAP TS-h973AX geht welches laut QNAP einen "AMD Ryzen™ V1000 series V1500B quad-core processor" hat.

In den anderen Modi sollte es aber sowieso selbst an Intel Chipsätzen kein Problem sein, wie ja auch in der Rezession geschrieben wurde, da hier der Host Controller ja nur ein Laufwerk sieht, auch wenn es in Wahrheit zwei im RAID oder JBOD (BIG) sind. Außerdem war ja davon die Rede das hier die beiden SSDs in Rahmen im RAID 0 laufen sollen.

Man muss bei Rezessionen eben immer aufpassen, auch wenn sie richtig und wahrheitsgemäß sind, so muss die Ursache nicht immer dort liegen wo man sie vermutet.
 
Naja, ich glaube schon auch, das es ein wenig auf das OS ankommt...
Ich hab z.B. nen Board mit integrieter CPU, da funktioniert der angeschlossene 5-Port SATA Port Multiplier im Linux (SuSe, Debian, Ubuntu, sogar VMware) wie ne 1 - unter Windows wird nur die Platte am Anschluß 1 erkannt.
 
Welches Board mit welcher CPU ist das? Welcher Treiber wird unter Windows verwendet?
 
Hardwareluxx setzt keine externen Werbe- und Tracking-Cookies ein. Auf unserer Webseite finden Sie nur noch Cookies nach berechtigtem Interesse (Art. 6 Abs. 1 Satz 1 lit. f DSGVO) oder eigene funktionelle Cookies. Durch die Nutzung unserer Webseite erklären Sie sich damit einverstanden, dass wir diese Cookies setzen. Mehr Informationen und Möglichkeiten zur Einstellung unserer Cookies finden Sie in unserer Datenschutzerklärung.


Zurück
Oben Unten refresh