Ergebnis 1 bis 4 von 4
  1. #1
    cpt sunday flyer Avatar von AliManali
    Registriert seit
    07.03.2012
    Beiträge
    2.365


    Standard OpenWRT-OpenVPN Web GUI Problem

    Hi

    Ich versuche mich an der Anleitung um auf einer OpenWRT VM NordVPN einzurichten.

    Ich scheitere da aber an Punkt 4. Wenn ich die Anleitung bis und mit 3. befolge, dann wird mir im OpenWRT Web Gui "Services > OpenVPN" im Menu angezeigt, aber leider der "OpenVPN Configuration File Upload" Teil nicht angezeigt wie am Schluss von 4. beschrieben. Also Anleitung befolgt, und den (die) Feeds angepasst für alle Komponenten. Nur ist da das Problem, dass in meinem GUI und beim Bild in der Anleitung andere Pfade nebst Luci auch nicht stimmen. *siehe Spoiler. Und in der Anleitung ist das Repro von Luci auf https, dann läd es schon gar nicht erst runter. Ich habe echt alle Pakete per CLI, Webgui, was weiss ich geladen, waren auch alle Pakete installiert und am laufen. Aber wenn ich die Snapshot Version von luci-app-openvpn nehme, dann wird in der Web-GUI der Menupunkt "Services > OpenVPN" nicht mehr angezeigt.

    Aba Jungs. Ich habs mit 18.06.4 probiert. Und dann bin ich auf 18.06.0 wie in der Anleitung geschwenkt. Der Menupunkt ist mal gelaufen, mit samt dem blöden "Upload OpenVPN Konfigfile". Aber ich hab das jenes lang getestet, brings weder mit der GUI noch per SSH wieder zum laufen...

    Hier die verschiednenen Feeds Links. Die sind bei mir irgendwie anders als nach Anleitung, bzw. der Bilder dort.




    Oh je. Hab das wirklich x-fach durch. Aber komme nicht weiter. Danke für die Hilfe.
    Linux is like a wigwam: No windows. No gates. Apache inside.

  2. Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

  3. #2
    Hauptgefreiter
    Registriert seit
    16.01.2010
    Beiträge
    177


    Standard

    Der Guide auf der NordVPN Seite ist etwas ungenau und lässt die Konfiguration offen.

    Die aktuelle stabile Version 18.06.4 hat eine alte Version von luci-app-openvpn, die kein Hochladen von .ovpn Dateien über die UI unterstützt (stable=keine neuen Features).
    Ein Konfiguration mit OpenVPN .ovpn Dateien ist afaik aber auch hier möglich über die Kommandozeile/per SSH Zugriff und uci - wiki - das ist aber komplizierter und fehleranfällig für Anfänger.

    Wenn du die Snapshot Version von OpenWRT verwendest, dann hat die VPN app auch den Upload button. Statt unter Services gibt es nun einen VPN Menüpunkt. (siehe openwrt wiki: hier).

    Vom Verwenden von Snapshot Paketen mit alten 18.06 Images würde ich abraten.

    Hab hier beides kurz in einer qemu VM getestet und es funktionierte mit der Snapshot variante.

  4. #3
    cpt sunday flyer Avatar von AliManali
    Registriert seit
    07.03.2012
    Beiträge
    2.365
    Themenstarter


    Standard

    Hoi

    Das ist super nett, dass Du das für mich ausprobiert hast in einer VM! Wie gesagt, bei mir hats nicht geklappt mit 18.06 und 18.06.4. Was das mit der Snapshot Version auf sich hat: da habe ich Null Plan von! Ist das quasi rolling release? Hast Du es mit der Snapshot Version zum laufen gebracht mit dem import button? Wär das aktueller? Soll ich die nehmen? Wo zieh ich mir die Snapshot Version rein?

    Und wie kriege ich das Image dort am besten in die VM? Ich habe die combined-ext4.img.gz runter geladen, unter Windows enpackt, und unter vmware clonezilla gestartet um das einzuspielen. Wenn ich das recht verstehe, mach ich da nur dd? Wie geht das am einfachsten?

    tyvm
    Geändert von AliManali (08.11.19 um 11:55 Uhr)
    Linux is like a wigwam: No windows. No gates. Apache inside.

  5. #4
    cpt sunday flyer Avatar von AliManali
    Registriert seit
    07.03.2012
    Beiträge
    2.365
    Themenstarter


    Standard

    Hi

    Super! Hat mal geklappt soweit mit der Snapshot Version.
    Linux is like a wigwam: No windows. No gates. Apache inside.

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •