Ergebnis 1 bis 3 von 3
  1. #1
    Oberbootsmann Avatar von Luckysh0t
    Registriert seit
    08.11.2009
    Ort
    Daheim
    Beiträge
    873


    • Systeminfo
      • Motherboard:
      • ASUS ROG STRIX B350-F GAMING
      • CPU:
      • AMD Ryzen 5 1600X
      • Kühlung:
      • Noctua NH-D15 SE-AM4
      • Gehäuse:
      • Nanoxia Deep Silence 1 Rev. B
      • RAM:
      • 16 GB G.Skill FlareX DDR4-3200
      • Grafik:
      • PowerColor Go Green 6570
      • Storage:
      • Samsung 960 Evo 512 GB
      • Monitor:
      • Dell UltraSharp 21,5
      • Netzteil:
      • Be Quiet Dark Power Pro 550 W
      • Betriebssystem:
      • Windows 10 Pro

    Standard Default Java ändern/aktualisieren in Solaris ging schief..und geht gar kein Java mehr

    Guten Abend zusammen,

    ich wollte eigentlich Cryptomator (*. jar Version) auf meinem Solaris Filer ausführen - *verzweifelte Lache* leichter gesagt als getan...

    Da es beim ersten Ausführen mittels java -jar cryptomatorx.x.x sehr viele Fehlermeldungen gab, dachte ich erstmal ich aktualisiere mal Java, da es wohl jre8 benötigt.

    Also Java von How do I download and install Java for Solaris? geladen und entpackt.

    Nun wollte ich dem ganzen auch das neue Java bekannt machen..tja und nun beginnen die Probleme..

    How to set the default java in Solaris? - Server Fault

    Code:
    cd /usr
    # rm java "hier wird ja wohl das alte Java entfernt, oder ?"
    # ln -s jdk/jdk1.8.0_121 java "hier das neue bekannt gemacht ?"   
    # java -version "Das funktioniert schonmal nicht mehr, weil kein Java bekannt..."
    java version "1.8.0_121"
    Java(TM) SE Runtime Environment (build 1.8.0_121-b13)


    Wäre toll, wenn sich jemand findet de rmir aus der Misere helfen kann.


    Gruß

    Lucky
    Solaris,Filer,vBox Host: Chenbro SR30169 - AMD Athlon 5350 - AC M1 - ASRock AM1B-ITX - 16 GB DDR 3 1600 - Crucial SSD (Rpool) - SanDisk SSD (VM Pool) - Seagate Ironwolf (Datenpool) - BQ PP 9 300W - Dual 10 Gbit CNA SFP+
    Pi 3B+,DietPi: RAID1-iSCSI auf dem ESXi durch VMWare Workstation installiert ist
    Infra:UBNT UniFi USG, UBNT UniFi AP-AC-LR, MT CSS326-24G-2S+RM
    vBoxVM on Solaris: DietPi (PiHole), Ubuntu Server (UniFi Controller), Win7 (itunes Airplay Server)
    D3-Profil

  2. Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

  3. #2
    Matrose
    Registriert seit
    28.05.2011
    Beiträge
    19


    Standard

    Zitat Zitat von Luckysh0t Beitrag anzeigen
    # java -version "Das funktioniert schonmal nicht mehr, weil kein Java bekannt..."
    Wie kein Java bekannt? Was _genau_ passiert?

    Zitat Zitat von Luckysh0t Beitrag anzeigen
    java version "1.8.0_121"
    Java(TM) SE Runtime Environment (build 1.8.0_121-b13)
    Wird doch gefunden. Was willst du noch?

    Zitat Zitat von Luckysh0t Beitrag anzeigen
    Wäre toll, wenn sich jemand findet de rmir aus der Misere helfen kann.
    Ich kann das Problem nicht nachvollziehen.

    Üblicherweise sind zum bequemen Starten von Java-Programmen 2 Dinge nötig:
    - $JAVA_HOME auf den Pfad der zu verwendenden Java-Installation setzen
    - $PATH so ergänzen, dass das passende, ausführbare "java" gefunden wird (in der Regel liegt das in $JAVA_HOME/bin)

    Ich würde das mit Slowlaris daherkommende Java übrigens nicht anfassen. Es gibt mitgelieferte Programme, die das benötigen. Da man problemlos beliebig viele Java-Installationen nebeneinander betreiben kann, gibts auch gar keinen Grund, die vorinstallierte Version kaputt zu machen, wenn man eine andere benötigt. Einfach die gewünschte Version zusätzlich irgendwo installieren, o.g. Variablen anpassen und fertig.
    Geändert von mensch183 (13.06.18 um 01:39 Uhr)

  4. #3
    Oberbootsmann Avatar von Luckysh0t
    Registriert seit
    08.11.2009
    Ort
    Daheim
    Beiträge
    873
    Themenstarter


    • Systeminfo
      • Motherboard:
      • ASUS ROG STRIX B350-F GAMING
      • CPU:
      • AMD Ryzen 5 1600X
      • Kühlung:
      • Noctua NH-D15 SE-AM4
      • Gehäuse:
      • Nanoxia Deep Silence 1 Rev. B
      • RAM:
      • 16 GB G.Skill FlareX DDR4-3200
      • Grafik:
      • PowerColor Go Green 6570
      • Storage:
      • Samsung 960 Evo 512 GB
      • Monitor:
      • Dell UltraSharp 21,5
      • Netzteil:
      • Be Quiet Dark Power Pro 550 W
      • Betriebssystem:
      • Windows 10 Pro

    Standard

    Zitat Zitat von mensch183 Beitrag anzeigen
    Wird doch gefunden. Was willst du noch?
    Achja, das war nur aus dem Link die Reihenfolge, bei mir kommt " Java nicht gefunden.Dank rm Java ist dass ja wohl weg..nunja ich werde mal mein vorheriges Bootenviroment booten und dann sauber von vorne beginnen - am besten erstmal in einer test Vm...und nicht am Livesystem..
    Geändert von Luckysh0t (13.06.18 um 08:32 Uhr)
    Solaris,Filer,vBox Host: Chenbro SR30169 - AMD Athlon 5350 - AC M1 - ASRock AM1B-ITX - 16 GB DDR 3 1600 - Crucial SSD (Rpool) - SanDisk SSD (VM Pool) - Seagate Ironwolf (Datenpool) - BQ PP 9 300W - Dual 10 Gbit CNA SFP+
    Pi 3B+,DietPi: RAID1-iSCSI auf dem ESXi durch VMWare Workstation installiert ist
    Infra:UBNT UniFi USG, UBNT UniFi AP-AC-LR, MT CSS326-24G-2S+RM
    vBoxVM on Solaris: DietPi (PiHole), Ubuntu Server (UniFi Controller), Win7 (itunes Airplay Server)
    D3-Profil

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •