Ergebnis 1 bis 7 von 7
  1. #1
    Oberstabsgefreiter
    Registriert seit
    05.07.2009
    Ort
    nähe Freiburg
    Beiträge
    421


    • Systeminfo
      • Motherboard:
      • ASRock Z390 Taichi
      • CPU:
      • Intel i7 8700K @4,8Ghz uV
      • Kühlung:
      • Genesis 2x140 - geköpfte CPU
      • Gehäuse:
      • Fractal Design Define XL R2
      • RAM:
      • 2x8GB G.Skill TridentZ F4-3200
      • Grafik:
      • EVGA GTX 1070TI SC @ MK-26
      • Storage:
      • Samsung 840 EVO 1TB; 2x HDD WD Green 3TB
      • Monitor:
      • Sony 40 Zoll LED KDL-40NX805
      • Netzwerk:
      • Unitymedia 400Mbit/20Mbit
      • Sound:
      • 2x nuPro A300+AW600 / YulongU100+DT990
      • Netzteil:
      • Bquiet Dark Pro 10 | 850W
      • Betriebssystem:
      • Win10 64bit Pro
      • Notebook:
      • Acer Aspire mit SSD Crucial M4 256GB
      • Handy:
      • Samsung S8

    Question extreme FPS drops sobald FPS Limiter aktiviert!? - teils gelöst

    Hi Leute,

    ich weiß nicht ob ich hier damit richtig bin aber ich habe folgendes Problem:

    Mein System: (detailliert,siehe links "Systeminfo")
    Monitor/TV 40 Zoll älterer Standard Sony 60Hz LED
    CPU: i7 8700K
    GK: GTX 1070 TI neueste Treiber

    Sobald ich über Nvidia Inspector meinem PC ein FPS Limit setzte, egal ob 58, 60, 65, 100 oder 200, habe ich in verschiedenen Spielen extreme FPS drops immer an den selben stellen. Alles reproduzierbar.
    Ich habe ohne V-Sync, mit V-Sync und auch mit der Option "Schnell" diese FPS drops. Sobald ich aber den FPS Limiter deaktiviere habe ich keine FPS drops mehr, auch nicht an den bestimmten stellen.

    Ich nehme als Beispiel Assasins Creed Odyssey, mit seinem internen Benchmark. An zwei stellen mit FPS Limiter habe ich extreme FPS Drops, bei der die CPU frametime in den roten Bereich hoch geht. Immer dann wenn man die zwei Momente sieht in der man einen weiten Panoramablick in die weite Welt hat.
    Hier ein Video von jemand anderem, mit einem gleichwertigen System, bei dem es ohne Probleme geht: https://www.youtube.com/watch?v=x-YLUkarkZM
    Die Probleme tauchen bei mir etwa bei 0:08 das erste mal für ca. 2 Sekunden und dann nochmal bei etwa 0:55 für ca. 7 Sekunden auf.

    Wie gesagt, sobald der FPS Limiter wieder deaktiviert ist läuft bei mir alles Smooth, jedoch möchte ich schon gerne mit Limiter arbeiten können, da ich ungern höhere Temperaturen und Energieverbrauch haben möchte durch zu viel produzierte FPS die ich nicht brauche, da ich nur einen 60Hz Monitor/TV habe.


    Kann mir jemand weiter Helfen? Ich bin leider am Ende meines Lateins angekommen...

    Grüße
    darky1986

    - - - Updated - - -

    Habe das Problem größten Teils Lösen können.

    Anstatt die FPS über Nvidia Inspector zu limitieren, was glaube ich Hardware/Treiberseitig läuft, lasse ich jetzt die FPS über RivaTunterStatisticServer (RTSS von/mit MSI Afterburner) limitieren, was soweit ich weiß Softwareseitig ist.

    Die einige Sekunden lange extremen FPS drops bzw. niedrig anhaltende FPS sind damit weg, jedoch merkt man zu Beginn der Momente, wo sie früher waren, einen ganz kurzen (1 Millisekunde) Drop/Ruckler. Damit kann ich aber leben... weil die höhere Hitze der Grafikkarte und der höhere Energiebedarf sind es mir nicht im Vergleich dazu Wert...


    Falls jemand eine noch bessere Lösung kennt/findet, teilt es mir gerne mit.


    Grüße
    darky1986


    edit 06.2019:

    Neue Info:
    mit dem neuen 436.15 Geforce Treiber habe ich wieder diese länger anhaltende FPS Drops, solange die Option "Ultra" bei "Low Latency" eingestellt ist. Stelle ich auf "ON" oder "OFF" geht alles wieder geschmeidig. Zuvor, vor der Clean Treiber Installation, spielte diese "Low Latency" Option keine Rolle, habe alles vorher schon ausprobiert (OFF, ON, Ultra"), es war ausschließlich der Hardwareseitige/Treiberseitige FPS CAP für das Problem verantworltich. Mit dem FPS CAP nur über RivaTuner läuft es wunderbar.
    Geändert von darky1986 (06.09.19 um 06:16 Uhr) Grund: neue Info, seit Treiber Update
    Füar jägliche Rächtschriebfehler ubernimm ike kaine Havtung !

  2. Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

  3. #2
    Oberbootsmann Avatar von Hyrasch
    Registriert seit
    10.12.2012
    Beiträge
    885


    Standard

    Die Bildrate mittels Programmen wie Rivatuner, nvidia inspector, amd frtc/enhanced sync etc. zu limitieren, aber auch die Option bei der nvidia Systemsteuerung die "Vertikale Synchronisierung" auf "Schnell" zu stellen, und nicht intern (wenn die Option vorhanden ist), erhöht die Gesamtlatenz; ist messbar und meist auch spürbar.

    Szenen wo viel Berechnungen durchgeführt werden, viel im Spiel nachgeladen werden muss, sich die Szene schnell ändert?
    Dann gehe ich davon aus dass du durch die Bildratenlimitierung, bei der die Bildrate nicht überschriten werden soll, diese leistungsfordernden Szenen einfach bemerkst, da hier kurzzeitig die Bildrate sinkt und dieser Puffer (höhere Bildraten > 60 runter auf >= 60) nun fehlt.
    Entwickler unterschieden hier zwischen einem Festsetzen der Bildrate auf einen bestimmten Wert und einem Limitieren der Bildrate auf einen bestimmten Wert.
    Nur weil du limitierst, heißt es nicht dass die Bildrate nicht dennoch sinken kann.

  4. #3
    Oberstabsgefreiter
    Registriert seit
    05.07.2009
    Ort
    nähe Freiburg
    Beiträge
    421
    Themenstarter


    • Systeminfo
      • Motherboard:
      • ASRock Z390 Taichi
      • CPU:
      • Intel i7 8700K @4,8Ghz uV
      • Kühlung:
      • Genesis 2x140 - geköpfte CPU
      • Gehäuse:
      • Fractal Design Define XL R2
      • RAM:
      • 2x8GB G.Skill TridentZ F4-3200
      • Grafik:
      • EVGA GTX 1070TI SC @ MK-26
      • Storage:
      • Samsung 840 EVO 1TB; 2x HDD WD Green 3TB
      • Monitor:
      • Sony 40 Zoll LED KDL-40NX805
      • Netzwerk:
      • Unitymedia 400Mbit/20Mbit
      • Sound:
      • 2x nuPro A300+AW600 / YulongU100+DT990
      • Netzteil:
      • Bquiet Dark Pro 10 | 850W
      • Betriebssystem:
      • Win10 64bit Pro
      • Notebook:
      • Acer Aspire mit SSD Crucial M4 256GB
      • Handy:
      • Samsung S8

    Standard

    Zitat Zitat von Hyrasch Beitrag anzeigen
    Die Bildrate mittels Programmen wie Rivatuner, nvidia inspector, amd frtc/enhanced sync etc. zu limitieren, aber auch die Option bei der nvidia Systemsteuerung die "Vertikale Synchronisierung" auf "Schnell" zu stellen, und nicht intern (wenn die Option vorhanden ist), erhöht die Gesamtlatenz; ist messbar und meist auch spürbar.
    -Das ist mir schon alles klar, um die Latenz geht es mir nicht

    Zitat Zitat von Hyrasch Beitrag anzeigen
    Szenen wo viel Berechnungen durchgeführt werden, viel im Spiel nachgeladen werden muss, sich die Szene schnell ändert?
    Dann gehe ich davon aus dass du durch die Bildratenlimitierung, bei der die Bildrate nicht überschriten werden soll, diese leistungsfordernden Szenen einfach bemerkst, da hier kurzzeitig die Bildrate sinkt und dieser Puffer (höhere Bildraten > 60 runter auf >= 60) nun fehlt.
    wie gesagt ist es egal ob ich V-Sync an/aus oder die Option "Schnell" benutze, sobald die FPS Limitiert werden, auf egal welchen Wert, habe ich FPS Drops bis runter auf 15 fps bei bestimmten reproduzierbaren Situationen und das teils über mehrere Sekunden lang, sehe ich alles über einen Graphen der mitläuft und die FPS, Frametimes etc. über längeren Zeitraum anzeigt. Stelle ich jedoch das FPS Limit aus, so habe ich keine FPS Drops mehr sondern mindestens angenehme 45 FPS in den besagten Situationen, ansonsten z.B. die auf 60 FPS die ich limitiert habe.
    Hinzukommt das wenn ich RTSS (Rivatuner) anstatt Nvidia Inspector zum Limitieren benutze, ich diese Sekundenlange FPS drops nicht mehr habe sondern nur noch einmalig einen 1 Millisekunden Drop, was ich in kauf nehme für niedrigere Temps und Energieverbrauch

    Zitat Zitat von Hyrasch Beitrag anzeigen
    Entwickler unterschieden hier zwischen einem Festsetzen der Bildrate auf einen bestimmten Wert und einem Limitieren der Bildrate auf einen bestimmten Wert.
    Nur weil du limitierst, heißt es nicht dass die Bildrate nicht dennoch sinken kann.
    -das eine limitierte Bildrate sinken kann ist mir logischer weise klar... ich deckle ja nur die fps nach oben hin ab... nach unten können die FPS so weit gehen wie Leistung dafür eben fehlt. Und bei der Option "Schnell" oder "V-Sync aus" ist ja nichts festgesetzt und trotzdem besteht das Problem wenn die FPS limitiert werden.
    Geändert von darky1986 (22.08.19 um 13:41 Uhr)
    Füar jägliche Rächtschriebfehler ubernimm ike kaine Havtung !

  5. #4
    Kackbratze Avatar von Scrush
    Registriert seit
    31.12.2008
    Ort
    Hessen
    Beiträge
    33.566


    • Systeminfo
      • Motherboard:
      • Gigabyte Aorus Master
      • CPU:
      • i9 9900K
      • Systemname:
      • Schrottkiste
      • Kühlung:
      • Corsair H150i Pro RGB
      • Gehäuse:
      • LianLi O11-Dynamic White
      • RAM:
      • 32Gb Corsair 3200Mhz RGB Pro
      • Grafik:
      • KFA² GTX 1080 HOF
      • Storage:
      • Samsung 960, 850, 840, WD Red
      • Monitor:
      • ASUS ROG Swift PG279Q & Dell u2414h
      • Netzwerk:
      • Speedport 724v Type B
      • Sound:
      • Beyerdynamic DT1990Pro @ AUNE T1SE
      • Netzteil:
      • Be-Quiet SP11-650W
      • Betriebssystem:
      • Win 10 Pro
      • Handy:
      • Samsung Galaxy S10

    Standard

    nur mit dem inspector gemacht oder auch mal mit AB ?

  6. #5
    Oberstabsgefreiter
    Registriert seit
    05.07.2009
    Ort
    nähe Freiburg
    Beiträge
    421
    Themenstarter


    • Systeminfo
      • Motherboard:
      • ASRock Z390 Taichi
      • CPU:
      • Intel i7 8700K @4,8Ghz uV
      • Kühlung:
      • Genesis 2x140 - geköpfte CPU
      • Gehäuse:
      • Fractal Design Define XL R2
      • RAM:
      • 2x8GB G.Skill TridentZ F4-3200
      • Grafik:
      • EVGA GTX 1070TI SC @ MK-26
      • Storage:
      • Samsung 840 EVO 1TB; 2x HDD WD Green 3TB
      • Monitor:
      • Sony 40 Zoll LED KDL-40NX805
      • Netzwerk:
      • Unitymedia 400Mbit/20Mbit
      • Sound:
      • 2x nuPro A300+AW600 / YulongU100+DT990
      • Netzteil:
      • Bquiet Dark Pro 10 | 850W
      • Betriebssystem:
      • Win10 64bit Pro
      • Notebook:
      • Acer Aspire mit SSD Crucial M4 256GB
      • Handy:
      • Samsung S8

    Standard

    Zitat Zitat von darky1986 Beitrag anzeigen
    - - - Updated - - -

    Habe das Problem größten Teils Lösen können.

    Anstatt die FPS über Nvidia Inspector zu limitieren, was glaube ich Hardware/Treiberseitig läuft, lasse ich jetzt die FPS über RivaTunterStatisticServer (RTSS von/mit MSI Afterburner) limitieren, was soweit ich weiß Softwareseitig ist.

    Die einige Sekunden lange extremen FPS drops bzw. niedrig anhaltende FPS sind damit weg, jedoch merkt man zu Beginn der Momente, wo sie früher waren, einen ganz kurzen (1 Millisekunde) Drop/Ruckler. Damit kann ich aber leben... weil die höhere Hitze der Grafikkarte und der höhere Energiebedarf sind es mir nicht im Vergleich dazu Wert...
    zuerst NV Inspector, jetzt mit RTSS
    Geändert von darky1986 (22.08.19 um 13:42 Uhr)
    Füar jägliche Rächtschriebfehler ubernimm ike kaine Havtung !

  7. #6
    Bootsmann
    Registriert seit
    02.07.2013
    Beiträge
    753


    • Systeminfo
      • Motherboard:
      • ASUS Rampage Extrem X99
      • CPU:
      • 5820K/1,26V-@4,7
      • Kühlung:
      • Aquastream XT, 2*480+Mora420
      • Gehäuse:
      • Phantek Enthoo Primo
      • RAM:
      • G.Skill Trident Z 3600
      • Grafik:
      • 2080 TI
      • Storage:
      • Samsung EVO 1000
      • Monitor:
      • Sony 4K Beamer VPL-VW260
      • Sound:
      • Asus Xonar Essence STX II
      • Netzteil:
      • Corsair 1200AXI
      • Betriebssystem:
      • WIN10 - 64Bit

    Standard

    kenne ein ähnliches Problem, ich stelle den Limiter immer auf 58, dass Bild ist somit geschmeidiger als mit 60...Versuchs mal

  8. #7
    Oberstabsgefreiter
    Registriert seit
    05.07.2009
    Ort
    nähe Freiburg
    Beiträge
    421
    Themenstarter


    • Systeminfo
      • Motherboard:
      • ASRock Z390 Taichi
      • CPU:
      • Intel i7 8700K @4,8Ghz uV
      • Kühlung:
      • Genesis 2x140 - geköpfte CPU
      • Gehäuse:
      • Fractal Design Define XL R2
      • RAM:
      • 2x8GB G.Skill TridentZ F4-3200
      • Grafik:
      • EVGA GTX 1070TI SC @ MK-26
      • Storage:
      • Samsung 840 EVO 1TB; 2x HDD WD Green 3TB
      • Monitor:
      • Sony 40 Zoll LED KDL-40NX805
      • Netzwerk:
      • Unitymedia 400Mbit/20Mbit
      • Sound:
      • 2x nuPro A300+AW600 / YulongU100+DT990
      • Netzteil:
      • Bquiet Dark Pro 10 | 850W
      • Betriebssystem:
      • Win10 64bit Pro
      • Notebook:
      • Acer Aspire mit SSD Crucial M4 256GB
      • Handy:
      • Samsung S8

    Standard

    Neue Info:

    mit dem neuen 436.15 Geforce Treiber habe ich wieder diese länger anhaltende FPS Drops, solange die Option "Ultra" bei "Low Latency" eingestellt ist. Stelle ich auf "ON" oder "OFF" geht alles wieder geschmeidig. Zuvor, vor der Clean Treiber Installation, spielte diese "Low Latency" Option keine Rolle, habe alles vorher schon ausprobiert (OFF, ON, Ultra"), es war ausschließlich der Hardwareseitige/Treiberseitige FPS CAP für das Problem verantworltich. Mit dem FPS CAP nur über RivaTuner läuft es wunderbar.

    @ Schu:
    Habe immer auf 59 gecapt wegen der geringeren Latenz als wenn 60 eingestellt ist, jedoch alles schon ausprobiert z.B. 30, 50, 58, 59, 60, 61, 65, 100, 120 und ohne, sprich Frei
    Füar jägliche Rächtschriebfehler ubernimm ike kaine Havtung !

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •