Seite 355 von 355 ErsteErste ... 255 305 345 351 352 353 354 355
Ergebnis 8.851 bis 8.869 von 8869
  1. #8851
    gea
    gea ist offline
    Fregattenkapitän
    Registriert seit
    16.11.2010
    Beiträge
    2.995


    Standard

    Einen Sammelthread "ZFS" der nur das Dateisystem abdeckt, halte ich nicht für sinnvoll.

    Man käme auch nicht auf die Idee sowas für ext4 oder ntfs zu machen. Als Sun ZFS für sein neues OpenSolaris entwickelte, war ZFS aber von Anbeginn als hochintegrierte Lösung gedacht die tief in das Betriebssystem eingebettet ist und neben dem reinen Dateisystem auch Volumemanagement Raidmanagement und iSCS//NFS/SMB (mit AD ACL) Sharemanagement abdeckt. Fragen zu ZFS lassen sich von Anbeginn nicht immer vom Betriebssystem abkoppeln.

    Man kann jetzt natürlich diskutieren ob Fragen zur Solaris Netzwerkkonfiguration (und das ist es ja aktuell, hat nichts mit dem Management Tool napp-it zu tun) in diesen Thread gehört da es User von BSD oder Linux nicht interessiert. Historisch ist ZFS wie dieser Thread aber Solaris + ZFS insofern gehören Solarish Fragen durchaus in diesen Thread (wohin auch sonst). Ich habe aber auch kein Problem damit wenn hier Fragen auftauchen die eher als Systemfragen zu BSD oder Linux zählen und nur hier landen weil eben auch ZFS benutzt wird und sich hier die Leute tummeln die was dazu sagen könnten. Wenn es ganz weit weg geht von ZFS kann man einen separaten Thread als Option sehen.

    Insgesamt sehe ich diesen Sammler als DIE deutschsprachige Anlaufstelle für alle die was mit ZFS machen wollen. Einen separaten BSD+ZFS, Linux+ZFS und Solarish+ZFS Thread sehe ich nicht als sinnvoll (da viel zu wenig Traffic). Dann noch zu unterscheiden ob man FreeNAS, Nas4Free, ZFSGuru (Free-BSD), OMV (Linux) oder eben napp-it (OI, OmniOS/Illumos, Solaris oder Linux) oder NexentaStor (Illumos) als Web-Management-Tool auf einem der drei Betriebssysteme nutzt, würde nur zu 10 bedeutungslosen Threads führen.

    In USA mag das anders sein. Da macht ein Spezialforum zu ZFS unter Solarish mit napp-it schon Sinn.
    OpenSolaris derived ZFS NAS/ SAN (OmniOS, OpenIndiana, Solaris and napp-it) | [H]ard|Forum hat 8000 Antworten und 1.7 Millionen Hits

    Solaris, Nexenta, OpenIndiana, and napp-it | ServeTheHome and ServeThe.Biz Forums hat die meisten Hits und Antworten im Bereich "Software Platforms" und schlägt da noch BSD, Linux oder Windows.

    Als englischsprachige Foren haben die aber eine ganz andere (weltweite) Reichweite.

  2. Wenn Du diese Anzeige nicht sehen willst, registriere Dich und/oder logge Dich ein.

  3. #8852
    Hauptgefreiter Avatar von hoppel118
    Registriert seit
    07.04.2012
    Beiträge
    215


    Standard ZFS Stammtisch

    Ok, dann haben wir es eigentlich geklärt.

    Alles was mit ZFS zu tun hat, bleibt in diesem Thread. Alles was nicht damit zu tun hat, wird freundlich darum gebeten zu dem konkreten Thema einen eigenen Thread aufzumachen.

    Ich sehe es auch nicht als sinnvoll an, für die verschiedenen „ZFS-Betriebssysteme“ (Linux, Solaris, what ever) eigene Threads zu erstellen, zumal sich die CLI-Befehle nur selten (oder gar nicht?) unterscheiden. Und wenn’s um die Bedienung der verschiedenen WebUIs oder irgendwelches Fehlverhalten in diesen geht, soll dies meinetwegen auch gern hier diskutiert werden. Aber wie man in einem bestimmten OS bspw. die Netzwerkverbindung konfiguriert, gehört hier nicht hin, auch wenn man dich @gea hier sehr gut erreichen kann.

    Das was wir hier gerade abstimmen, ist für mich die normale Vorgehensweise in Foren. Spezifische Openmediavault-Probleme spreche ich sowieso nur im OMV Forum an. Für generelle ZFS/ZoL-Themen nutze ich diesen Thread sehr gerne, da ich hier in Landessprache schreiben kann.

    Gruß Hoppel
    Geändert von hoppel118 (13.06.18 um 16:28 Uhr)

  4. #8853
    Gefreiter
    Registriert seit
    07.12.2013
    Beiträge
    44


    • Systeminfo
      • Motherboard:
      • ASUS Z97-WS
      • CPU:
      • i7 4790K
      • Kühlung:
      • Custom Loop
      • Gehäuse:
      • Lian Li PC-A77
      • RAM:
      • 32GB, DDR3L-1600, CL9-9-9-24
      • Grafik:
      • Titan X (Pascal)
      • Storage:
      • SSDs (8TB) + 2 NAS (32TB)
      • Netzteil:
      • be quiet! DPP 10 550W
      • Betriebssystem:
      • Windows 10

    Standard

    Gibt es irgendwo Benchmarks der ZFS Verschlüsselung unter Solaris? Bisher hat mir Google da nur Ergebnisse zu alten Solarisversionen mit sehr alter Hardware geliefert. Ich plane gerade ein NAS und weiß noch nicht, ob Verschlüsselung für mich denkbar ist und welche CPU ich da bräuchte. Falls es nichts konkretes gibt, würde es schon helfen zu wissen ob die Verschlüsselung bei einer modernen CPU mit AES NI ähnlichen Durchsatz erreicht wie zB TrueCrypt oder BitLocker.

    Oder ganz konkret, falls das zufällig jemand beantworten kann: Kriege ich mit einem Xeon 4108/4110 1,25GB/s hin? Was für IOPS darf man erwarten?

  5. #8854
    gea
    gea ist offline
    Fregattenkapitän
    Registriert seit
    16.11.2010
    Beiträge
    2.995


    Standard

    Ich kenne keine aktuellen Vergleichszahlen.
    Als Solaris ZFS Verschlüssellung herauskam gabs ein paar Tests im Vergleich zur Device-Verschlüssellung unter BSD. Das Ergebnis damals war dass AES NI unterstützt wird, Solaris aber nicht ganz so schnell war wie Geli. Oracle hat das in der Zwischenzeit aber sicher verbessert.

    1.25 Gbit/s ist sicher kein Problem mit einem aktuellen Xeon. 1.25 Gbyte/s schon eher (auch unverschlüsselt).

    Iops dürfte eher vom Storage denn der Verschlüssellung abhängig sein.

  6. #8855
    Gefreiter
    Registriert seit
    07.12.2013
    Beiträge
    44


    • Systeminfo
      • Motherboard:
      • ASUS Z97-WS
      • CPU:
      • i7 4790K
      • Kühlung:
      • Custom Loop
      • Gehäuse:
      • Lian Li PC-A77
      • RAM:
      • 32GB, DDR3L-1600, CL9-9-9-24
      • Grafik:
      • Titan X (Pascal)
      • Storage:
      • SSDs (8TB) + 2 NAS (32TB)
      • Netzteil:
      • be quiet! DPP 10 550W
      • Betriebssystem:
      • Windows 10

    Standard

    Ein Vergleich Solaris vs Geli wäre auch interessant, da ich zumindest zu FreeNAS ein bisschen was gefunden habe. hier erreicht jemand storage limitiert ~300 MB/s und sein i5-4570 hat dabei 10% Auslastung unverschlüsselt und 20% Auslastung verschlüsselt.
    Wenn man das stumpf hochrechnen würde, ich habe keine Ahnung wie realitätsfremd das ist, könnte sein System locker 10 GBit/s verschlüsselt liefern. Bei einem lokalen Test mit dd ohne Netzwerkprotokolle wohlgemerkt.
    Da der Xeon 4110 ~66% schneller als der i5-4570 ist, bleibt für mich die Frage, ist Geli mehr als 60% schneller als die Solaris Lösung?

    Inwiefern sind 10 Gbit/s bzw. 1.25 GByte/s unverschlüsselt ein Problem? Nur vom Storage her? Gehen wir hier einfach mal von einer RAM Disk oder meinetwegen einem 4 x 6 RAIDZ2 über NVMe SSDs aus(, auch wenn die CPU nicht so viele Lanes hat).
    Soll da die CPU schon Schwierigkeiten kriegen, oder gehts um die Netzwerk- und Freigabeprotokolle?

  7. #8856
    Oberbootsmann Avatar von Luckysh0t
    Registriert seit
    08.11.2009
    Ort
    Daheim
    Beiträge
    809


    • Systeminfo
      • Motherboard:
      • ASUS ROG STRIX B350-F GAMING
      • CPU:
      • AMD Ryzen 5 1600X
      • Kühlung:
      • Noctua NH-D15 SE-AM4
      • Gehäuse:
      • Lian Li Armorsuit PC-P50
      • RAM:
      • 16 GB G.Skill FlareX DDR4-3200
      • Grafik:
      • PowerColor Go Green 6570
      • Storage:
      • Samsung 960 Evo 512 GB
      • Monitor:
      • Dell UltraSharp 21,5
      • Netzteil:
      • Be Quiet Dark Power Pro 550 W
      • Betriebssystem:
      • Windows 10 Pro

    Standard

    In wie fern nehme ich mir eigentlich die Selbstheilungsfähigkeiten etc. von ZFS, wenn ich einen Pool bzw. Filesystem als Read only markiere ?
    Geändert von Luckysh0t (15.06.18 um 07:05 Uhr)
    Solaris,Filer,vBox Host: Chenbro SR30169 - AMD Athlon 5350 - AC M1 - ASRock AM1B-ITX - 16 GB DDR 3 1600 - Crucial SSD (Rpool) - SanDisk SSD (VM Pool) - Seagate Ironwolf (Datenpool) - BQ PP 9 300W
    Pi 3B+,DietPi: RAID1-iSCSI auf dem ESXi durch VMWare Workstation installiert ist
    Infra:UBNT UniFi USG, UBNT UniFi AP-AC-LR, MT CSS326-24G-2S+RM
    vBoxVM on Solaris: DietPi (PiHole), Ubuntu Server (UniFi Controller), Win7 (itunes Airplay Server)
    D3-Profil

  8. #8857
    Oberstabsgefreiter
    Registriert seit
    16.04.2012
    Beiträge
    408


    Standard

    kann zumindest sagen dass Snapshots zu erstellen sind selbst wenn das Dataset auf ReadOnly gesetzt ist in Nappit.

  9. #8858
    Matrose
    Registriert seit
    05.03.2017
    Beiträge
    24


    Standard

    moinsen
    hab napp-it schon länger im hintergrund am laufen, bis jetzt alles TOP als VM mit esxi6.5

    was ich aber bis jetzt nie hinbekommen habe ist der hostname.
    den habe ich damals unter:
    System- Network- Eth- hostname
    vergeben.

    und dann habe ich in der hosts auch die IP und den Hostnamen eingetragen aber trotzdem zeigt mein Lancom Router den hostnamen nicht an, das selbe wenn ich einen L3 switch nehme.
    andere vms werden korrekt erkannt. habe ich irgend etwas vergessen ?

  10. #8859
    Kapitän zur See
    Registriert seit
    13.06.2006
    Ort
    Würzburg
    Beiträge
    3.134


    • Systeminfo
      • Motherboard:
      • M5A97 LE R2.0 | X8DTL-iF
      • CPU:
      • FX-6300 | Xeon X5677
      • Systemname:
      • Karl | Gut(t)enberg
      • Kühlung:
      • T-Spirit 120/2x80 | pasv/5x80
      • Gehäuse:
      • Chenbro RM413 | Supermicro 836
      • RAM:
      • 2x 8GB ECC | 3x 16GB reg ECC
      • Grafik:
      • 260X 2GB | G200eW + IPMI
      • Storage:
      • 128GB | 40GB + 8x2000GB (Z2)
      • Monitor:
      • EX3501R | SSH?
      • Netzwerk:
      • Fritz 7362SL, MikroTik wAP ac
      • Sound:
      • ReVox Evolution und DRECKIGER ONBOARDSOUND :))
      • Netzteil:
      • Focus 450 | Fractal 450 + USV
      • Betriebssystem:
      • Ubuntu 18.04 | Solaris 11.3
      • Sonstiges:
      • janz viele ESP8266!
      • Notebook:
      • ThinkPad T400 / P9700 / 2x4GB / 256+128+2x32 GB / WXGA+ LED / GMA + 2503 Grakadock / 3x3abgn-ac+UTMS
      • Photoequipment:
      • Canon S100
      • Handy:
      • Galaxy S5, N900

    Standard

    Zitat Zitat von Bccc1 Beitrag anzeigen
    Oder ganz konkret, falls das zufällig jemand beantworten kann: Kriege ich mit einem Xeon 4108/4110 1,25GB/s hin? Was für IOPS darf man erwarten?
    1,25GB/s schiebst du sehr sicher via AES-NI durch die Kerne. Die Frage wäre da eher, wo die Geschwindigkeit plattenseitig herkommt, und wie du sie zum Client kriegst. IOPS sind rein von deinem Storage abhängig.

    Wenn du mir sagst, was ich genau messen soll, kann ich mal ein Ründchen den Filer anwerfen. Und wo du einen (zugegebenermaßen recht langsam getakteten) 8C16T Skylake planst, hechelt bei mir ein 3M6T Vishera, der FX-6300, um genau zu sein. Wenn der dem Skylake da auch nur die Reste vom Teller zieht, läuft irgendwas verkehrt. lz4 ist bei mir auch noch an...

  11. #8860
    Oberstabsgefreiter
    Registriert seit
    16.04.2012
    Beiträge
    408


    Standard

    Zitat Zitat von gea Beitrag anzeigen
    In der akltuellen 18.09dev habe ich für min, hour und day die Option every/n1;n2 (ausser) hinzugefügt.
    Ein Bug bei der Erkennung von size=0 (bis auf neuesten Snap) ist ebenfalls behoben.
    Habe unter "day" manuell nun "tue-sun" eingetragen. Allerdings führt er dann den Job dennoch auch am "mon" aus. Kann man das auch irgendwie unter 18.01 so hinbekommen dass es funktioniert?

    snap ssdpool/daten keep 30 daily del zero, hld 8 - every tue-sun 0 0 1528205817 active 18.jun 00 00 - run now delete
    eigentlich hätte er diesen job heute nicht ausführen dürfen.
    Geändert von CommanderBond (18.06.18 um 00:31 Uhr)

  12. #8861
    Gefreiter
    Registriert seit
    07.12.2013
    Beiträge
    44


    • Systeminfo
      • Motherboard:
      • ASUS Z97-WS
      • CPU:
      • i7 4790K
      • Kühlung:
      • Custom Loop
      • Gehäuse:
      • Lian Li PC-A77
      • RAM:
      • 32GB, DDR3L-1600, CL9-9-9-24
      • Grafik:
      • Titan X (Pascal)
      • Storage:
      • SSDs (8TB) + 2 NAS (32TB)
      • Netzteil:
      • be quiet! DPP 10 550W
      • Betriebssystem:
      • Windows 10

    Standard

    @Bzzz: Danke, das war die Info die ich haben wollte. Das klingt für mich danach, als wäre eine Messung nicht notwendig. Oder hast du die Möglichkeit ein schnellen SSD Pool oder eine RAMDisk einmal mit und einmal ohne Verschlüsslung auf Latenz zu testen? Das wäre das einzige was mich noch interessiert. Allerdings glaube ich nicht, dass das meine Wahl der CPU ändern würde, da die besseren Optionen einfach zu teuer sind.

    Die 10GBit/s sollte mein Storage liefern können. Es werden 2 Pools:
    Einmal 24 HDDs als 4x6 Z2, wobei ich für den Anfang nicht alle HDDs kaufen werde, wahrscheinlich nur 12 oder 18.
    Der zweite Pool ist noch nicht fertig geplant und wird auch erst später gekauft, aber wird aus SSDs bestehen. Da ist das Thema IOPS und Latenzen relevant, da ich Daten die ich aktuell lokal auf SSDs habe aufs NAS verlagern möchte.

  13. #8862
    gea
    gea ist offline
    Fregattenkapitän
    Registriert seit
    16.11.2010
    Beiträge
    2.995


    Standard

    Zitat Zitat von CommanderBond Beitrag anzeigen
    Habe unter "day" manuell nun "tue-sun" eingetragen. Allerdings führt er dann den Job dennoch auch am "mon" aus. Kann man das auch irgendwie unter 18.01 so hinbekommen dass es funktioniert?
    eigentlich hätte er diesen job heute nicht ausführen dürfen.
    Eine Angabe wie tue-sun wird nicht unterstützt und könnte man allenfalls selber (Zeile ca 200) integrieren in
    /var/web-gui/data/napp-it/zfsos/_lib/scripts/auto.pl

    Ansonsten werden in 18.01 nur gravierende Sachen rückportiert (wie die Unterstützung von Solaris 11.4 oder OmniOS 151026 die später kamen). Alles andere ist nicht machbar da napp-it mit OmniOS, OpenIndiana und Solaris drei Betriebssysteme unterstützt, die sich laufend weiterentwickeln, ihr Verhalten leicht ändern oder neue Features integrieren. Anpassungen daran und kleinere Bugfixes gibts nur in der aktuellen dev Version und dann mit Verzögerung in der jeweiligen Pro oder Free Version.

  14. #8863
    Oberstabsgefreiter
    Registriert seit
    30.03.2005
    Beiträge
    430


    Standard

    Liebe Gemeinde,
    zig-Stunden Frust und Erkenntnisse möchte ich dann doch mal hier teilen bzw. los werden.
    Die "Ideal-Lösung" für ein Napp-IT/ZFS-full-featured lautet ja Solaris11.4+Napp-It. Wahlweise innerhalb ESXi oder Bare-Metal.

    Nun zum Denverton C3578, anhand Supermicro A2SDi-H-TF:
    1) ESXI 6.50, 6.5U2, 6.7: Es gibt immer noch keine Unterstützung für die Onboard-10GBase-T-NIC. Spanndenderweise ist der Kernel von 6.5u2 "neuer" als der von 6.7 - hilft nur nix. Erneut zeigt sich, wie eingeschränkt eine ITX-Wahl ist, wenn man eine zusätzliche NIC benötigt UND einen SAS-Adapter. Ich hatte über alle Internetquellen hin versucht, einen Treiber zu bekommen. Jedoch ist mangels offener Quellen für ESXi auch ein Eigenbau mithilfe Toolchain nicht möglich - ich habe zumindest nichts dazu gefunden für 6.5u2/6.7. Ein angebotener Treiber im Netz von Privat verursacht in allen drei getesteten Versionen einen Absturz und scheint damit inkompatibel. Der Versuch, die onboard-NIC zum Laufen zu bekommen hat mich zwei volle Wochenendtage gekostet. Weder Supermicro noch VMWare fühlen sich für die Treiber zuständig (nach Support-Kontakt...).

    2) Bare-Metal-Solaris: Kein NIC, keine Installation möglich.

    3) Proxmox V5.2: Installiert sich problemlos, die Hardware wird vollständig erkannt und ist nutzbar.

    3a) Proxmox + Solaris: Leider ist es immer noch unmöglich, PCIe-Passthrough mit Solaris (und OI) zu betreiben. Leider gehen sowohl VirtIO als auch der SCSI-Treiber mit simuliertem SCSI-Adapter in Solaris nicht - es gibt keine nutzbaren HDDs. IDE/SATA möchte ich aufgrund der zu erwartenden Leistungsprobleme nicht.

    3b) Proxmox + OI 18.04 Hipster: OI hat im Gegensatz zum Original-Solaris eine anscheinend funktionierende Unterstützung für VirtIO-Geräte, so dass man wenigstens per HDD-Passthrough (PCIe-PT geht hier auch nicht) die HDD-devies (by-id) durchreichen kann. Auch die NIC-Bridge kann per VirtIO bereitgestellt werden und läuft. Nachteil: "nur" HDD-Passthrough = suboptimal.

    Da mich eigentlich das ZRaid-Grow und die embedded Verschlüsselung interessieren wollte ich das original-Solaris. Nur leider ist das Mainboard bis auf Weiteres inkompatibel. Die "OI"-Lösung ist daher schon per-se eine second-best-solution. Die aktuell teilweise als alpha/beta erhältlichen ZFSoL-Pakete sind für einen Fileserver mit 50TB eher nicht so mein Ding...

    Gibt es noch Tipps? Gea?
    Spoiler: Anzeigen

  15. #8864
    gea
    gea ist offline
    Fregattenkapitän
    Registriert seit
    16.11.2010
    Beiträge
    2.995


    Standard

    Es gibt eine eherne Regel

    Sobald man von Windows und schon mit Einschränkungen Linux weggeht
    hin zu Unix (BSD, OSX, Solarish) oder ESXi so sollte man nur das nehmen was

    1.) üblich und erprobt ist
    2.) nicht das neueste ist

    Da die Probleme meist im Breich Netzwerk- und Plattentreiber liegen, so kann man üblicherweise alternativ einen PCI-e Adapter einstecken bis ein Treiber für Onboardgeräte verfügbar ist. Bei iTX ist das verwehrt. Ich würde daher immer ITX meiden und wenigstens Flex-ATX oder uATX nehmen.

    Für ein AiO System ist die Idealkonfiguration immer Sata für ESXI (ESXi boot + local datastore) und ein BroadCom/LSI SAS HBA. Diesen SAS HBA kann man problemfrei komplett an eine Storage VM durchreichen oder daran angeschlossene Sata/SAS Platten einzeln in den VM-Einstellungen per Disk > Add: Raw einer beliebigen VM hinzufügen (sogar mehreren für HA Setups).

    Mit einem M.2 Port könnte man zwar versuchen, ESXi + local datastore auf die M.2 zu legen um Sata an die Storage VM durchzureichen, das ist aber außerhalb dessen was immer und sofort funktioniert.

    Das Board ist also für das Vorhaben eher ungeeignet oder zumindest "suboptimal".
    Das Einzige was geht (bis ESXi einen Treiber hat, sollte mittelfristig der Fall sein) ist eine PCI-e Netzwerkkarte und physical RDM der Sata Platten oder Booten von M.2 und Pass-through von Sata (sofern das nicht zickt.)

  16. #8865
    Gefreiter
    Registriert seit
    19.03.2018
    Beiträge
    46


    • Systeminfo
      • Motherboard:
      • Supermicro X11SSH-LN4F
      • CPU:
      • Intel Xeon E3 1225v6
      • Gehäuse:
      • Intertech 4U4408 19"
      • RAM:
      • Kingston 16GB UDIMM ECC
      • Storage:
      • Corsair MP500 480GM NVMe SSD
      • Netzteil:
      • Cooler Master V Series V550
      • Betriebssystem:
      • ESXi 6.5

    Standard

    Da mir in "meinem" Thread (Tipps zu Homeserver Virtualisierung / Strukturierung - Seite 3) bislang noch niemand einen Tipp geben konnte bzgl. einer sinnvollen Strategie, mit meinen vorhandenen Platten einen ZFS Pool aufzusetzen, versuche ich mein Glück mal hier. Andernorts sind Doppelposts verpönt / nicht gewünscht und falls das hier auch so sein sollte, dann bitte ich vielmals um Entschuldigung - dann dürfen die Moderatoren diesen Beitrag hier gerne löschen

    Vorgeschichte: Ich baue einen per ESXi virtualisierten Server neu auf, als Storage VM kommt napp-it zum Einsatz. Da bin ich noch recht weit am Anfang. ESXi läuft im Wesentlichen, napp-it ist installiert. Einige der verfügbaren Platten sind noch in Benutzung, andere nicht. Ziel ist es, eine Storage VM bereitzustellen und wieder eine Backup-Platte (möglichst extern) zu haben. Auf dem NAS schlummern überschaubare rd. 950GB an Daten, weitere knapp 500 GB liegen auf dem abzulösenden VDR. Insgesamt stehen folgende Platten zur Verfügung:

    * 4x 500GB (Western Digital)
    ** 2x stecken schon im Server
    ** 1x noch im alten NAS, könnte dort raus und in den Server
    ** 1x noch im alten VDR, sollte da möglichst noch verbleiben
    * 2x 2TB (Hitachi)
    ** 1x noch im alten NAS => Da sind derzeit sämtliche Daten drauf. Ist somit zunächst einmal die Quelle für die Initialbetankung des neuen Servers und steht erst danach zur Verfügung
    ** 1x als Backup Platte. Backup aus Gründen nicht ganz aktuell, aber das Delta seit dem letzten erfolgreichen Backup ist gering.

    Frage: Macht es überhaupt Sinn, mit diesen Platten loszulegen? Ich bin durchaus bereit, bei Gelegenheit nochmal in neue Platten zu investieren. Dann werden es auch ausreichend große und viele gleichartige Platten werden. Aber ob ich den Tausender noch in diesem Jahr springen lasse... weiß nicht.

    Welche Konfiguration bzw. Vorgehensweise wäre aus Eurer Sicht sinnvoll, um mit den vorhandenen Platten einen neuen Pool anzulgegen, die Daten vom NAS (und später vom VDR) rüber zu migrieren und anschließend beide 2GB Platten mit zu nutzen (eine davon als Backup Platte im externen USB Gehäuse)? Wie ich gelesen habe, muss ich mich von vornherein entschließen, ob ich einen Basic Pool, ein RAIDZ1 oder ein RAIDZ2 haben möchte. Außerdem ist es wohl ungünstig (no go?) im Nachhinein eine einzelne Platte zum Pool hinzuzufügen. Ist das richtig?

    Meine Überlegung war, jetzt einen Pool mit den 500 GB Platten (drei?) anzulegen, wegen mir noch die 2TB Backup Platte mitzunutzen, die Daten vom NAS zu migrieren und nach erfolgreicher Migration die bislang produktive 2TB Platte aus dem NAS als Backup Platte weiter zu nutzen. Ist diese Vorgehensweise sinnvoll? Und kann ich die drei 500GB Platte sinnvoll mit einer 2TB Platte kombinieren, oder bleiben da von vornherein 1,5 TB auf der 2TB Platte ungenutzt? Hmm, da sind bei mir noch viele Fragezeichen...

    Wäre nett, wenn mir jemand hier möglichst konkrete Tipps, auch zur Vorgehensweise geben könnte.

    Und wie gesagt: dieser Beitrag kann gerne wieder raus genommen werden, es ist immer noch mein Originalthread mit der gleichen Frage offen und wartet auf Rückmeldungen Thanx,folks!

  17. #8866
    Oberstabsgefreiter
    Registriert seit
    30.03.2005
    Beiträge
    430


    Standard

    @gea: Ich nutze in der Tat Linux seit über 15 Jahren und hatte seit fast genauso lange keine Probleme mehr mit NIC-Treibern... Da hatte ich schlicht nicht dran gedacht. Ansonsten alles nach bewährter Methode: H310 auf IT geflasht, besterinos SAS-Expander (ohne PCIe-Slot-Notwendigkeit), XCase 16-Hotswap 19"-3U-Gehäuse und 48GB RegECC RAM. Es sah so gut aus ;(
    In OpenIndiana/Proxmox ist das Napp-IT saaaaauuu langsam (2h für "processing" bis - vermutlich - alle Menüpunkte da sin...).
    Ich steige wohl doch mit diesem Board wieder auf mein altbewährtes Ubuntu inkl. [email protected]
    Also liebe Leute: "NappIT || Denverton"

    edit: btw, OI mit GUI bare-metal kommt bei Installations-Booten nicht über die ersten drei Zeilen hinaus... :/
    Geändert von danielmayer (19.06.18 um 15:28 Uhr)
    Spoiler: Anzeigen

  18. #8867
    gea
    gea ist offline
    Fregattenkapitän
    Registriert seit
    16.11.2010
    Beiträge
    2.995


    Standard

    Zitat Zitat von kandamir Beitrag anzeigen

    Meine Überlegung war, jetzt einen Pool mit den 500 GB Platten (drei?) anzulegen, wegen mir noch die 2TB Backup Platte mitzunutzen, die Daten vom NAS zu migrieren und nach erfolgreicher Migration die bislang produktive 2TB Platte aus dem NAS als Backup Platte weiter zu nutzen. Ist diese Vorgehensweise sinnvoll? Und kann ich die drei 500GB Platte sinnvoll mit einer 2TB Platte kombinieren, oder bleiben da von vornherein 1,5 TB auf der 2TB Platte ungenutzt? Hmm, da sind bei mir noch viele Fragezeichen...
    Der beste Rat wird wohl der sein, den Pool strukturell so anzulegen wie man ihn später mal haben möchte. Wenn man also auf einen Raid-Z2 Pool möchte, dann z.B. eine Pool aus 6 Platten aufbauen (wobei die kleinste Platte aktuell die Kapazität vorgibt) oder aber einen Raid-10 Pool aus 4 bzw 6 Platten erstellen. Wenn man dann später die kleinen Platten ersetzt wird die volle Kapazität genutzt. Bei Raid-10 kann der Pool einfach jeweils mit zwei Platten als Mirro wachsen.

    Einen Pool umzustrukturieren ist momentan noch nicht so einfach. Lediglich das neue Solaris 11.4 beherrscht das Entfernen beliebiger vdevs und das Erweitern eines vdevs um einzelne Platten kommt frühestens Ende des Jahres bei Open-ZFS.

    - - - Updated - - -

    Zitat Zitat von danielmayer Beitrag anzeigen
    @gea: Ich nutze in der Tat Linux seit über 15 Jahren und hatte seit fast genauso lange keine Probleme mehr mit NIC-Treibern... Da hatte ich schlicht nicht dran gedacht. Ansonsten alles nach bewährter Methode: H310 auf IT geflasht, besterinos SAS-Expander (ohne PCIe-Slot-Notwendigkeit), XCase 16-Hotswap 19"-3U-Gehäuse und 48GB RegECC RAM. Es sah so gut aus ;(
    In OpenIndiana/Proxmox ist das Napp-IT saaaaauuu langsam (2h für "processing" bis - vermutlich - alle Menüpunkte da sin...).
    Ich steige wohl doch mit diesem Board wieder auf mein altbewährtes Ubuntu inkl. [email protected]
    Also liebe Leute: "NappIT || Denverton"

    edit: btw, OI mit GUI bare-metal kommt bei Installations-Booten nicht über die ersten drei Zeilen hinaus... :/
    Für neue Intel Nics kommen angepasste Treiber für Unix und ESXi meist "relativ" zeitnah. Da sollte eine Lösung absehbar sein. Die Unterstützung von Unix unter Proxmox dürfte bei weitem nicht so gut sein wie unter ESXi (da wird ja von BSD über Linux, OSX, Solaris bis Windows alles bestens unterstützt, man muss sich aber an die HCL halten)

    Wenn OI beim Installieren hier hängt, liegt es meist an nicht gefiúndener Hardware (warten bis zum Timeout, kann auch mal 10Minuten dauern) oder aber an USB Problemen. Wenn das Board unterschiedliche USB (v2/v3) hat, mal USB2 versuchen. Eine andere Option ist es, im Bios nach den USB Einstellungen zu schauen, vgl SuperMicro X11 SPH-nCTPF/ nCTF on OmniOS/OI/Solaris | ServeTheHome and ServeThe.Biz Forums

    Teilweise ist auch OmniOS das den BSD Loader nutzt beim Booten etwas unkritischer als OI bei neuer Hardware. Auch unterstützt OmniOS LX/Linux Zonen (Linux Virtualisierung unter Solaris, übernommen aus SmartOS/Joyent). Da gibt es aber dafür keine Desktop Version

  19. #8868
    Gefreiter
    Registriert seit
    19.03.2018
    Beiträge
    46


    • Systeminfo
      • Motherboard:
      • Supermicro X11SSH-LN4F
      • CPU:
      • Intel Xeon E3 1225v6
      • Gehäuse:
      • Intertech 4U4408 19"
      • RAM:
      • Kingston 16GB UDIMM ECC
      • Storage:
      • Corsair MP500 480GM NVMe SSD
      • Netzteil:
      • Cooler Master V Series V550
      • Betriebssystem:
      • ESXi 6.5

    Standard

    Zitat Zitat von gea Beitrag anzeigen
    Der beste Rat wird wohl der sein, den Pool strukturell so anzulegen wie man ihn später mal haben möchte. Wenn man also auf einen Raid-Z2 Pool möchte, dann z.B. eine Pool aus 6 Platten aufbauen (wobei die kleinste Platte aktuell die Kapazität vorgibt) oder aber einen Raid-10 Pool aus 4 bzw 6 Platten erstellen. Wenn man dann später die kleinen Platten ersetzt wird die volle Kapazität genutzt. Bei Raid-10 kann der Pool einfach jeweils mit zwei Platten als Mirro wachsen.

    Einen Pool umzustrukturieren ist momentan noch nicht so einfach. Lediglich das neue Solaris 11.4 beherrscht das Entfernen beliebiger vdevs und das Erweitern eines vdevs um einzelne Platten kommt frühestens Ende des Jahres bei Open-ZFS.
    Danke, @gea! D.h. also, dass mit Raid-Z2 oder Raid-Z1 ein schrittweiser Aufbau nicht wirklich möglich sein wird, also z.B. zu einem späteren Zeitpunkt noch eine der 500GB Platten dazu zu nehmen, richtig? Und bei einem Raid10 halbiere ich den Plattenplatz im Vergleich zu den eingesetzten Platten. Dafür könnte ich aber immer zwei Platten ergänzen, die für sich als Mirror arbeiten und den vorhandenen Pool per Striping erweitern. Auch richtig?

    Würde denn folgende Konfiguration möglich und sinnvoll sein? Zunächst ein Stripeset aus 4x 500GB = 2TB, welches dann mit einer der 2TB Platten einen Mirror bildet? Das wäre dann ein RAID01? Damit hätte ich 2TB Speicherplatz zur Verfügung bei einfacher Ausfallsicherheit (wann immer eine Platte, egal welche ausfällt, federt der Mirror den Ausfall dieser einen Platte ab). So richtig bildet das meine Wunschkonfiguration nicht ab, aber ich könnte zunächst das Stripeset aus den 500GB Platten bilden, die Daten von der produktiven 2TB Platte via NFS rüber kopieren und anschließend meine 2TB Backup Platte umwidmen als Mirror zum Stripeset. Sobald der Mirror aktiv ist, wären die Daten dreimal vorhanden (Stripeset, Mirror und ursprüngliches Original). Ab dann könnte ich die dann ehemals produktive 2TB Platte zur Backup Platte umwidmen und hätte zu keiner Zeit die Gefahr von Datenverlust wegen Plattenausfall. Aber ich fürchte, das klappt so nicht, oder?

  20. #8869
    gea
    gea ist offline
    Fregattenkapitän
    Registriert seit
    16.11.2010
    Beiträge
    2.995


    Standard

    Zitat Zitat von kandamir Beitrag anzeigen
    Aber ich fürchte, das klappt so nicht, oder?
    Klappt in der Tat so nicht (ZFS unterstützt das so nicht ohne Umwege).

    Ein ZFS Pool besteht aus vdevs. Das sind quasi eigenständige Raid Arrays aus Basic (Raid-0), Mirror oder Raid-Zn. Diese vdevs werden grundsätzlich als Raid-0 verknüpft. Zwei vdevs lassen sich nicht spiegeln.


    Die einzige Möglichkeit das doch zu erreichen wäre etwas komplizierter.
    Man könnte einen Raid-0 Pool aus den 4 x 500G Platten machen und den komplett als iSCSI Target freigeben.

    Dieses Target könnte man dann als 2 TB Platte mounten und mit einer physikalischen 2TB Platte spiegeln um daraus ein raid-1 vdev bauen. Das wäre über Umwege das Spiegeln der 2TB Platte mit einem 4x500 MB Array.

    Das widerspricht aber dem KISS Prinzip für problemfreie Technik.
    Sollte man allenfalls als Übergangslösung machen bis man eine zweite 2TB Platte hat um das iSCSI Target damit zu ersetzen.


Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •